W32tm

I have a member server and when I enter w32tm /stripchart /compuiter:IP the time returned is +.05.  On other member servers I enter the same command and it is -.01 and less.  This member server is a part of a cluster.  Does anyone know of any additional troubleshooting that I can do to figure out why the time is so far off on this server. I have compared both servers registry settings and they are the same.  Does the cluster service impact the time sync on the active node?
boydosborneAsked:
Who is Participating?
 
RichardWltenburgConnect With a Mentor Commented:
on your DC (needs to be the one with PDC Emulator. (find in ADUC right click on your domain then Operation Masters)

Use in command "w32tm /query /status" (without the """ )  to see what is status.

log on to the server with the PDC emulator.

command:
w32tm /config /manualpeerlist:time.windows.com /syncfromflags:manual /reliable:yes /update
net stop w43time
net start w43time
now when a computer is connected to the domein it will automaticly get the time.

in case settings were changed on a client you can change it by

w32tm /config /syncfromflags:domhier /update
net stop w32time
net start w32time


to resync the time:
w32tm /resync

hope this will work. make sure port 123 (NTP) is open on firewalls.
0
 
markdmacCommented:
Time is kept on the motherboard by running a current through a crystal which then resonates at what is supposed to be a set interval.  Being a product of nature the crystals sometimes don't cooperate.  You could try forcing a time sync daily on that machine to keep it in check or you may find you need to replace the motherboard.

Cluster services have never caused me any issues with time sync and it is super important that all nodes have the same time.
0
 
boydosborneAuthor Commented:
I was thinking the Crystal was only for local time sync and was not considered when configuring network Time sync.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
boydosborneAuthor Commented:
If I run the w32tm /stripchart /computer:IP Address the offset returned is +.07.  Is there any setting that I can configured to resolve this issue?
0
 
markdmacCommented:
What do you get when you query the SNTP server?

NET TIME /QUERYSNTP

You can set the server to be the same as the other servers with

NET TIME /SETSNTP:SERVERNAME
0
 
boydosborneAuthor Commented:
I receive "this computer is not currently configured to use a specific SNTP server."
0
 
boydosborneAuthor Commented:
This member server is part of a cluster, just for additional information.
0
 
Jim P.Commented:
You may neet to reconfigure your w32time service. I have the setup at work.
0
 
boydosborneAuthor Commented:
If you could send that to me I would greatly appreciate it.  Thanks
0
 
Jim P.Commented:
Try running this from a cmd prompt.

w32tm /config /syncfromflags:domhier /update
net stop w32time
net start w32time

Open in new window

0
 
boydosborneAuthor Commented:
We have ran this command on both servers.  The time issue appears to be on the active node.
0
 
boydosborneAuthor Commented:
Is there any other option out there? I have used the following commands and nothing has fixed the issue.  Any other idea would be greatly appreciated.

net stop w32time
w32tm /unregister
w32tm /register
net start w32time
0
All Courses

From novice to tech pro — start learning today.