[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 785
  • Last Modified:

Windows 2003 Server Winsock/TCPIP Problem

  I used Acronis Echo Server to image a 2003 server from an old Compaq Proliant ML380 over to a new Dell T310. All went well (kind of). The 310 booted and I started installing the new drivers. Everything installed with the exception of the Broadcom drivers. It gave me an error about not being compatible with the currently installed software. I tried installing directly from the INF files (and bypassing their setup.exe program) and the NIC driver installed but with a yellow exclimation through it. Of couse Dell support was a total waste of time (I won't go in to detail :))

   I then ordered and installed an Intel Pro/1000 PT adapter. It installed without a hitch but...  no internet. If did the good old ipconfig /all and got absolutely noting back. No IP. I have been trying to do WInsock fixes and everything else. Nothing seems to work. I need to reset Winsock and TCP/IP from ground zero but can seem to get that accomplished.

Help!
0
jimbecher
Asked:
jimbecher
  • 2
2 Solutions
 
youngj06Commented:
Is the LAN port that exists already an onboard one?
It may be worth disabling the online card through the BIOS in case there is a conflict.

Also did the old sever have a static IP address set? Try setting the new adaptor to the same IP addres/subnet/DNS settings as the old server in case it is not picking up DHCP (if you have it).
0
 
Kevin_LeadbeaterCommented:
To reset the IP stack, your best option is to completely remove all services, protocols and adapters.  Go into control panel, and choose properties of the local area connection.  uninstall the tcp/ip stack, as well as the Client and Service entries (uninstall everything you can).  Then go to device manager and remove all of the network adapters, also removing the drivers.  Reboot, and all being well Windows should re-detect the hardware, and prompt for you to install drivers again, and it should recreate the IP stack.
0
 
jimbecherAuthor Commented:
  I disabled the on-board NICs when I put the Intel in. The first thing I tried doing was un-installing everything in the Local Area Connection. TCP/IP did not giveme the option to un-install. When I rebooted at that poing the sever kept rebooting. I don't hink it like me unistalling the Microsoft Client...
0
 
Kevin_LeadbeaterCommented:
My mistake, to reset TCP/IP in Windows Server 2003, do it from the command line:

netsh int ip reset

http://support.microsoft.com/kb/317518


Also, maybe useful to know, is the fact that device manager doesn't list all of the adapters that are actually installed, some are hidden from that list - to remove all of them (including any ghost entries) try the trick here.

   1. Click Start, click Run, type cmd.exe, and then press ENTER.
   2. Type set devmgr_show_nonpresent_devices=1, and then press ENTER.
   3. Type Start DEVMGMT.MSC, and then press ENTER.
   4. Click View, and then click Show Hidden Devices.
   5. Expand the Network Adapters tree.
   6. Right-click the dimmed network adapter, and then click Uninstall.

http://support.microsoft.com/kb/269155
0
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now