Can you use WIX with Dotfuscator?

I am using the Dotfuscator CE enhanced version in my current solution.  To that end, I added a Dotfuscator project to my solution, added the appropriate project output, and then built the project.  All of that worked without any issues.

I then went to modify my WXS file in my WIX project to point to the new EXE and DLLs required to run my application.  While the installation worked fine, the EXE would not run.  I then copied the Map.xml file into the deployment folder and that did not help either.

Can somebody please help me understand how to deploy a Dotfuscated EXE with WIX?

Thanks!
ktolaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike_MozhaevCommented:
Dotfuscated exe starts just as a non-obfuscated one. And it has nothing to do with WiX.
Most probably some dependent assemblies are missing. Or there are some configuration problems.
Open your assembly in reflector and see what assemblies are referenced.
Or you can use fuslogvw.exe (from .NET SDK) to see assembly binding failures.

Does you application work being started from your working folder?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ktolaAuthor Commented:
As it turns out there is something wrong with Dotfuscator and assemblies signed with a PFX file.  The Dotfuscator people are trying to help out but I would love to hear from anybody who has had similar issues...
0
ktolaAuthor Commented:
As it turns out, Dotfuscator does not work with password-protected signing (i.e. PFX files).  Once I took that out and enabled the Built-In rules for the options I chose, everything worked properly.
0
ktolaAuthor Commented:
Thanks for trying to help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.