Error Upgrading From Exchange Server 2007 SP1 to SP2

Server Role Topology:
Two physical servers running both CAS and HT server roles (CASHT1+CASHT2)
Two physical servers running mailbox server roles in cluster (SCC, MBXCN1+MBXCN2)
All servers run on Windows Server 2008 SP2

I've tried upgrading to SP2 on either CASHT server with the same error on both. The same error is thrown when attempting an upgrade via CLI.

Exchange Setup Log has the following output:

[3/27/2010 9:42:13 AM] [1] Preparing to output objects. Maximum result set size "unlimited".
[3/27/2010 9:42:13 AM] [1] Ending processing.
[3/27/2010 9:42:14 AM] [1] [ERROR] Setup cannot continue with the upgrade because the 'exsetupui' (Exchange Server 2007 SP2 Setup) process (ID: 5060) has open files. Close the process and restart Setup.
[3/27/2010 9:42:14 AM] [1] [ERROR] Setup cannot continue with the upgrade because the 'setup' () process (ID: 3940) has open files. Close the process and restart Setup.
[3/27/2010 9:42:14 AM] [1] Ending processing.

'exsetupui' is the GUI interface wizard for the actual Service Pack.
'setup' is initiated when the Service Pack begins pre-requisite scans.

I've prepped SCHEMA and AD. I've attempting multiple reboots.

I have a feeling there is a pending operation somewhere in the Registry of the servers...but initial attempts at clearing the error have been unsuccessful. Any help/suggestions would be appreciated.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Go to the following location:-
Check if there is watermark and action dowrd values present under te sub containers
I had this issue while ago, it should be on the setup key or under v14. Need to double check.

Try these:
1.) Make sure EMC or Exchange management shell is not open.
2.) Disconnect other sessions to the server so that you are the only one
3.) Do not store or run SP2 from an Exchange related folder
4.) run /m:upgrade instead
5.) It could be due to corrupt SP2 files so download it and try again:

I think you have already tried number 4, but start from the top and worse case scenario is that you will be doing number 5...
acstechsAuthor Commented:
Thanks for the comments guys.

Terminate: I see Microsoft\Exchange\setup and Microsoft\Exchange\v8.0\setup ... but nothing obvious within those keys as far as what to do. Both keys pretty much have the same content:

CurrentBuild DWORD
MsiBuildMajor DWORD
MsiBuildMinor DWORD
MsiInstallPath String
MsiProductMajor DWORD
MsiProductMinor DWORD
NewestBuild DWORD
Required machine-level settings DWORD
Services String

What should I be seeing? No v14 key either.

1) EMC / Shell was definately not running.
2) This was done as well. I had rebooted the server and was on a console/KVM connection.
3) SP2 was unpacked to the root of C and I was running it from there....this is not the exchange install folder or an exchange-related folder.
4) tried that. same error.
5) I had already re-downloaded and extracted the service pack before hitting the same issue.

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Hmmm, re install SP1 then install SP2.
Or uninstall SP1 then install SP2
Do you have any anti-virus software on there, if so, disable/uninstall it and try SP2 again
acstechsAuthor Commented:
No AV is installed on these nodes at this time. They are new builds with Exchange SP1 installed. Un-installing SP1 would require removing Exchange completely.
Download SP1, re-apply it. then install SP2
acstechsAuthor Commented:
Looks like we'll be placing a call with MS to resolve our SP2 woes.
Hopefully it will be a free call.
acstechsAuthor Commented:
Unfortunately, it was not a free call...but the issue is resolved.

MS Tech Support stated that in some environments they have seen this error. The recommendation is to copy/run the SP2 setup from another local disk. Since my CASHTs only have one partition, this was not possible. What I ended up having to do was copy the SP2 folder to a network location, map a drive, and then run the setup from there. By doing this, instead of the service pack simply executing the files, it must first extract the files to the local server, and THEN execute. Wherever the files were written must have been a different location, because once I did that, it was all good.

I've repeated these steps on my other CASHT and that worked fine as well.

I ran SP2 on our 2-node SCC cluster (recently rebuilt physical servers) and did not run into this error.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Thanks for the update. Glad U got it working.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.