How do i make asterisk transer an incoming call to IVR with extension 7000?

Hi,

I have installed Asterisk PBX from Debian Lenny 5.0.4 repository and compiled WEB GUI 2.0 on it.

My problem is that when people call in, they get hung up on by the asterisk because and asterisk outputs:
[Apr  1 02:42:15] NOTICE[7190]: chan_sip.c:14441 handle_request_invite: Call from '' to extension '7000' rejected because extension not found.

Here is my register string (the X's are just censored numbers for my privacy):
register => 85XXXXXX:XXXXXXX:4785XXXXXXX@sip.phonzo.com/7000

If I use a SIP phone on my Asterisk server; e.g extension 6000 i can call IVR 7000 without problems and navigate the menu.

Thanks for any help.
LVL 1
us-pataAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
us-pataConnect With a Mentor Author Commented:
I fixed it myself.
I just added include voicemenus to default and it all worked out =D
[default]
include = voicemenus

Open in new window

0
 
jfaubiontxCommented:
An IVR with a number of 7000 is not the same as an extension. Your register string is attempting to associate your sip trunk to extension 7000 which doesn't exist. Either add extension 7000 or change your register string to point the trunk to extension 6000.
0
 
us-pataAuthor Commented:
But how to i achieve my goal of people getting right to the IVR menu? I dont want it to ring directly to a phone because we have sevral departments.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
koffuCommented:
When you define SIP account to register, you should define in sip.conf:

register => fromuser@fromdomain:secret:authuser@host:port/extension

[sipprovodername]
context=incomingcontext

first is needed to force asterisk to register on remote server.
second definition is needed for some connection settings, as context, codecs, etc.

so when incoming call will come, asterisk will try to search "/extension" in "incomingcontext".

Without this asterisk will try to found 7000 in "incoming", which will be default in [general] of sip.conf.
0
 
jfaubiontxCommented:
The solution us-pata provided is a secondary fix for the problem he had. His recommendation is not really a solution.
0
 
larrytousCommented:
us-pata:

Here is a more real solutions.... if your incoming calls are going to context [inbound] then create the extension for the incoming number, answer it and send it to your ivr context.

[inbound]
exten => 3035554444,1,Answer
exten => 3035554444,2,Goto(custom-ivr,s,1)

[custom-ivr]
exten => s,1,Background(custom-ivr-english)
0
All Courses

From novice to tech pro — start learning today.