Rmagick - ImageMagick configuration problem

Hi folks.

I tried to do an install of Rmagick using Macports, and got errors.  then i did an install of ImageMagick using Git and that seemed to be ok.

I'm working on a rails cms project, and when i try for a rake db:setup or rake gems:install, I get

"rake aborted!
This installation of RMagick was configured with ImageMagick 6.5.9 but ImageMagick 6.5.8-10 is in use."

How to i get rid of the old version of ImageMagick (if thats the actual solution)?

John HGeneral TinkererAsked:
Who is Participating?
Andrew DoadesConnect With a Mentor IT TechnicianCommented:
I think, as you've installed from Git, you should be able to just delete the ImageMagick folder, where Git put it?

Then install the "6.5.9"

Most system package managers come with ImageMagick, this is how I installed it.

I ran into this problem on a Arch Linux box, but I just used the package manager to uninstall the older version.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.