SBS 2003 companyweb will not load on IE but will on Firefox

Hi,

As the title states, I can't open companyweb from any computer or even the server if I use IE, but I can if I use Firefox. It would always come up with:

***********************
You are not authorized to view this page
You do not have permission to view this directory or page using the credentials that you supplied.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator if you believe you should be able to view this directory or page.
Click the Refresh button to try again with different credentials.
HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Authentication, Access Control, and About Custom Error Messages.
***********************

It would ask me for username and password, just as it is when I use Firefox, but when I put in the same credential (using domain Administrator account), it would open companyweb in Firefox but not IE.

I have tried updating IE 8 with the latest update. I even tried uninstalling IE 8 and use IE 7 but companyweb still won't load.

Any ideas?
LVL 2
astrosbsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael OrtegaSales & Systems EngineerCommented:
That's odd. From Firefox can you actually navigate around through CompanyWeb without it continually prompting you for credentials or improperly loading the page?

MO
0
astrosbsAuthor Commented:
Yes I can navigate fine without being interrupted by credential prompts.

One thing that I notice is that when I type companyweb (in both IE and Firefox), it would redirect me to companyweb/default.htm instead of companyweb/default.aspx. And that default.htm page is someone else's calendar. But if I manually go to companyweb/default.aspx it would take me to the right companyweb page.
0
astrosbsAuthor Commented:
OK I think I might have partially fixed the issue. It seems like it's caused by wrong DNS configuration on the client computers. It's now fixed. Just one thing that still confuses me is that redirection issue to default.htm instead of default.aspx. I don't want people to see this person's calendar when they go to companyweb.

How do I change the default page to default.aspx?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Michael OrtegaSales & Systems EngineerCommented:
Look at your site in IIS. I bet somehow the companyweb site is using default.htm as the default document for the site.

MO
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.