How to forward RDP port in Cisco 5500 using ASDM

Hello,

A cisco newbie needing some help with getting 3389 forwarded to a internal IP which I think is properly NATed with a .31 public IP.  I have created the services all using ASDM and still can not use remote desktop on the server im trying to open up.  Below is a running config.  Any help is much appreciated!



: Saved
:
ASA Version 7.2(4)
!
hostname router
domain-name OIS.local
enable password
passwd
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.199 255.255.255.0
 ospf cost 10
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 24.x.x.30 255.255.255.248
 ospf cost 10
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp
 ospf cost 10
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name xxx.local
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service SBS tcp
 description Ports for Small Business Server
 port-object eq 3389
 port-object eq 4125
 port-object eq www
 port-object eq https
 port-object eq 3390
object-group service TS-Ports tcp
 port-object eq 3390
object-group service RDC tcp
 description RDC3389
 port-object eq 3389
access-list outside_access_in extended permit tcp 204.x.x.0 255.255.255.0 host 24.x.x.29
access-list outside_access_in extended permit tcp 24.x.x.192 255.255.255.248 host 24.x.x.29 eq smtp
access-list outside_access_in extended permit tcp any host 192.168.1.11 eq 8888
access-list outside_access_in extended permit object-group TCPUDP any host 192.168.1.231 range 1098 1099
access-list outside_access_in extended permit tcp 216.x.x.0 255.255.255.0 host 24.x.x.29 eq smtp
access-list outside_access_in extended permit tcp 204.x.x.64 255.255.255.192 host 24.x.x.29 eq smtp
access-list outside_access_in extended permit tcp any host 24.x.x.29 object-group SBS
access-list outside_access_in extended permit tcp any host 24.x.x.31 object-group SBS
access-list outside_access_in extended permit tcp 204.x.x.0 255.255.255.0 host 24.x.x.31
access-list outside_access_in extended permit tcp 24.x.x.192 255.255.255.248 host 24.x.x.31
access-list outside_access_in extended permit tcp 216.x.x.0 255.255.255.0 host 24.x.x.31
pager lines 24
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 101 0.0.0.0 0.0.0.0
static (inside,outside) 24.x.x.29 192.168.1.2 netmask 255.255.255.255
static (inside,outside) 24.x.x.31 192.168.1.3 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 24.123.142.25 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 24.x.x.192 255.255.255.248 outside
http 192.168.1.10 255.255.255.255 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 195.168.1.2 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f5157ec1f460b6cc64e46dbcd3f7abf6
: end
asdm image disk0:/asdm-524.bin
asdm location 192.168.1.3 255.255.255.255 inside
asdm location 24.x.x.30 255.255.255.255 inside
asdm location 24.x.x.31 255.255.255.255 inside
no asdm history enable
crucial311Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Istvan KalmarHead of IT Security Division Commented:
HI,

if oyu have 255.255.255.248 host range is: x.x.x.25 - x.x.x.30
so the x.x.x.25 is the default gw, you able to use 26.27.28.29.30

so this line is wrong:

static (inside,outside) 24.x.x.31 192.168.1.3 netmask 255.255.255.255
please use this instead:


static (inside,outside) 24.x.x.28 192.168.1.3 netmask 255.255.255.255
clear xlate


Besides the config is almost good....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pete LongTechnical ConsultantCommented:
Agree if you are adamant you want to use the ADSM see http://www.petenetlive.com/KB/Article/0000077.htm
0
crucial311Author Commented:
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.