Cisco PVST+ VLAN1 ACROSS 802.1Q TRUCK

i have an 802.1q trunk between two switches 2950 3750. I have multiple vlans traversing the truck
but the root bridge for vlan 1 is both switches. Have lowered the priority no change.
THe mac address which is being used by the switch that I do not want to be root for vlan1 is not located on this switch. All other vlans bpdu's are being picked up and the debug shows this.
There is a service provider how is providing an interconnect between the two switches.
Any help would much appreciated
tzeroAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tzeroAuthor Commented:
Sw9 3750  the one that I do no want to be root for V1
Vlan                   Root ID          Cost    Time  Age Dly  Root Port
---------------- -------------------- --------- ----- --- ---  ------------
VLAN0001         45057 0024.9865.cc00         0    2   20  15                  
VLAN0003         32771 0018.1815.ed80        42    2   20  15  Fa1/0/24        
VLAN0008         32776 000a.b836.3280        57    2   20  15  Fa1/0/24        
VLAN0010         32778 000a.b836.3280        57    2   20  15  Fa1/0/24        
VLAN0015         32783 000a.b836.3280        57    2   20  15  Fa1/0/24        
VLAN0016         32784 0019.06b0.2080        38    2   20  15  Fa1/0/24        
VLAN0018         32768 0021.a091.4f60        19    2   20  15  Fa1/0/14        
VLAN0019         32787 0024.9865.cc00         0    2   20  15    


sw2   the switch that i want to be root for the moment

            Vlan                   Root ID          Cost    Time  Age Dly  Root Port
---------------- -------------------- --------- ----- --- ---  ------------
VLAN0001         32769 000a.b836.3280         0    2   20  15                  
VLAN0003         32771 000a.b836.3280         0    2   20  15                  
VLAN0007         32775 000a.b836.3280         0    2   20  15                  
VLAN0008         32776 000a.b836.3280         0    2   20  15                  
VLAN0010         32778 000a.b836.3280         0    2   20  15                  
VLAN0013         32781 000a.b836.3280         0    2   20  15                  
VLAN0015         32783 000a.b836.3280         0    2   20  15                  
VLAN0020         32788 000a.b836.3280         0    2   20  15                  
VLAN0099         32867 000a.b836.3280         0    2   20  15        
0
tzeroAuthor Commented:
sw2

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     000a.b836.3280
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     000a.b836.3280
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/2            Desg FWD 19        128.2    P2p

sw9 VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    45057
             Address     0024.9865.cc00
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    45057  (priority 45056 sys-id-ext 1)
             Address     0024.9865.cc00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/4          Desg FWD 19        128.6    P2p
Fa1/0/23         Desg FWD 19        128.25   P2p
Fa1/0/24         Desg FWD 19        128.26   P2p



0
Nayyar HH (CCIE RS)Network ArchitectCommented:
Try applying the global configuiration command "vlan dot1q tag native" on both switches. I suspect there could be some misforwarding :-) going on ....
0
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

tzeroAuthor Commented:
the 2960 has not got that command available
0
tzeroAuthor Commented:
That command caused spanning tree instability
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
To produce the same effect change the Native VLAN on that interface to an unused VLAN, this will cause VLAN 1 to be tagged as it goes out. Interface Command is "switchport trunk native vlan <unused_vlan-id>"
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
Can you post a schematic?
0
tzeroAuthor Commented:
THe interface already has this command using vlan6 changing this will cause an outage would have to do this out of hours
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
OK, in the meantime please post run config on both sides if possible
0
tzeroAuthor Commented:
sw1
-----------
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime localtime show-timezone
!
hostname sw1
!
logging buffered 200000 debugging
no logging console
!
clock timezone GMT 1
clock summer-time BST recurring
switch 1 provision ws-c3750-24ts
system mtu routing 1500
vtp domain autotest
vtp mode transparent
ip subnet-zero
no ip source-route
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 23,25
!
vlan internal allocation policy ascending
!
vlan 3
 name
!
vlan 6
 name stacking
!
vlan 7
 name DMZ
!
vlan 8
 name
!
vlan 10
 name
!
vlan 11
 name
!
vlan 12
 name
!
vlan 13
 name
!
vlan 15
 name
!
vlan 16
!
vlan 20
 name
!
interface FastEthernet1/0/1
 description
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,6
 switchport mode trunk
 speed 100
 duplex full
 storm-control multicast level bps 1073741
!
interface FastEthernet1/0/2
 description
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,6
 switchport mode trunk
 speed 100
!
interface FastEthernet1/0/3
 description
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,6
 switchport mode trunk
 speed 100
!
interface FastEthernet1/0/4
 description
 switchport mode access
 speed 100
 duplex full
 storm-control broadcast level bps 1677721
 storm-control multicast level bps 1677721
!
interface FastEthernet1/0/5
 shutdown
!
interface FastEthernet1/0/6
 shutdown
!
interface FastEthernet1/0/7
 description
 speed 100
 duplex full
!
interface FastEthernet1/0/8
 shutdown
!
interface FastEthernet1/0/9
 shutdown
!        
interface FastEthernet1/0/10
 shutdown
!
interface FastEthernet1/0/11
 shutdown
!
interface FastEthernet1/0/12
 description interconnect to ww-lon-sw-ts2
 speed 100
 duplex full
 storm-control broadcast level bps 1677721
 storm-control multicast level bps 1677721
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
 shutdown
!
interface FastEthernet1/0/15
 description
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
 storm-control broadcast level bps 1677721
 storm-control multicast level bps 1677721
!
interface FastEthernet1/0/16
 shutdown
!
interface FastEthernet1/0/17
 shutdown
!
interface FastEthernet1/0/18
 description
 switchport trunk encapsulation dot1q
 switchport mode trunk
 storm-control broadcast level bps 1677721
 storm-control multicast level bps 1677721
!
interface FastEthernet1/0/19
 description
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet1/0/20
 description
 switchport mode access
 shutdown
 speed 10
 duplex full
 storm-control broadcast level bps 1677721
 storm-control multicast level bps 1677721
!
interface FastEthernet1/0/21
 description
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface FastEthernet1/0/22
 description
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
 storm-control broadcast level bps 1677721
 storm-control multicast level bps 1677721
!
interface FastEthernet1/0/23
 description
 switchport mode access
 speed 100
!
interface FastEthernet1/0/24
 description
 switchport access vlan 6
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 6
 switchport trunk allowed vlan 1,6
 switchport mode trunk
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
  ip access-group 1 in
 no ip route-cache
!
ip classless
ip http server
!
!
control-plane
!
end
-------------------------------------------------------------------------------------------------------------


sw9
------

hostname sw9
!
l
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
switch 1 provision ws-c3750-24ts
system mtu routing 1500
vtp domain autotest
vtp mode transparent
ip subnet-zero
no ip source-route
!
!
!        
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 45056
!
vlan internal allocation policy ascending
!
vlan 3
 name
!
vlan 8
 name
!
vlan 10
 name
!
vlan 15
 name
!
vlan 16,18
!
vlan 19
 name
!
class-map match-all class_12M
  match access-group name bandwidth
!
!
policy-map policy_12
  class class_12M
    police 12000000 500000 exceed-action drop
!
!
interface FastEthernet1/0/1
 description
 switchport access vlan 15
 switchport mode access
 storm-control multicast level bps 1073741
!
interface FastEthernet1/0/2
 description
 switchport access vlan 15
 switchport mode access
 storm-control broadcast level bps 1073741
!
interface FastEthernet1/0/3
 description
 switchport access vlan 15
 switchport mode access
 speed 100
 duplex full
 storm-control broadcast level bps 1073741
!
interface FastEthernet1/0/4
 description
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,3,19
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth limit 12
 storm-control broadcast level bps 1073741
 storm-control multicast level bps 1073741
 service-policy input policy_12
!
interface FastEthernet1/0/5
 description
 switchport access vlan 8
 switchport mode access
 speed 100
 duplex full
!
interface FastEthernet1/0/6
 description
 switchport access vlan 15
 switchport mode access
 storm-control broadcast level bps 1073741
!
interface FastEthernet1/0/7
 description
 switchport access vlan 3
 switchport mode access
 shutdown
!        
interface FastEthernet1/0/8
 description
 switchport access vlan 8
 switchport mode access
!
interface FastEthernet1/0/9
 description
 switchport access vlan 15
 switchport mode access
!
interface FastEthernet1/0/10
 description
 switchport access vlan 8
 switchport mode access
!
interface FastEthernet1/0/11
 description
 switchport access vlan 8
 switchport mode access
 shutdown
 duplex full
!
interface FastEthernet1/0/12
 shutdown
!
interface FastEthernet1/0/13
 description
 switchport access vlan 18
 switchport mode access
 speed 100
 duplex full
!
interface FastEthernet1/0/14
 description
 switchport access vlan 18
 switchport mode access
!
interface FastEthernet1/0/15
 description
 switchport access vlan 19
 switchport mode access
 shutdown
 duplex full
!
interface FastEthernet1/0/16
 description
 shutdown
!
interface FastEthernet1/0/17
 shutdown
!
interface FastEthernet1/0/18
 shutdown
!
interface FastEthernet1/0/19
 shutdown
!
interface FastEthernet1/0/20
 shutdown
!
interface FastEthernet1/0/21
 shutdown
!
interface FastEthernet1/0/22
 shutdown
!
interface FastEthernet1/0/23
 description Local Switch Interconnect
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
 storm-control broadcast level bps 1073741
 storm-control multicast level bps 1073741
!
interface FastEthernet1/0/24
 description
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!        
interface Vlan1
 no ip address
!
interface Vlan8
 ip address
 ip access-group 1 in
 no ip route-cache
!
ip classless
ip http server
!
ip access-list extended bandwidth
 permit ip any any
!


!
control-plane
!

l

end
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tzeroAuthor Commented:
sw1


Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

-----------------------------------------------------------------------------------------------------------------------------
sw 9


Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
0
Nayyar HH (CCIE RS)Network ArchitectCommented:
OK, Thanks wat ports interconnects the two switches?
0
tzeroAuthor Commented:
sw1 it is fastethernet 1/0/19
sw9 it is fastethernet 1/0/24
0
xzatechCommented:
In this switch here-> "sw9" you are setting the  the "priority" with this command
(spanning-tree vlan 1 priority 45056).  ...   as apposed to "sw2" your only not allowing STP on these vlans (no spanning-tree vlan 23,25) normal  operational stuff  in conclusion spanning-tree vlan 1 priority 45056 is making sw9 your root bridge


priority sets the STP bridge priority; valid values are from 0 to 65535.
0
mick442Commented:
Put this command on SW2:

spanning-tree vlan 1 root primary  

Put this command on SW9:

spanning-tree vlan 1 root secondary
0
tzeroAuthor Commented:
ok ill try this and let you know thanks
0
tzeroAuthor Commented:
i changed the root priority to see if sw9 would pick up the root bridge from switch 2.
This did not happen as sw10 became the root bridge for vlan1.

This issue is that sw9 is not seeing bpdu from sw2 via the 802.1q trunk.
0
mick442Commented:
try removing this command from sw2:

no spanning-tree optimize bpdu transmission
0
tzeroAuthor Commented:
p
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.