Novell Client For Windows 7 doesn't map drives

We have just added our first Windows 7 workstation to our small office network (all the others are XP - we skipped Vista).

I downloaded and installed the Novell Client 2 SP1 for Windows 7, but found that it's not mapping network drives specified in the Login script when logging in. I've looked for the problem on various forums including this one, and have tried the following suggestions - all without success:
1) uninstalling the client and replacing it with the Client 2 for Vista / 2008
2) turning off UAC in Windows (by moving the slider bar down to the bottom - I don't know if there's any further step that can be taken to completely disable it). Most forum posts I've seen claim that this usually resolves the issue, but it hasn't for me.
3) turning off the prompt for a Windows ID and password using Control Userpasswords2
4) loading Windows, then logging in from the red N icon in the System Tray - this works sometimes, especially if I leave the workstation for 5-10 minutes after loading Windows, but more often than not it doesn't.

I do find it remarkable that, more than 6 months after the release of Windows 7, Novell appear still not to have a functional compatible client for it!

Can anyone suggest what else I can try to get this client to work properly? I don't mind if it's set to login to Novell as Windows loads (as is the default) or if it has to be after Windows has fully loaded, so long as it works consistently.
rodomahonyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

naburtonCommented:
create a bat file to map your drives.  have novell run the bat file at logon or put it in the local gpo to run at startup.
net use f: \\servername\share
net use h: \\servername\share

Please forgive me if that's what you are already doing with the bat file with novell....  I replaced my novell 5.1 years ago for this very issue.  Novell and Microsoft has issues...  and All Microsoft has issues too....  but...  You only have to point your finger in one direction to get it fixed if your all microsoft.
0
jmcilhargeyCommented:
Have you tried using ip addresses in place of tree and context in the client. You also want to make sure to use full UNC paths to map the drives in the login script.
0
BudDurlandDirector of ITCommented:
When we experimented wit the client for WIndows 7, we saw the same problem.  The solution was in the client set up for the resolution protocols; NCP had to be enabled.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

nlmcdanielCommented:
In order for the Novell login scripts to work properly, you have to disable UAC and your login scripts will run as expected.
0
nlmcdanielCommented:
Also what version of netware?
0
rodomahonyAuthor Commented:
Hi,

Thanks for the various suggestions. My replies as follows:

nlmcdaniel:
1) As I mentioned in the question, I've already switched off UAC but this hasn't helped. Unless there's something more I should be doing beyond moving the slider bar down to the bottom?
2) We're actually using Novell OWS (SBE edition) on Linux. I couldn't see a 'zone' for OWS when posting the question, so used Netware as the closest alternative - I meant to clarify in the body of the the question, but I see I omitted to do so - apologies.

BudDurland:
NCP is listed, along with DNS, SLP and DHCP, in Client Properties / Name Services. I assume this means it's enabled? - can't see a setting for it anywhere else.

jmcilhargey:
The login script already used full UNC paths. I've tried using the Server IP in the Tree and Context, but that hasn't helped.

naburton:
We have a single login script for all users, which maps drives according to a user's Novell group memberships; I'm guessing (correct me if I'm wrong!) that a .bat file on the workstation wouldn't be able to handle that.

The weird thing about this is that - sometimes - the login maps the drives properly. However this only seems to occur if
a) I've already logged in once, either during bootup or from the desktop; and
b) I then leave the machine for at least 5-10 minutes before logging again from the desktop.
0
jmcilhargeyCommented:
Have you tried not setting the tree or context but just setting the server in the authentication using ip only. I had some Vista machines that would not map network drives unless the ip was used in the server field under profiles.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rodomahonyAuthor Commented:
Hi,

It works! I set up a login profile as suggested by jmcilhargey, with no tree or context set, and the server identified by IP rather than by name. Tried to log in, and it failed with a 'tree or server unable to be found' error message. Back to square one, I thought - however I waited 5 minutes and tried again, and this time it logged in and mapped the drives. Rebooted the machine, and it still works straight away. Rebooted another couple of times, and it works every time.

Many thanks for your help, and also to everyone else who offered suggestions. I'm still curious to know what the issue is/was here, if anyone has any ideas. However the main thing is I can now roll out W7 workstations on the network without worrying that users won't be able to access network drives when they boot up and log on.
0
jmcilhargeyCommented:
A lot of our issues have been resolved by setting up the proper scopes and ldap in Novell. I have not had issues once we moved to the newer OES2 Linux boxes.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Novell Netware

From novice to tech pro — start learning today.