Having problems opening port 5080 on a Cisco ASA 5505 series

Hello,

I am having issues opening port 5080 on a Cisco ASA 5505 series router.
The outside rule is:
Source: any
Destination: target server.
Service: TCP 5080

Any ideas?
firewallrule.JPG
morakoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

morakoAuthor Commented:
Is there a tool that I can use to test this port from outside the network?
0
troubleshooter141Commented:
From outside the firewall, you can telnet <server IP address> 5080
If the port is listening and the port forwarding is done correctly, you will see a response (most times it will just be a black screen) this will indicate the port is listening and that you can connect to it.

Also, a Show run would be helpful. You can change the IPs for security purposes if you want but being able to see your access-list and NAT statements would be helpful in troubleshooting the issue.
0
morakoAuthor Commented:
Result of the command: "show running-config"

: Saved
:
ASA Version 8.2(2)
!

names
name 192.168.1.1 CiscoASA-Priv description CiscoASA-Pvt1
name 192.168.1.2 ILO-VMware1-1-Pvt description ILO Connection for VMware1-1-Pvt
name 192.168.1.3 ILO-Database1-1-Pvt description ILO Connection for Database1-1-Pvt
name 192.168.1.4 ILO-Encoding1-1-Pvt description ILO Connection for Encoding1-1-Pvt
name 192.168.1.5 SV-VMware1-1-Pvt description Server VMware 1-1-Pvt
name 192.168.1.6 SV-Database1-1-Pvt description Server Database 1-1-Pvt
name 192.168.1.7 SV-Encoding1-1-Pvt description Server Encoding 1-1-Pvt
name 192.168.1.8 VM-WindowsWeb1-1-Pvt description VM Windows Web 1-1-Pvt
name 192.168.1.9 VM-LinuxWeb1-1-Pvt description VM Linux Web Server 1-1-Pvt
name 192.168.1.10 VM-LinuxPlesk1-1-Pvt description VM Linux Plesk Server 1-1-Pvt
name 192.168.1.11 VM-LinuxDev1-1-Pvt description VM Linux Development Server 1-1-Pvt
name 44.44.44.68 ILO-VMware1-1-Pub description ILO Connection for VMware1-1-Pub
name 44.44.44.69 ILO-Database1-1-Pub description ILO Connection for DB1-1-Pub
name 44.44.44.70 ILO-Encoding1-1-Pub description ILO Connection for Encoding1-1-Pub
name 44.44.44.71 SV-VMware1-1-Pub description Server VMware 1-1-Pub
name 44.44.44.72 SV-Database1-1-Pub description Server Database 1-1-Pub
name 44.44.44.73 SV-Encoding1-1-Pub description Server Encoding 1-1-Pub
name 44.44.44.74 VM-WindowsWeb1-1-Pub description VM Windows Web 1-1-Pub
name 44.44.44.75 VM-LinuxWeb1-1-Pub description VM Linux Web Server 1-1-Pub
name 44.44.44.76 VM-LinuxPlesk1-1-Pub description VM Linux Plesk Server 1-1-Pub
name 44.44.44.77 VM-LinuxDev1-1-Pub description VM Linux Development Server 1-1-Pub
name 118.102.143.1 AGRIYA1 description AGRIYA Development Office IP 1
name 118.102.143.2 AGRIYA2 description AGRIYA Development Office IP 2
name 119.82.115.146 AGRIYA3 description AGRIYA Developers network IPs
name 172.16.0.1 CiscoASA description CiscoASA
name 74.251.135.44 WWBNOffice description WWBNOffice
name 192.168.2.0 Sagonet-NAT description Sagonet Internal Network
name 192.168.1.14 VH-TestDrive-WindowsWeb1-Pvt description https://testdrive.wwbn.com Private IP
name 44.44.44.80 VH-Testdrive-WindowsWeb1-Pub description https://testdrive.wwbn.com Public IP
name 44.44.44.79 VH-Platform-WindowsWeb1-Pub description Platform.WWBN.com Public IP
name 192.168.1.13 VH-Platform-WindowsWeb1-Pvt description Platform.WWBN.com Private IP
name 44.44.44.78 VH-MyWWBN-WindowsWeb1-Pub description My.WWBN.com Public IP
name 192.168.1.12 VH-MyWWBN-WindowsWeb1-Pvt description My.WWBN.com Private IP
name 63.246.134.90 Sagonet-Router-Pub description Sagonet Router
name 44.44.44.82 ILO-Storage1-1-Pub description ILO Storage Server Public IP
name 192.168.1.16 ILO-Storage1-1-Pvt description ILO Storage Server Private IP
name 44.44.44.83 SV-Storage1-1-Pub description Storage Server External IP
name 192.168.1.17 SV-Storage1-1-Pvt description Storage Server Private IP
name 44.44.44.84 VH-SearchadsWWBN-LinuxWeb1-Pub description Virtual Host searchads.wwbn.com on LinuxWeb1 Public I
name 192.168.1.18 VH-SearchadsWWBN-LinuxWeb1-Pvt description Virtual Host searchads.wwbn.com on LinuxWeb1 Private IP
name 44.44.44.85 VH-SearchmercialsWWBN-LinuxWeb1-Pub description Virtual Host searchmercials.wwbn.com Public I
name 44.44.44.86 VH-ShopWWBN-LinuxWeb1-Pub description Virtual Host shop.wwbn.com Public IP
name 192.168.1.20 VH-ShopWWBN-LinuxWeb1-Pvt description Virtual Host shop.wwbn.com Private IP
name 86.57.245.84 DHTMLX description Russian Development Team
name 44.44.44.81 VH-SupportWWBN-WindowsWeb1-Pub description https://support.wwbn.com/livesupport/
name 192.168.1.15 VH-SupportWWBN-WindowsWeb1-Pvt description https://support.wwbn.com/livesupport/  Private IP
name 192.168.1.19 VH-SearchmercialsWWBN-LinuxWeb1-Pvt description Virtual Host searchmercials.wwbn.com Private IP
name 62.213.72.101 Parallels1
name 64.131.90.27 Parallels2
name 82.200.65.190 Parallels3
name 91.204.24.0 Parallels4
name 91.204.24.6 Parallels10
name 91.204.24.7 Parallels11
name 91.204.24.8 Parallels12
name 91.204.24.9 Parallels13
name 91.204.24.10 Parallels14
name 91.204.24.11 Parallels15
name 91.204.24.12 Parallels16
name 91.204.24.13 Parallels17
name 91.204.24.14 Parallels18
name 91.204.24.15 Parallels19
name 91.204.24.16 Parallels20
name 91.204.24.17 Parallels21
name 91.204.24.18 Parallels22
name 91.204.24.19 Parallels23
name 91.204.24.20 Parallels24
name 91.204.24.21 Parallels25
name 91.204.24.22 Parallels26
name 195.214.232.10 Parallels27
name 195.214.233.10 Parallels28
name 208.251.212.1 Parallels29
name 203.32.4.0 Parallels30
name 203.32.4.1 Parallels31
name 203.32.4.2 Parallels32
name 203.32.4.3 Parallels33
name 203.32.4.4 Parallels34
name 203.32.4.5 Parallels35
name 203.32.4.6 Parallels36
name 203.32.4.7 Parallels37
name 203.32.4.8 Parallels38
name 203.32.4.9 Parallels39
name 203.32.4.10 Parallels40
name 203.32.4.11 Parallels41
name 203.32.4.12 Parallels42
name 203.32.4.13 Parallels43
name 203.32.4.14 Parallels44
name 203.32.4.15 Parallels45
name 203.32.4.16 Parallels46
name 203.32.4.17 Parallels47
name 203.32.4.18 Parallels48
name 203.32.4.19 Parallels49
name 91.204.24.1 Parallels5
name 203.32.4.20 Parallels50
name 203.32.4.21 Parallels51
name 203.32.4.22 Parallels52
name 203.32.4.23 Parallels53
name 203.32.4.24 Parallels54
name 203.32.4.25 Parallels55
name 203.32.4.26 Parallels56
name 91.204.24.2 Parallels6
name 91.204.24.3 Parallels7
name 91.204.24.4 Parallels8
name 91.204.24.5 Parallels9
name 91.204.24.201 Parallels57
dns-guard
!
interface Vlan1
 nameif inside
 security-level 100
 ip address CiscoASA-Priv 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address ##.##.##.## 255.255.0.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa822-k8.bin
ftp mode passive
dns domain-lookup outside
dns server-group DefaultDNS
 name-server ##.##.##.##
 name-server ##.##.##.##
 domain-name wwbn.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network DM_INLINE_NETWORK_1
 network-object host ILO-VMware1-1-Pub
 network-object host ILO-Database1-1-Pub
 network-object host ILO-Encoding1-1-Pub
 network-object host ILO-Storage1-1-Pub
object-group service MySQL tcp
 description MySQL Server
 port-object eq 3306
object-group service HPSIM tcp
 description HP System Management
 port-object eq 2381
object-group service DM_INLINE_TCP_1 tcp
 group-object MySQL
 port-object eq https
 port-object eq ssh
 group-object HPSIM
object-group service DM_INLINE_TCP_3 tcp
 group-object MySQL
 port-object eq https
 port-object eq ssh
 port-object eq www
object-group service DM_INLINE_TCP_5 tcp
 port-object eq ftp
 port-object eq ssh
 port-object eq www
 port-object eq https
object-group service RDP tcp
 description Remote Desktop
 port-object eq 3389
object-group service DM_INLINE_TCP_6 tcp
 group-object RDP
 port-object eq ftp
object-group service VMConsole tcp
 description Port For VMware Console
 port-object eq 902
object-group service DM_INLINE_TCP_7 tcp
 group-object VMConsole
 port-object eq https
 port-object eq ssh
 port-object eq ftp
 port-object eq www
object-group service DM_INLINE_TCP_8 tcp
 port-object eq https
 port-object eq telnet
object-group service HTTPSPlesk tcp
 description HTTPS for Plesk
 port-object eq 8443
object-group service DM_INLINE_TCP_9 tcp
 port-object eq www
 port-object eq https
 group-object HTTPSPlesk
 group-object MySQL
object-group service DM_INLINE_TCP_10 tcp
 group-object HPSIM
 port-object eq ssh
 port-object eq https
 group-object MySQL
 port-object eq www
object-group service DM_INLINE_TCP_11 tcp
 group-object HPSIM
 port-object eq https
 port-object eq ssh
 group-object MySQL
 port-object eq www
object-group service DM_INLINE_TCP_13 tcp
 port-object eq ssh
 group-object MySQL
 port-object eq ftp
 port-object eq www
 port-object eq https
object-group service WMI tcp-udp
 port-object eq 135
object-group service debug tcp-udp
 description debug proxy
 port-object eq 1036
 port-object eq 1936
object-group service ejabbered tcp-udp
 description ejabbered
 port-object eq 5280
object-group service rtmp tcp
 description rtmp
 port-object eq 1935
object-group service rtmpt tcp-udp
 description rtmpt
 port-object eq 8088
object-group network DM_INLINE_NETWORK_4
 network-object host SV-Encoding1-1-Pub
 network-object host VM-LinuxDev1-1-Pub
 network-object host SV-Storage1-1-Pub
object-group network DM_INLINE_NETWORK_3
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_6
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_5
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_7
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_8
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_9
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group service http_servlet tcp
 port-object eq 5080
object-group network DM_INLINE_NETWORK_11
 network-object host SV-Encoding1-1-Pub
 network-object host VM-LinuxDev1-1-Pub
 network-object host SV-Storage1-1-Pub
object-group service DM_INLINE_TCP_15 tcp
 port-object eq www
 port-object eq https
object-group network DM_INLINE_NETWORK_13
 network-object host VH-SearchadsWWBN-LinuxWeb1-Pub
 network-object host VH-SearchmercialsWWBN-LinuxWeb1-Pub
 network-object host VH-ShopWWBN-LinuxWeb1-Pub
object-group network DM_INLINE_NETWORK_2
 network-object host VH-MyWWBN-WindowsWeb1-Pub
 network-object host VH-Platform-WindowsWeb1-Pub
 network-object host VH-Testdrive-WindowsWeb1-Pub
 network-object host VH-SupportWWBN-WindowsWeb1-Pub
object-group service DM_INLINE_TCP_2 tcp
 port-object eq www
 port-object eq https
object-group network DM_INLINE_NETWORK_14
 network-object host VM-LinuxPlesk1-1-Pub
 network-object host VH-SupportWWBN-WindowsWeb1-Pub
object-group network Agriya
 description Agriya Development
 network-object host AGRIYA1
 network-object host AGRIYA2
 network-object host AGRIYA3
object-group network PARALLELS
 description Plesk, Sitebuilder Support
 network-object host Parallels27
 network-object host Parallels28
 network-object host Parallels30
 network-object host Parallels40
 network-object host Parallels41
 network-object host Parallels42
 network-object host Parallels43
 network-object host Parallels44
 network-object host Parallels45
 network-object host Parallels46
 network-object host Parallels47
 network-object host Parallels48
 network-object host Parallels49
 network-object host Parallels31
 network-object host Parallels50
 network-object host Parallels51
 network-object host Parallels52
 network-object host Parallels53
 network-object host Parallels54
 network-object host Parallels55
 network-object host Parallels56
 network-object host Parallels32
 network-object host Parallels33
 network-object host Parallels34
 network-object host Parallels35
 network-object host Parallels36
 network-object host Parallels37
 network-object host Parallels38
 network-object host Parallels39
 network-object host Parallels29
 network-object host Parallels1
 network-object host Parallels2
 network-object host Parallels3
 network-object host Parallels4
 network-object host Parallels14
 network-object host Parallels15
 network-object host Parallels16
 network-object host Parallels17
 network-object host Parallels18
 network-object host Parallels19
 network-object host Parallels20
 network-object host Parallels21
 network-object host Parallels22
 network-object host Parallels23
 network-object host Parallels5
 network-object host Parallels24
 network-object host Parallels25
 network-object host Parallels26
 network-object host Parallels6
 network-object host Parallels7
 network-object host Parallels8
 network-object host Parallels9
 network-object host Parallels10
 network-object host Parallels11
 network-object host Parallels12
 network-object host Parallels13
object-group network DM_INLINE_NETWORK_10
 network-object host WWBNOffice
 group-object PARALLELS
 network-object host Parallels57
object-group network DM_INLINE_NETWORK_16
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group service DM_INLINE_TCPUDP_1 tcp-udp
 group-object debug
 group-object ejabbered
 group-object rtmpt
object-group service DM_INLINE_TCP_16 tcp
 group-object MySQL
 group-object http_servlet
 group-object rtmp
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group network DM_INLINE_NETWORK_12
 network-object host SV-Encoding1-1-Pub
 network-object host VM-LinuxDev1-1-Pub
 network-object host SV-Storage1-1-Pub
object-group network DM_INLINE_NETWORK_18
 network-object host WWBNOffice
 group-object Agriya
object-group network DM_INLINE_NETWORK_15
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_19
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_20
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group service DM_INLINE_TCP_4 tcp
 port-object eq www
 port-object eq https
object-group network DM_INLINE_NETWORK_21
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group network DM_INLINE_NETWORK_22
 network-object host VM-LinuxDev1-1-Pvt
 network-object host SV-Storage1-1-Pvt
 network-object host SV-Encoding1-1-Pvt
object-group service DM_INLINE_TCP_12 tcp
 port-object eq ftp
 port-object eq ssh
object-group network DM_INLINE_NETWORK_17
 network-object host AGRIYA1
 network-object host AGRIYA2
 network-object host AGRIYA3
 network-object host WWBNOffice
object-group network DM_INLINE_NETWORK_23
 network-object host SV-Encoding1-1-Pub
 network-object host VM-LinuxDev1-1-Pub
object-group network DM_INLINE_NETWORK_24
 network-object host SV-Encoding1-1-Pub
 network-object host VM-LinuxDev1-1-Pub
object-group network DM_INLINE_NETWORK_25
 network-object host SV-Encoding1-1-Pub
 network-object host VM-LinuxDev1-1-Pub
 network-object host SV-Storage1-1-Pub
access-list outside_access_in remark https access for WWBN development and testdrive.wwbn.com
access-list outside_access_in extended permit tcp any object-group DM_INLINE_NETWORK_14 object-group DM_INLINE_TCP_9
access-list outside_access_in extended permit object-group TCPUDP any object-group DM_INLINE_NETWORK_12 eq 1935
access-list outside_access_in extended permit tcp any object-group DM_INLINE_NETWORK_11 eq 5080
access-list outside_access_in extended permit object-group TCPUDP any object-group DM_INLINE_NETWORK_25 eq 8088
access-list outside_access_in extended permit icmp any object-group DM_INLINE_NETWORK_23 inactive
access-list outside_access_in extended permit ip any object-group DM_INLINE_NETWORK_24 inactive
access-list outside_access_in remark SSH access to encoding server
access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_17 object-group DM_INLINE_NETWORK_4 object-group DM_INLINE_TCP_13
access-list outside_access_in remark Management access to Plesk hosting server
access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_10 host VM-LinuxPlesk1-1-Pub eq ssh
access-list outside_access_in remark Rule for searchads.wwbn.com, searchmercials.wwbn.com and shop.wwbn.com
access-list outside_access_in extended permit tcp host WWBNOffice object-group DM_INLINE_NETWORK_2 object-group DM_INLINE_TCP_2
access-list outside_access_in remark Rule for searchads.wwbn.com, searchmercials.wwbn.com and shop.wwbn.com
access-list outside_access_in extended permit tcp object-group DM_INLINE_NETWORK_18 object-group DM_INLINE_NETWORK_13 object-group DM_INLINE_TCP_15
access-list outside_access_in remark Management access to development server
access-list outside_access_in extended permit tcp host WWBNOffice host VM-LinuxDev1-1-Pub object-group DM_INLINE_TCP_3
access-list outside_access_in remark Management access to linux websites
access-list outside_access_in extended permit tcp host WWBNOffice host VM-LinuxWeb1-1-Pub object-group DM_INLINE_TCP_5
access-list outside_access_in remark Management access to Windows applications
access-list outside_access_in extended permit tcp host WWBNOffice host VM-WindowsWeb1-1-Pub object-group DM_INLINE_TCP_6
access-list outside_access_in remark Access to database server
access-list outside_access_in extended permit tcp host WWBNOffice host SV-Database1-1-Pub object-group DM_INLINE_TCP_1
access-list outside_access_in remark SSH access to encoding server
access-list outside_access_in extended permit tcp host WWBNOffice host SV-Encoding1-1-Pub object-group DM_INLINE_TCP_10
access-list outside_access_in remark Access to VMware management console
access-list outside_access_in extended permit tcp host WWBNOffice host SV-VMware1-1-Pub object-group DM_INLINE_TCP_7
access-list outside_access_in remark Access to stoarge server 1
access-list outside_access_in extended permit tcp host WWBNOffice host SV-Storage1-1-Pub object-group DM_INLINE_TCP_11
access-list outside_access_in remark WWBN Access to server ILO
access-list outside_access_in extended permit tcp host WWBNOffice object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_TCP_8
access-list outside_access_in extended permit ip Sagonet-NAT 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_access_in extended deny icmp any any
access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 Sagonet-NAT 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 Sagonet-NAT 255.255.255.0
access-list inside_access_in extended permit ip 192.168.1.0 255.255.255.0 any
access-list inside_access_in extended permit object-group TCPUDP object-group DM_INLINE_NETWORK_8 object-group DM_INLINE_NETWORK_9 object-group DM_INLINE_TCPUDP_1
access-list inside_access_in extended permit tcp object-group DM_INLINE_NETWORK_15 object-group DM_INLINE_NETWORK_16 object-group DM_INLINE_TCP_16
access-list inside_access_in extended permit tcp object-group DM_INLINE_NETWORK_19 object-group DM_INLINE_NETWORK_20 object-group DM_INLINE_TCP_4
access-list inside_access_in extended permit tcp object-group DM_INLINE_NETWORK_21 object-group DM_INLINE_NETWORK_22 object-group DM_INLINE_TCP_12
access-list inside_access_in extended permit icmp object-group DM_INLINE_NETWORK_5 object-group DM_INLINE_NETWORK_7
access-list inside_access_in extended permit ip object-group DM_INLINE_NETWORK_3 object-group DM_INLINE_NETWORK_6
access-list Split_Tunnel_List remark Internal Network
access-list Split_Tunnel_List standard permit 192.168.1.0 255.255.255.0
access-list Split_Tunnel_List remark Sagonet Network
access-list Split_Tunnel_List standard permit Sagonet-NAT 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool Default 192.168.1.133-192.168.1.160 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) ILO-VMware1-1-Pub ILO-VMware1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) ILO-Database1-1-Pub ILO-Database1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) ILO-Encoding1-1-Pub ILO-Encoding1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) ILO-Storage1-1-Pub ILO-Storage1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) SV-VMware1-1-Pub SV-VMware1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) SV-Database1-1-Pub SV-Database1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) SV-Encoding1-1-Pub SV-Encoding1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) SV-Storage1-1-Pub SV-Storage1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VM-WindowsWeb1-1-Pub VM-WindowsWeb1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VM-LinuxWeb1-1-Pub VM-LinuxWeb1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VM-LinuxPlesk1-1-Pub VM-LinuxPlesk1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VM-LinuxDev1-1-Pub VM-LinuxDev1-1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-Testdrive-WindowsWeb1-Pub VH-TestDrive-WindowsWeb1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-Platform-WindowsWeb1-Pub VH-Platform-WindowsWeb1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-MyWWBN-WindowsWeb1-Pub VH-MyWWBN-WindowsWeb1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-SearchadsWWBN-LinuxWeb1-Pub VH-SearchadsWWBN-LinuxWeb1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-SearchmercialsWWBN-LinuxWeb1-Pub VH-SearchmercialsWWBN-LinuxWeb1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-ShopWWBN-LinuxWeb1-Pub VH-ShopWWBN-LinuxWeb1-Pvt netmask 255.255.255.255 dns
static (inside,outside) VH-SupportWWBN-WindowsWeb1-Pub VH-SupportWWBN-WindowsWeb1-Pvt netmask 255.255.255.255 dns
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 44.44.44.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http WWBNOffice 255.255.255.255 outside
snmp-server host inside SV-Database1-1-Pvt poll community ***** version 2c
no snmp-server location
no snmp-server contact
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer Sagonet-Router-Pub
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto ca trustpoint ASDM_TrustPoint0
 crl configure
crypto ca trustpoint ASDM_TrustPoint1
 keypair ASDM_TrustPoint1
 crl configure
crypto ca certificate chain ASDM_TrustPoint1
 certificate 008c572fc09708c4d840d812396b89cd56
    308205de 308204c6 a0030201 02021100 8c572fc0 9708c4d8 40d81239 6b89cd56
    300d0609 2a864886 f70d0101 05050030 62310b30 09060355 04061302 55533121
    301f0603 55040a13 184e6574 776f726b 20536f6c 7574696f 6e73204c 2e4c2e43
    2e313030 2e060355 04031327 4e657477 6f726b20 536f6c75 74696f6e 73204365
    72746966 69636174 65204175 74686f72 69747930 1e170d30 39313230 33303030
    3030305a 170d3130 31323033 32333539 35395a30 81f8310b 30090603 55040613
    02555331 0e300c06 03550411 13053330 30353231 10300e06 03550408 13074765
    6f726769 61311030 0e060355 04071307 41746c61 6e746131 16301406 03550409
    130d5375 69746520 3131302d 31373331 1d301b06 03550409 13143431 33322041
    746c616e 74612048 69676877 6179312b 30290603 55040a13 22576f72 6c642057
    69646520 42726f61 64636173 74204e65 74776f72 6b2c2049 6e632e31 19301706
    0355040b 13104e65 74776f72 6b205365 63757269 74793121 301f0603 55040b13
    18536563 75726520 4c696e6b 2053534c 2057696c 64636172 64311330 11060355
    0403140a 2a2e7777 626e2e63 6f6d3082 0122300d 06092a86 4886f70d 01010105
    00038201 0f003082 010a0282 010100b4 a45c936f 5b0eabea c742fd58 e060f2d0
    c3e532c1 315625ae 9c6776d9 2ada4d34 cabebfb3 1e681369 8c78b59a 179e329c
    ecb2406e e5149656 39d38653 8197cc87 827059bb f42f8494 4bcc1caf 3e2d3bf9
    019cc79c 35813160 12021726 5ca450d5 5e1c6af4 afeb0495 18e9e980 870cf3a9
    18e998a9 649d4bb4 4b7a3d2b e8f1fb32 1acb262b 2492eb08 3e0ee7ec cc8d11a8
    204e8103 06612f38 9a035aa2 4b491add d53e84d9 5713318d e3a2f768 cf6dceea
    0dff22db 8926fd4d 9f66d9a9 ffc2faa5 40c112ca b56bcb57 3e523432 a2cfb0e1
    63bee581 636abea9 226fcd24 05fe4304 0b10d9a3 26669bfb f04586c6 48deee88
    e0074199 1568229e 9859758c 190f5702 03010001 a38201f6 308201f2 301f0603
    551d2304 18301680 143c41e2 8f0808a9 4c25898d 6dc538d0 fc858c62 17301d06
    03551d0e 04160414 33779544 5e050893 eb9ddee0 1580bf37 8d6f4f63 300e0603
    551d0f01 01ff0404 030205a0 300c0603 551d1301 01ff0402 3000301d 0603551d
    25041630 1406082b 06010505 07030106 082b0601 05050703 02306b06 03551d20
    04643062 3060060c 2b060104 01860e01 02010301 3050304e 06082b06 01050507
    02011642 68747470 3a2f2f77 77772e6e 6574776f 726b736f 6c757469 6f6e732e
    636f6d2f 6c656761 6c2f5353 4c2d6c65 67616c2d 7265706f 7369746f 72792d63
    70732e6a 7370307a 0603551d 1f047330 713036a0 34a03286 30687474 703a2f2f
    63726c2e 6e657473 6f6c7373 6c2e636f 6d2f4e65 74776f72 6b536f6c 7574696f
    6e735f43 412e6372 6c3037a0 35a03386 31687474 703a2f2f 63726c32 2e6e6574
    736f6c73 736c2e63 6f6d2f4e 6574776f 726b536f 6c757469 6f6e735f 43412e63
    726c3073 06082b06 01050507 01010467 3065303c 06082b06 01050507 30028630
    68747470 3a2f2f77 77772e6e 6574736f 6c73736c 2e636f6d 2f4e6574 776f726b
    536f6c75 74696f6e 735f4341 2e637274 30250608 2b060105 05073001 86196874
    74703a2f 2f6f6373 702e6e65 74736f6c 73736c2e 636f6d30 15060355 1d11040e
    300c820a 2a2e7777 626e2e63 6f6d300d 06092a86 4886f70d 01010505 00038201
    0100808a 657f19c4 dc6c1f1e 996c5789 84a6c9f4 6e3ebee4 90b61fbc 4dc3d3c3
    85596682 c6c63bd0 bd6bbb5f c423a4ef c8a350d1 f171a78f f4de9b9d e789d1ab
    279f1f96 f9d3d2c9 89a94760 f28b6f5b ec7eb7f3 2a4f7ec0 186b7951 58c0d087
    68766113 fa7776b1 10f7ff5d 09cbd111 ff0e6da3 eb84bc13 293c2af4 8c37770b
    756a1525 bbecab78 95f8cb17 ca8e3ba1 dc1d0c0a 2a4a327d a15d2ba0 11ffdb67
    3ef2ae7f 9417cbca 8f046ec5 0ab9a9a0 fc9f449e 91e9f72f db7c479a 5bd5d369
    501f16a1 3c783ce0 ae658e83 59a7f4b4 b3ffa4ef b4b0ef4c a2107cba 2e3a0f69
    94843284 11a01887 888c9cb9 1bda5f95 5c448161 4b3bc4b2 87cf43af bfbbdfdf 58eb
  quit
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.132 inside
dhcpd dns 69.25.88.131 69.25.88.132 interface inside
dhcpd domain wwbn.com interface inside
dhcpd auto_config outside interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ntp server 129.6.15.28 source outside prefer
ssl trust-point ASDM_TrustPoint1 outside vpnlb-ip
ssl trust-point ASDM_TrustPoint1 outside
ssl trust-point ASDM_TrustPoint1 inside vpnlb-ip
ssl trust-point ASDM_TrustPoint1 inside
webvpn
 enable outside
 anyconnect-essentials
 csd image disk0:/securedesktop-asa-3.3.0.151-k9.pkg
 svc image disk0:/anyconnect-win-2.4.0202-k9.pkg 1 regex "Windows NT"
 svc image disk0:/anyconnect-linux-2.4.0202-k9.pkg 2 regex "Linux"
 svc image disk0:/anyconnect-macosx-i386-2.4.0202-k9.pkg 3 regex "Intel Mac OS X"
 svc image disk0:/anyconnect-macosx-powerpc-2.4.0202-k9.pkg 4 regex "PPC Mac OS X"
 svc image disk0:/anyconnect-wince-ARMv4I-2.4.0202-k9.pkg 5 regex "Windows CE"
group-policy DfltGrpPolicy attributes
 dns-server value 69.25.88.131 69.25.88.132
 vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Split_Tunnel_List
 address-pools value Default
username james password HUH0MoWoggJ5f3xN encrypted privilege 0
username james attributes
 service-type remote-access
username alexious password LbpC50TyRKQCIX// encrypted privilege 15
tunnel-group 63.246.134.90 type ipsec-l2l
tunnel-group 63.246.134.90 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e6aa765d7db4de6e0462ae9e1d70c523
: end
0
Identify and Prevent Potential Cyber-threats

Become the white hat who helps safeguard our interconnected world. Transform your career future by earning your MS in Cybersecurity. WGU’s MSCSIA degree program was designed in collaboration with national intelligence organizations and IT industry leaders.

troubleshooter141Commented:
I don't see a static (inside, outside) command that references to port 5080
this is what would NAT you internal server to the desired public address for the specific port.
0
morakoAuthor Commented:
Excuse my ignorance, as I am new to this.  I have attached an image of the interface.  Is this where I set the NAT Rule, Then do I check the Port Address Translation (PAT) to TCP, original port 5080, translated port 5080?
static-nat.JPG
0
troubleshooter141Commented:
Yes
Interface inside source will be your server's ip address
Tranlated interface outside wil be the public ip address you want to use
enable port address tranlation for tcp 5080 on both original and translated
0
morakoAuthor Commented:
I am using a tool called lynx which is used to test the RED5 connection to the server from one ip to another.

When I run lynx http://192.168.1.#:5080/
I get the RED5 test page below

  Red5 Test Page

when I run  lynx http://44.44.44.44.:5080/   (public IP)
     Making HTTP connection to (ip address):5080
with no connection

the developers are telling me that I need to get the same test page for the public ip address, but that is not happening.

I do however get a blinking prompt with a black screen when I telnet the public IP with the port5080 as you had previously mentioned from an external machine.    

Would you like to see the running configuration again with the current changes?              
0
morakoAuthor Commented:
The five hits seen in the attached image are from the 5 telnet calls I made to the server.

Could it be that the calls are reaching the router, but not the machine?
5-hits.JPG
0
morakoAuthor Commented:
Hi,

It seems I can connect from outside the network to telnet ip address 5080, but when I use a public address from within the network from server to server but using public IP address it does not connect.

It seems that I cannot get outbound from within the network.  Any ideas?
0
morakoAuthor Commented:
Also I can ping google from the box, but I cannot ping another public IP fron the same network.

[root@linuxweb1 ~]# ping google.com
PING google.com (74.125.47.99) 56(84) bytes of data.
64 bytes from yw-in-f99.1e100.net (74.125.47.99): icmp_seq=1 ttl=57 time=1.83 ms
64 bytes from yw-in-f99.1e100.net (74.125.47.99): icmp_seq=2 ttl=57 time=1.48 ms
64 bytes from yw-in-f99.1e100.net (74.125.47.99): icmp_seq=3 ttl=57 time=1.58 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2043ms
rtt min/avg/max/mdev = 1.480/1.633/1.838/0.157 ms

[root@linuxweb1 ~]# ping dev.wwbn.com
PING dev.wwbn.com (192.168.1.11) 56(84) bytes of data.
64 bytes from 192.168.1.11: icmp_seq=1 ttl=64 time=1.59 ms
64 bytes from 192.168.1.11: icmp_seq=2 ttl=64 time=0.251 ms

--- dev.mywebsite.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1023ms
rtt min/avg/max/mdev = 0.251/0.925/1.599/0.674 ms

[root@linuxweb1 ~]# ping ##.##.##.## ( my ip)
PING ##.##.##.## (##.##.##.##) 56(84) bytes of data.

--- ##.##.##.## ping statistics ---
27 packets transmitted, 0 received, 100% packet loss, time 26911ms
0
troubleshooter141Commented:
>but when I use a public address from within the network from server to server but using public IP address it does not connect.


You can't use the public IP address from within the network.... The firewall does not allow for this.
0
morakoAuthor Commented:
So an outside call would be done through the 192.168.1.1 and this would NAT out to the public IP?
0
morakoAuthor Commented:
If so is there any documentation that you know of that I can reference this information and get better acquainted with this process and rule?
0
troubleshooter141Commented:
Ok, after a second look at this, you might be able to accomplish this but it can be a little tricky...
Look at this article:

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00807968d1.shtml#solution2

I believe what you are looking at is called hairpin routing
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
morakoAuthor Commented:
Very professional, informative and helpful.  Thank you very much troubleshooter141.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Operations

From novice to tech pro — start learning today.