Seamless Windows issue on Windows 2008R2 Remote Desktop Server

When Windows Server 2008R2 Remote Desktop Remote Apps are installed on a desktop using the Create Installer Packages, we run into an annoying problem that when a Remote App is started from an other Remote App, the seamless window jumps behind all the other open windows. When this happens, it looks like the program isn't responding, it is indeed responding, but it's opening the new window behind all other open windows. You have to Alt-Tab your way to it.

An example is when Word is selected as Outlook editor in Office 2003. In that case every new e-mail or replies are opened behind Outlook, looking as if Outlook isn't responding. We solved this by selecting the Outlook editor. But now we are running into other programs doing the same. For instance creating a document from CRM in Outlook. The word add-on has started Word, but behind all other open windows. having to Alt-Tab to it.

We already tried the following:
[HKEY_CURRENT_USER\Control Panel\Desktop]
"ForegroundFlashCount"=dword:00000000
"ForegroundLockTimeout"=dword:00000000

but it does not fix it. Even when "ForegroundFlashCount" is set to zero, you see Word flashing in the background, but selecting the flashing window does not open the right Word window. You really have to Alt-Tab to it. Very annoying.

Does anyone know a work around or fix for this?
NicoNLAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
BLipmanConnect With a Mentor Commented:
Yep, and then you lose all of the benefits: RemoteApp, EasyPrint, etc.  If I end up finding something or calling MS myself I will try to find this post again and update it.  I am holding off W2K8 in my Citrix environment for this exact reason.  
0
 
BLipmanCommented:
There is a Z Order issue with Server 2008, our apps do this in a single session when we call another app from our old VB6 program.  The only fix I can suggest is either
1) don't use seamless (use a % screen size instead of seamless for example)
2) disable session sharing: http://support.citrix.com/article/ctx159159

I bet you don't see the issue on Server 2003?  

Here is info on our issues, z-order, and "bring to front":
http://msdn.microsoft.com/en-us/library/microsoft.visualbasic.compatibility.vb6.support.zorder.aspx
0
 
NicoNLAuthor Commented:
We are not using Citrix, so there are no Citrix session sharing to disable. We use Windows server 2008 Release 2 Remote Desktop Server. With 2008R2 it is also possible to kind of publish the application through the RemoteApp manager to RD Web Access or by using a rdp or msi file.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
BLipmanCommented:
Sorry, assumed you were using Citrix.  I am actually pretty familiar with TS also so I am well aware of RemoteApp...kind of comes with the territory.  
Regardless of how you are getting in, the issue is with the OS, not Citrix or TS.  I can reproduce this right on the desktop of a Server 2008 Terminal Server.  When I launch my program's report viewer, it does exactly what you are saying.  You may end up needing to complain to Microsoft because this was not an issue with Server 2003.  Our trainers are just telling users to minimize the program down to see the other application.  It is not a great situation.  
0
 
NicoNLAuthor Commented:
Okay, thanks for the info. So there isn't a solution for that at this moment. This will make it more difficult for us  to please our users with our new 2008R2 Remote Desktop server. They are probably going to prefere using the old 2003 Terminal Server, instead of the new 2008R2 Remote Desktop because of this.
0
 
NicoNLAuthor Commented:
> If I end up finding something or calling MS myself I will try to find this post again and update it
I would very much appreciate this, thanks!
0
 
NicoNLAuthor Commented:
Hi BLipman,

I'll give you the points. Please update this post if you find a solution.
0
 
BLipmanCommented:
Hello, I might have found a solution, try this:

http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/2bdb5802-bd6f-440d-be30-8dc9e4309124/

"Change the value of ForegroundLockTimeout within HKEY_CURRENT_USER\Control Panel\Desktop into "0"
Logoff/Logon"

You will need to do this to every user on each server but that can be done in a logon script.
0
 
NicoNLAuthor Commented:
Hi BLipman,

Thank you for your reply. I already tried the following: [HKEY_CURRENT_USER\Control Panel\Desktop]
"ForegroundFlashCount"=dword:00000000 / "ForegroundLockTimeout"=dword:00000000 back in januari 2010. That didn't want to do the job back then.

I now added the reg key again, using gpo registry preferences, this time without the ForegroundFlashCount setting, so that will stay set to the default value.

I tried a reply from Outlook 2003 with Word selected as editor. A reply would usually appear hiding behind the outlook screen. It now jumps up in front. That's a good sign ;-)
I have an ERP program with diappearing sub screens, users having to Alt Tab to make it appear. I'll check it out, hopefully these sub screen will also keep jumping up in front now.

Thanks!
0
 
BLipmanCommented:
Yeah, hopefully this is a fix!  My company makes a finance package we deploy through Citrix or Terminal Services and this issue has been causing major headaches.  I will report back if we find any issues/limitations/etc.  
0
 
NicoNLAuthor Commented:
Ok, thanks again :-)
0
All Courses

From novice to tech pro — start learning today.