Qmail Cname and deliverability issues

For some reason, since about 3 or 4 weeks ago, my domain (aws.com) receives email from Yahoo, Juno, etc. (qmail users) about 10% of the time. The rest of the emails get kicked back with:

CNAME lookup failed temporarily. (#4.4.3)
I'm not going to try again; this message has been in the queue too long.

Note that I have pretty much narrowed this down to only services that use Qmail.

Our DNS servers and MX records are all good. We've had it verified by 3 third party vendors.

DNS response times average 4 ms and the payload is around 250 or so bytes.

I have opened a ticket with Yahoo, but they seem to have no answer. Juno is blaming my DNS. I blame Qmail.

Any and all advice is welcomed. As you can imagine, this is quite frustrating.

thanks,
joe
awsnocAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shauncroucherCommented:
I tried querying for your namservers and it took 3 or 4 nslookup queries for the results to be returned. That's not a good sign.

Clarify with weatherbug.com that they aren't having any load issues on the DNS servers.

Shaun
0
awsnocAuthor Commented:
Hi Shaun.  Can you try again?  I had rebooted one of our DNS servers in hopes that that might rememdy the problem.

Thanks!
joe
0
awsnocAuthor Commented:
Sorry Shaun, but can you tell me if you are hitting a particular NS and if so, which one took the retries?

thx,
joe
0
Do You Have a Trusted Wireless Environment?

A Trusted Wireless Environment is a framework for building a complete Wi-Fi network that is fast, easy to manage, and secure.

shauncroucherCommented:
That could have been it then. I was on ns3.weatherbug.com if I remember correctly.

All the DNS looks fine by the way, I can't see any reason why mail should be having a hard time reaching you.

You do however have 2 MX's poiting to same host, although this shouldn't cause any issues, I would remove it just in case.

ip.aws and ipw.aws - remove one of these MX records.

Shaun
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Daniel McAllisterPresident, IT4SOHO, LLCCommented:
Use the site http://www.intodns.com to test your DNS servers... it will also check the MX records on there...

My best guess from what you've said is that your MX records are pointers to CNAME records (instead of A records, as required -- or at least strongly urged).

If you suspect this is a QMail issue, look at what DNS service your QMail server is using (the contents of /etc/resolv.conf).

Good Luck!

Dan
IT4SOHO
0
awsnocAuthor Commented:
I removed ipw.aws.com and that fixed the problem.  It still makes no sense, as Qmail was the only email MTA affected, but hey, now it works!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.