Windows 7 - Mapped Drives Red X Applications Fail to load

I am in the testing phase of deploying Windows 7 throughout my network.  We are currently in the process of developing our new AutoCAD 2010 customization and we noticed a very strange thing.

-AutoCAD customized shortcut points to a file located on my L:\2010_MEP\test.arg

-In Windows Explorer, my mapped L:\ drive has a Red X through it, the customized version of AutoCAD fails to load

-When I click on the mapped L:\ drive through Windows Explorer everything appears, the icon  for the mapped drive turns green and the customized version of AutoCAD loads up perfectly.

-I have this same configuration for Windows XP machines and it loads without a problem, including when the same mapped network drive is "Disconnected from Network"

-My current login scripts are configured as: net use L: \\wmanas.wmace.com\CAD /persistent:yes for all workstations.

Bottom line: In Windows 7, when a Red X appears, any applications that point to mapped drives will fail to load.  When we click on the mapped drives, they "go green" and THEN the applications load without a problem.

I need a solution for this.



HemisFearAsked:
Who is Participating?
 
ggefterConnect With a Mentor Commented:
you think you have full control but you dont until you turn off UAC (user access control)

http://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-windows-vista/

try turning this off and try again ...
0
 
HemisFearAuthor Commented:
Turning off UAC is not an option in a work enviornment.  We fully plan to utilize UAC once I deploy Windows 7.  This is unfortunately, not a plausible solution.

I'm reading that Windows 7 has timeout issues with mapped drives as compared to Windows XP.  Also, I've noted that even though the drives are totally available for use when you click on them, when I run a Net Use command in a command prompt I recieve the following:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\M18>net use
New connections will be remembered.


Status       Local     Remote                    Network

-------------------------------------------------------------------------------
OK           G:        \\wmanas.wmace.com\Drawings
                                                Microsoft Windows Network
Unavailable  H:        \\wmanas.wmace.com\Documents
                                                Microsoft Windows Network
OK           I:        \\wmanas.wmace.com\Standard
                                                Microsoft Windows Network
OK           J:        \\wmanas.wmace.com\DosApps
                                                Microsoft Windows Network
Unavailable  K:        \\wmanas.wmace.com\WinApps
                                                Microsoft Windows Network
OK           L:        \\wmanas.wmace.com\CAD    Microsoft Windows Network
Unavailable  M:        \\wmanas.wmace.com\Departments\IS
                                                Microsoft Windows Network
Unavailable  O:        \\wmanas.wmace.com\Share  Microsoft Windows Network
Unavailable  Q:        \\wmanas.wmace.com\Log    Microsoft Windows Network
OK           U:        \\wmanas.wmace.com\users\M18
                                                Microsoft Windows Network
The command completed successfully.


C:\Users\M18>
0
 
ggefterConnect With a Mentor Commented:
but for testing purposes you can turn it off and see if your custom app works ... then we can move forward when we have answers. But right now your shooting in the dark
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
arnoldCommented:
When mapping the drive are you using the net use L: directive?
Try net use L: /persistent:yes
This should keep the mapped drive connection active.
Are the systems part of a domain or are they members of the same workgroup?
The difference might be with the sharing configuration.  What is the OS on the system where the share resides?
0
 
HemisFearAuthor Commented:
I have disabled UAC completely and the behavior has changed so that when the user logs in, the mapped drives no longer have a Red X by them.  I do not know yet though if there is a timeout period that will enable the Red X's again.

My issue of course is that we want to utilize UAC when we deploy Windows 7.  Does this help?
0
 
arnoldCommented:
Are your systems members of an AD, or are they Workgroup and which sharing options are set(public, work, home)?
under the network and sharing interface, there are settings dealing with the connection encryption, potentially if you have a non-AD setup and the network configuration is for public that may explain the issue.  Need more detail on the current setup.
0
 
HemisFearAuthor Commented:
arnold : If you look above I posted exactly what my login scripts are doing to map the drives, including that we are using the /persistent:yes switch

My organization is 15 servers, 70 workstations, in a Windows 2003 domain enviornment.  I do have one Windows Server 2008 DC that currently holds none of the master roles for a DC in preparation for the migration to Windows 7.

Windows Server 2003 R2 - Standard is the operating system of the shares.
0
 
HemisFearAuthor Commented:
Oops, excuse me, I didn't post the login script!  I appologize gentlemen.  My login script looks like this.

net use G: \\wmanas.wmace.com\Drawings /persistent:yes
net use H: \\wmanas.wmace.com\Documents /persistent:yes
net use I: \\wmanas.wmace.com\Standard /persistent:yes
net use J: \\wmanas.wmace.com\DosApps /persistent:yes
net use K: \\wmanas.wmace.com\WinApps /persistent:yes
net use L: \\wmanas.wmace.com\CAD /persistent:yes
net use M: \\wmanas.wmace.com\Departments\IS /persistent:yes
net use O: \\wmanas.wmace.com\Share /persistent:yes
net use Q: \\wmanas.wmace.com\Log /persistent:yes
0
 
gemartiCommented:
I think you'll find the solution to your problem here:

http://www.technoogies.com/?p=201
0
 
HemisFearAuthor Commented:
I'm going to try and implement that solution over the weekend and see if it resovles my issue on Monday.  If it does, I will aware points for the http://www.technoogies.com/?p=201 at that time.
0
 
HemisFearAuthor Commented:
gemarti: Unfortunately your recommendation did not solve my problem.

So far the only way to remove the Red X is by shutting UAC off.  

For more information I have done a Net Use via a command prompt.  
Below are the results as they are displayed without UAC shut off in conjuction with the login script above:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\M18>net use
New connections will be remembered.


Status       Local     Remote                    Network

-------------------------------------------------------------------------------
Unavailable  G:        \\wmanas.wmace.com\Drawings
Unavailable  H:        \\wmanas.wmace.com\Documents
Unavailable  I:        \\wmanas.wmace.com\Standard
Unavailable  J:        \\wmanas.wmace.com\DosApps
Unavailable  K:        \\wmanas.wmace.com\WinApps
Unavailable  L:        \\wmanas.wmace.com\CAD
Unavailable  M:        \\wmanas.wmace.com\Departments\IS
Unavailable  O:        \\wmanas.wmace.com\Share
Unavailable  Q:        \\wmanas.wmace.com\Log
OK           U:        \\wmanas.wmace.com\users\M18
The command completed successfully.

Once I double click on any of the mapped drives, it connects without a problem and browses the file shares.
0
 
HemisFearAuthor Commented:
I figured it out.  The issue is because Windows Vista & Windows 7 handle security tokens differently for standard users and administrator user accounts.  The user who was testing this was an admin.  The minute I logged on as a standard user, this issue was resolved.

I found the solution located here:

http://social.technet.microsoft.com/Forums/fi-FI/w7itpronetworking/thread/8bcf17bc-191e-4125-9dab-b1120b7c8f21

I'm going to award ggefter some of the points because he pointed me in the right direction.
0
 
gemartiCommented:
Okay
On Your windows 7 machine try this :

Click START
Enter: MMC
Click FILE
Click ADD/REMOVE SNAPIN
Local Group Policy Object Editor
Click ADD
Click Finish
Click OK
Double click Local Group Policy
Under Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\
Network security: LAN manager authentication level
Select Send LM & NTLM responses in the dropdown box
Click Ok

0
All Courses

From novice to tech pro — start learning today.