Dell Inspiron 1525 Won't Charge Battery

Hello everyone,

I've got myself a problem.  I have a Dell Inspiron 1525 Laptop that won't charge the battery.  I have tried a new Battery and new AC Adapter.

When I go into BIOS it says the Battery is performing normally.  The old Battery says it is at 0% and idle.  It says below that the AC-Adapter can't be identified.  I've got the factory AC Adapter connected and I've tried a new 3rd party AC-Adapter as well as a Universal AC-Adapter.  All say the same thing that they can't be identified.  They all work to power and run the system but the Battery will not charge.

I've had this happen to me about 6 months ago on another Dell computer where it wouldn't Charge.  I am wondering what my options are.  Are there any fixes.  I will try and upgrade the BIOS but I don't know that it will fix it.  Is it another one where the entire motherboard must be replaced?  Thanks in advance for any help you can provide.
LVL 12
kadafitcdAsked:
Who is Participating?
 
CDCCtechConnect With a Mentor Commented:
Probably the board. The center pin on the barrel connector of your adapter tells the system what ac adapter you are using. As you know, if it does not identify the adapter, it will disable the battery charging for safety. In my experience, those connectors(the one on the board) very rarely fail meaning that it is a problem with the board itself.

I believe those models have a small board with the dc jack and two usb ports on them. You might try replacing just that board. Bought one for $30 on ebay a few weeks ago.
0
 
Rob HutchinsonDesktop SupportCommented:
Did you try the simple fix already: try to pull the battery connectors out a little in the laptop's battery bay to make sure they are touching the battery?

If this doesn't work, then you are right and likely have to have the systemboard replaced which may be too expensive than replacing the laptop if you can't find a reasonably priced board on eBay.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
kadafitcdAuthor Commented:
Sorry for the inactivity on this question.  I am extremely busy at work and this has been put off to the side for now.  I should be able to get  to it in the next couple of days.  I just wanted to leave an update.
0
 
kadafitcdAuthor Commented:
OK tried the bios update.  I made sure it was the proper one with my Service Tag.  It didn't work.  It probably will help other things.  Now I'm down to the point that I have to decide whether I want to invest in a new power jack board or if I want to just sell the computer as is without charging capability.  I've already purchased a new battery for it and everything.  Heck the old one might still be good just depleted.  

I am going to give the points to you: CDCCtech.  It is the best advice and the other 2 didn't fix the problem.  Sorry guys.

Thanks again for everyone's help.
0
 
kadafitcdAuthor Commented:
Only solution to the problem left untested.  Either the power jack board or a motherboard problem.  Thanks for your help.
0
All Courses

From novice to tech pro — start learning today.