Problems with tutorial from GWT

I have never used GWT before so I am trying to run through this basic tutorial google offer.
I have a simpe to question, hopefully. It  arises from my attempt to run through the tutorial regarding the  Google Web Tools tutorial for eclipse, http://code.google.com/webtoolkit/usingeclipse.html

From the "Compile and run in Production Mode" section.

For this section it says to enter  the URL into the browser now I have tried a few different ways to do this
a) http://127.0.0.1:8888/MyWebApp/war/MyWebApp.html
this dispalys "error1.png" (see the attached) as well as the below in the console box in eclipse.

[WARN] 404 - GET /MyWebApp/war/MyWebApp.html (127.0.0.1) 1412 bytes
   Request headers
      Host: 127.0.0.1:8888
      User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
      Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
      Accept-Language: en-gb,en;q=0.5
      Accept-Encoding: gzip,deflate
      Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
      Keep-Alive: 115
      Connection: keep-alive
   Response headers
      Content-Type: text/html; charset=iso-8859-1
      Content-Length: 1412

b) file:///C:/Users/Owner/Project/MyWebApp/war/MyWebApp.html

This second ways seems to work? Is this is what is meant in the tutorial. I just want a clear understanding of what is happening here. Thanks.
bhessionAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
VenabiliConnect With a Mentor Commented:
The tutorial says:
"To see the final application, open the file MyWebApp/war/MyWebApp.html in your web browser."

So I suspect that yes - it means open the file from your file system.

You do not have a webserver running and this application is not deployed anywhere yet. In order for any HTTP request to be served, you need a server :) Further down it says:
"You could now deploy your application to production by serving the HTML and JavaScript files in your MyWebApp/war/ directory from your web servers."

So if you have a web server, you can deploy these files there. But I suspect that this is covered in another tutorial - this one seems to be for really basic stuff so you can get started.

Do you have any web server installed? Try http://127.0.0.1:8080/MyWebApp/war/MyWebApp.html and http://127.0.0.1:80/MyWebApp/war/MyWebApp.html just in case but I do not see anything in the tutorial about actual webservers...

Did you successfully do "Run locally in Development Mode"?

PS: That tutorial is a bit strange so I am not sure what they mean in half of the places and I use the API :) But then I Am used to SUn style tutorials I suspect.
0
 
bhessionAuthor Commented:
Sorry I forgot to attach this :)
error1.png
0
 
bhessionAuthor Commented:
I have Tomcat installed and I tried http://localhost::8080/MyWebApp/war/MyWebApp.html in my web browser got the following error on the browser.

HTTP Status 404 - /MyWebApp/war/MyWebApp.html

type Status report

message /MyWebApp/war/MyWebApp.html

description The requested resource (/MyWebApp/war/MyWebApp.html) is not available.
Apache Tomcat/6.0.24

Yeah I succesfully got the "Run locally in Development Mode" part going. I think its just running from the computers file system. Its just a bit confusing
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
VenabiliCommented:
Well - I do not see anything in that tutorial that tells you how to put it on your Tomcat server - unless if something from the automatic things do it.

PS: YOu do not use double : before the port, right?
0
 
bhessionAuthor Commented:
No just a single :
that must be what it refers to.
0
 
bhessionAuthor Commented:
Thank you for yourhelp. Great to get someone elses perspective.
0
All Courses

From novice to tech pro — start learning today.