Cisco 3560g switch killing xerox commuication

I have recently acquired 3 new xerox machines. (4250, and 2 phaser 3635)

These machines sit at my remote branches.

These new machines cannot communicate to head office. (I have dozens of other xerox machines that can)

In their own LANs they function fine, These machines can also talk to other remote branches just fine.

Attempts to 'talk' to head office fail. (Please see attachment "Red-Green.jpg") or if head office tries to talk to them it also fails.

The one key to all of this is that Cisco switch. Everything on the green side works fine. Everything on the red side works fine....but if you try to put traffic through the switch....and just for these 3 xerox machines, the communication fails.

For example. If server 10.13.1.221 tries to ping machine 192.168.99.5 only one out of fifty or so pings succeed. (see attachment 1.)

In attachment 1 you can see that 10.13.1.221 started a ping to 192.168.99.5.
99.5 received and replied to 1.221 (which makes it back to 1.221)
Next is that black line from the cisco switch - Something about a redirect
After that 1.221 sends pings....99.5 receives the pings...but fails to respond.

again below 99.5 attempts an SMTP communication.
cisco switch does its 'redirection'
1.226 sends and acknowledgement, but 99.5 fails to respond.

This was recorded using wireshark on my laptop, hooked to a hub, right in front of 99.5

Also attached is my cisco 'show running config.'

Please let me know if you need further information.




sw-01#show running-config
Building configuration...

Current configuration : 10172 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname sw-01
!
!
username 
username
no aaa new-model
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip routing
!
!
mls qos map policed-dscp  8 16 26 32 46 48 56 to 0
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos map ip-prec-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 3  0 1
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 3  8 9 10 11 12 13 14 15
mls qos
!
!
no file verify auto
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 1000
 name Vestibule
!
vlan 1001
 name Data
!
vlan 1300-1302
!
class-map match-any clmNortelRtp
  description Match Nortel RTP voice packets
  match access-group 100
class-map match-any clmLowPriorityData
  description Match low priority packets
  match access-group 199
class-map match-any clmNortelSignalling
  description Match Nortel Signalling voice packets
  match access-group 110
!
!
policy-map plmDataPolicies
  class clmNortelRtp
   set dscp ef
  class clmNortelSignalling
   set dscp af41
  class clmLowPriorityData
   set dscp cs1
!
!
interface GigabitEthernet0/1
 description *** Vestibule (VLAN 1300)
 switchport access vlan 1300
 switchport mode access
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/2
 description *** Vestibule (VLAN 1300)
 switchport access vlan 1300
 switchport mode access
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/3
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/4
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/5
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/6
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/7
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/8
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/9
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/10
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/11
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/12
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/13
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/14
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/15
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/16
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/17
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/18
 description *** Data (VLAN 1301) and Voice (VLAN 1302) port
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/19
 description *** To Voice (VLAN 1302) port
 switchport access vlan 1302
 switchport mode access
 priority-queue out
 mls qos trust dscp
!
interface GigabitEthernet0/20
 description *** To Voice (VLAN 1302) port
 switchport access vlan 1302
 switchport mode access
 priority-queue out
 mls qos trust dscp
!
interface GigabitEthernet0/21
 description *** To Data (VLAN 1301) port
 switchport access vlan 1301
 switchport mode access
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/22
 description *** To Data (VLAN 1301) port
 switchport access vlan 1301
 switchport mode access
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/23
 description *** To Data (VLAN 1301) port
 switchport access vlan 1301
 switchport mode access
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/24
 description *** To Data (VLAN 1301) port
 switchport access vlan 1301
 switchport mode access
 priority-queue out
 service-policy input plmDataPolicies
!
interface GigabitEthernet0/25
 description *** Trunk (VLANs 1301[n] and 1302) > To swCoquitlam-02
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 mls qos trust dscp
!
interface GigabitEthernet0/26
 description *** Trunk (VLANs 1301[n] and 1302) > To swCoquitlam-03
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 mls qos trust dscp
!
interface GigabitEthernet0/27
 description *** Trunk (VLANs 1301[n] and 1302)
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 mls qos trust dscp
!
interface GigabitEthernet0/28
 description *** Trunk (VLANs 1301[n] and 1302)
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1301
 switchport trunk allowed vlan 1301,1302
 switchport mode trunk
 priority-queue out
 mls qos trust dscp
!
interface Vlan1
 description *** VLAN 1: Unused
 no ip address
 shutdown
!
interface Vlan1300
 description *** VLAN 1300: Vestibule
 ip address 10.13.0.254 255.255.255.0
 ip helper-address 10.13.1.2
!
interface Vlan1301
 description *** VLAN 1301: Data LAN
 ip address 10.13.1.1 255.255.255.0
!
interface Vlan1302
 description *** VLAN 1302: Voice LAN
 ip address 10.13.2.1 255.255.255.0
 ip helper-address 10.13.1.2
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.13.0.1
ip route 10.13.3.0 255.255.255.0 10.13.0.1
ip route 192.168.0.0 255.255.128.0 10.13.0.1
ip http server
ip http authentication local
!
access-list 100 permit udp any any range 51000 51200
access-list 100 permit udp any range 51000 51200 any
access-list 110 permit udp any any range 7000 7000
access-list 110 permit udp any range 7000 7000 any
access-list 199 permit ip any any
no cdp run
!
control-plane
!
!
line con 0
 login local
line vty 0 4
 login local
 length 0
line vty 5 15
 login local
!
end

Open in new window

1.JPG
Red-Green.JPG
pdesjardins1Asked:
Who is Participating?
 
from_expConnect With a Mentor Commented:
I would say, that cisco is innocent and is doing its routing job.
take a look at your sniff and topology. 192.168.99.0/24 network is behind 10.13.0.2, but cisco sends traffic to 10.13.0.1 and it is sonicwall, who redirects traffic.
I would suggest correcting routing table on the switch
0
 
pdesjardins1Author Commented:
Ok. I will make that change tonight.
0
 
pdesjardins1Author Commented:
I have updated the cisco switch to read:
ip route 192.168.0.0 255.255.128.0 10.13.0.2

No change in network communication.
0
Turn Raw Data into a Real Career

There’s a growing demand for qualified analysts who can make sense of Big Data. With an MS in Data Analytics, you can become the data mining, management, mapping, and munging expert that today’s leading corporations desperately need.

 
from_expCommented:
how does routing table on intel router look like?
0
 
pdesjardins1Author Commented:
Thank you for your continued help

Intel routing table is blank.
There is only the Red Gateway (Lan) and Black gateway (internet)

The Red Gateway is 10.13.0.1
Black is our public internet address.

See attached image. Also attached is the routes for the Sonicwall

This problem is making me crazy because everything else in the network, including the other 20+ xerox machines in the company works fine. The problem is with Just these 3 machines and the only thing these machines have in common is the cisco switch. Thus my thinking the problem lies there.

intel.JPG
Sonicwall.JPG
0
 
pdesjardins1Author Commented:
The problem was with the routing tables. Although it worked for everything else, these xerox machines were overly touchy. I changed the Cisco routes to point traffic as it should be and not just sending everything to the Sonicwall. I also change the Intel table, making the Cicso the LAN gateway.
0
 
from_expCommented:
hi!
I really had that feeling that routing table could be the problem here.
sorry for my late response - it was easter time here in Europe.
0
All Courses

From novice to tech pro — start learning today.