smbclient

Hello
I have debian PDC server and 2 win xp clients,I try to send message to the xp client from samba server with " smbclient -M hostname " but always error?

please help
thanks
linuxdebianAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ClintSwineyCommented:
What is the error?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
linuxdebianAuthor Commented:
smbclient -M hotsname
Unknown parameter encountered:"SO_RCVBUF"
Ignoring unknow.......
connection to hostname failed
0
linuxdebianAuthor Commented:
Unknown parameter encountered: "SO_RCVBUF"
Ignoring unknown parameter "SO_RCVBUF"
Connection to xx failed. Error NT_STATUS_BAD_NETWORK_NAME
0
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

ClintSwineyCommented:
Is the Messenger Service turned on at the Windows XP workstation you are trying to Message? It's turned off by default. To turn it on click Start -> Run -> Type in  "services.msc" -> find Messenger, change it from Disabled to Automatic. Then click Start.

smbclient -M hotsname

again...
0
linuxdebianAuthor Commented:
yes  services enabled on xp machine
0
AbhisekSanyalCommented:
Hi,
  I am taking a big leap here, but this could very well be possible-
In your debian system, open the file "/etc/samba/smb.conf". Now, search for SO_RCVBUF.
Typically, the smb.conf file has a setting like the following (Note the # in front of the SO_RCVBUF line) -

#         SO_RCVBUF=8192 SO_SNDBUF=8192
   socket options = TCP_NODELAY

I am suspecting that someone has removed the # and it is now -

SO_RCVBUF=8192 SO_SNDBUF=8192
   socket options = TCP_NODELAY
 
This could be resulting in your problem. The correct setting would be

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

Hope that helps
 
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.