32-bit application pool in IIS7 SBS 2008

I need to run an application in 32-bit mode.  However I am on SBS 2008 if i change the default pool to 32 bit and start the app the classic.net pool stops.  If i create a new pool and set it to 32-bit then assign that pool to my application then the new 32-bit pool stops as soon as I try to launch the app.  What can i do to configure this so that it plays nice with the other applications in SBS?
Blade42Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shreedhar EtteCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blade42Author Commented:
Worked through that disabled compression and i have the same issue.  When i start the app the application pool halts.
0
Blade42Author Commented:
I created a new app pool (the classic app pool must be 64-bit on SBS 2008) named VLP32bit
Under Advanced Application properties set bit to true for VLP32bit
Edited C:\Windows\System32\inetsrv\config\applicationHost.config:
 <add name="PasswordExpiryModule" image="C:\Windows\system32\RpcProxy\RpcProxy.dll" preCondition="bitness64" />
Disabled xpress compression globally for ISS 7
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

this solved the issue found on various different forums
0
Blade42Author Commented:
I am accepting this as a solution since it pointed me in the right direction, although it was not a complete fix for my particular problem it did put me on the right track.  Addded a comment with the complete solution to the bottom.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.