Mac folder permissions problem

When trying to open a folder on my Mac i cant and there is a red stop circle over the folder icon. The folder was last used on my old mac and i was the creator /owner, but now i cant get in to it. How can i get back in?
PowerhousecomputingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirocco87Commented:
Highlight the folder. Hit the Apple Key + I (get info). There should be a sharing/permissions tab at the bottom. Try fixing the settings there. It would also help if you were an admin on the current machine.
0
PowerhousecomputingAuthor Commented:
i am admin on the current machine. when i look at the info box and unlock the padlock it says "you have no access" and the users below are greyed out with privilege set to "no access".
0
SnowWolfCommented:
Try logon using the root account.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

sirocco87Commented:
Are you accessing the folder while it's still on an external drive or have you moved it to the Users folder?

You can enable or disable permissions on a disk with the vsdbutil command:
% vsdbutil -h
Usage: vsdbutil [-a path] | [-c path ] [-d path] [-i]
where
        -a adopts (activates) on-disk permissions on the specified path,
        -c checks the status of the permissions usage on the specified path
        -d disowns (deactivates) the on-disk permissions on the specified path
        -i initializes the permissions database to include all mounted HFS/HFS+ volumes
0
PowerhousecomputingAuthor Commented:
i tried using root. this removes the red dot but i cannot see anything in the folder. the folder info windows says i can only read but the permissions are out. greyed
0
marookCommented:
Using Get Info, you need to Unlock the permissions part (click the padlock and enter admin credentials).
Enable access for All, or add yourself and set the right permissions for you.

Another GUI option, is to use BatChmod (http://www.macupdate.com/info.php/id/6440/batchmod) to correct the permissions.
Remember to 'apply to enclosed items...' so all the underlying folders get the same permissions.

If you like to use the Terminal, do
>cd theFolder/you/need/to/change
>sudo chown -R yourusername theFolderName
Password: <enterYourAdminPassword>
>sudo chmod -R 644 theFolderName

Hope it helps..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SnowWolfCommented:
In terminal, type
sudo chmod -R 777 /path/to/folder

(you can drag and drop the folder after typing 777)

This will reset the everyone permission
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.