SQL 2005 not using all the memory that is allocated to it

I have a SQL Server 2005 SP2 running on Windows 2008 64 bit machine with 12 gb of ram
I have allocated 9.5 gb of ram to SQL Server via SP_Configure - however then I go see the memory usage via Resource Monitor in Windows Server I see it only using 487000kb of memory.

Need to find out why sql server is not using all of the 9.5gb that is allocated to it.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Ok.. Kindly confirm the Min and Max values specified in your SQL Server instance.
Also let me know whether you have one or more instance in your server.
What version of SQL Server  2005 are you using?

SQL Server will use some memory as per the memory component/requirement of its architecture. With user defined tables when one does SELECT/INSERT/UPDATE/DELETE all occur in RAM. So, when lots of these happen especially SELECT fetching lot of records from big tables, your RAM usage will increase.

Also refer:

SQL Server memory architecture

Memory Management in SQL Server 2005
Dynamic Memory Management

How to adjust memory usage by using configuration options in SQL Server
SQL Server memory usage
SQL Server Memory Usage Grows and Not Shrinks
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

DavidKanAuthor Commented:
Ok.. Kindly confirm the Min and Max values specified in your SQL Server instance.
Also let me know whether you have one or more instance in your server.

Min 9500
Max: 10000

Only 1 instance running
DavidKanAuthor Commented:
What version of SQL Server  2005 are you using?

SQL 2005 Developer Edition with SP2
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Ok. Check whether you have enabled

* Lock Pages in Memory for the startup account of SQL Server service.
"Eventhough Lock Pages in Memory is not required for 64-bit operating system, it’s recommend to lock pages in memory."

* Apply SP3

Restart your machine once after the above changes..
And hope you have 64 bit SQL Server 2005 instead of 32 bit..
If you have 32 bit SQL Server 2005, then make sure you have enabled AWE..

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.