Exchange 2007 OWA - Sent Messages put into Drafts Folder

Evening.

When logging into OWA, a user who writes and sends an email will have that email end up in the Drafts folder and never be sent. I have replicated this issue myself so no user error here. Items in the drafts folder stay in even after (supposed) deletion.

When logging into Exchange over Outlook Anywhere with the same account, the user can send and receive mail without issue. However the Drafts folder is empty.

I've checked available space on the Exchange server and have over 100gb free on the drive Exchange is installed, so this is not a Back pressure issue.

I've seen several post online about this but none that I could find lead to an answer. Anyone have a guess?
LVL 1
chrisbrnsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MinoDCCommented:
Did you see if there are errors in the event view of exchange and the client from which you access the OWA?
0
MinoDCCommented:
You make sure everything is configured correctly, I use OWA without any problems, and I did not do special configurations.
Look here for correct configuration:
http://www.microsoft.com/downloads/details.aspx?FamilyID=EE292C13-C933-4F59-91D9-16E4B38F5E34&displaylang=en

or here:

http://www.outlook-web-access.com/owa-2007
0
Glen KnightCommented:
It's got nothing to do with the drive exchange is insalled on, what's important is the drive the log files are on.  It needs to have more than 4GB of free space.

I would also make sure the server is upto date, at least Service Pack 2.  And run the best practice analyzer and see if that gives any ideas
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

chrisbrnsAuthor Commented:
I should have mentioned in my main post, the issue started after the installation of SP2.  However, the server is fully patched in regards to Exchange 2007.  The exact version is v8.2 Build 176.2.

Also the logs are writing to the same drive Exchange is installed on.  However the C drive has 25gb free space where the Exchange drive has 100gb free.

I ran all of the analyzer tools and the server passed all scans using default settings.

i've set up exhange several times and from all i know the owa is set correctly.  I made no custom alterations save adding the external URL

I do notice even id 12014 source MSExchangeTransport.  It says that the certificate I am using is not found in the personal certificate store.  I imported this cert from the Exchange powershell.  I will add the cert to the store, restart and test.
0
MinoDCCommented:
Use this cmdlet for setting correctly the certificate:

http://technet.microsoft.com/en-us/library/aa997231.aspx
0
chrisbrnsAuthor Commented:
The cmdlet I used was;

Import-ExchangeCertificate -Path E:\email.domain.com.crt | Enable-ExchangeCertificate  -Services iis

i've also disabled TLS as an ecryption option for my receive connector
0
MinoDCCommented:
you must enable the certificate after importing.
You can use this cmdlet:

Get-ExchangeCertificate <thumbprint>

copy, certified's thumbprint you want to use
next:

Enable-ExchangeCertificate <thumprint>-Services "IIS"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MinoDCCommented:
next you must use IIS Manager to associate a specific certificate with those Web sites trought Edit Binding
0
MinoDCCommented:
Select site and in the treeview (on the right) and click Bindings... in the Actions pane.  This brings up the bindings editor that lets you create, edit, and delete bindings for your Web site.

Select HTTPS and click Edit and select correct certificate.


binding.jpg
0
chrisbrnsAuthor Commented:
I've ran the cmdlet as indicated.  I've also checked the bindings in IIS and the default website was set to use the proper certificate.  Verified this via the OWA site and looking at the certificate.

I've restarted the server and tested.

Although sent items are no longer stuck in drafts, oddly a message that is sent displays that it is in the drafts folder, however upon clicking the drafts folder it is empty and the message was in fact sent.  Seems rather a small thing now but I know this isn't the way OWA normally behaves so i'm not sure if I should move forward with moving users to this server or not.
0
chrisbrnsAuthor Commented:
Meh, after looking at another working OWA setup and some reading, the appearing to go into drafts is by design.  The issue seems resolved.

Thanks
0
chrisbrnsAuthor Commented:
Even though we followed the documentation from MS about adding certificates via Powershell, this last command was left out and is needed to enable the certificate.
0
FernandoMadrugaCommented:
I'm having the same problem stated here and this solution didn't solve. Anything else I can try?
0
jr60Commented:
One thing that can cause that is when the Microsoft Exchange Mail Submission service is not running on the mailbox server.
This service was running on our server but we still had the issue, so we restarted the service (ended up having to kill the process), then restarted it and voila, it all started moving again.
Hope this helps.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.