How to configure Cisco 877 W

Dear All,

Can anyone help me with step by step configuration for Cisco 877w router.

I got a new router. When i connect it to adsl the internet doesnt work.
my running configuration attached with this


Regards,

Vikas
cisco877#show run
cisco877#show running-config
Building configuration...

Current configuration : 1854 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco877
!
boot-start-marker
boot-end-marker
!
enable password 7 pwd123
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid melbourne
   authentication open
   guest-mode
!
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username admin password 7 pwd123
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 ip address 192.168.9.1 255.255.255.0
 ip virtual-reassembly
 !
 ssid melbourne
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
!
interface Vlan1
 ip address 192.168.8.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
!
interface Dialer0
 no ip address
!
interface Dialer1
 mtu 1454
 ip address negotiated
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp chap refuse
 ppp pap sent-username coinopsolutions@optusnet.com.au password 7 pwd12345
17
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
 password 7 pwd123
 login local
 no modem enable
line aux 0
 password 7 pwd123
 login local
line vty 0 4
 password 7 pwd123
 login local
!
scheduler max-task-time 5000
end

cisco877#

Open in new window

kavinagpurAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tombourCommented:
Can you ping the an outside ip address from the router?

At first sight your nat rule seems to be missing

ip nat inside source list 101 interface Dialer1 overload
access-list 101 permit ip 192.168.8.0 255.255.255.0 any
access-list 101 permit ip 192.168.9.0 255.255.255.0 any
0
kavinagpurAuthor Commented:
I didn't configure Preferred DNS & Gateway on router
Is it necessary or not ?

Thanks
0
tombourCommented:
dns-server not really
default gateway yes:

ip route 0.0.0.0 0.0.0.0 dialer1
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

tombourCommented:
err my bad: in the access list use wildcard masks instead of subnet masks:

access-list 101 permit ip 192.168.8.0 0.0.0.255 any
access-list 101 permit ip 192.168.8.0 0.0.0.255 any

0
kavinagpurAuthor Commented:
How to configure Default gateway

Thanks
0
tombourCommented:
that's the command i gave u before

ip route 0.0.0.0 0.0.0.0 dialer1

you can always set the following command as well (but imho its not necessary):

ip default-gateway <ip address of isp's gateway>
0
tombourCommented:
dialer-list 1 protocol ip permit is also missing

If it still doesnt work, post current config again plz
0
kavinagpurAuthor Commented:
Didn't get any success
here is my running configuration, Please suggest

cisco877#show run
Building configuration...

Current configuration : 2344 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco877
!
boot-start-marker
boot-end-marker
!
enable password 7 pwd123
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid melbourne
authentication open
guest-mode
!
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username admin password 7 pwd1234
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
ip address 192.168.9.1 255.255.255.0
ip virtual-reassembly
!
ssid melbourne
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
54.0
station-role root
!
interface Vlan1
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
!
interface Dialer0
mtu 1454
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp chap refuse
ppp pap sent-username coinopsolutions@optusnet.com.au password 7 pwd123
!
interface Dialer1
mtu 1454
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp chap refuse
ppp pap sent-username coinopsolutions@optusnet.com.au password 7 pwd123
17
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Dialer0 overload
!
access-list 101 permit ip 192.168.8.0 0.0.0.255 any
access-list 101 permit ip 192.168.9.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
line con 0
password 7 pwd123
login local
no modem enable
line aux 0
password 7 pwd123
login local
line vty 0 4
password 7 pwd123
login local
!
scheduler max-task-time 5000
end

0
GJHopkinsCommented:
You have no interesting traffic defined for the dialer - the command under dialer 0 "dialer-group 1" refers to a list which defines which traffic will initiate dialing. So you need to add

see tombour's post above  you need

dialer-list 1 protocol ip permit

The access list for NAT  is 101 but the NAT statement refers to100

ip nat inside source list 100 interface Dialer0 overload
!
access-list 101 permit ip 192.168.8.0 0.0.0.255 any
access-list 101 permit ip 192.168.9.0 0.0.0.255 any

so change

no ip nat inside source list 100 interface Dialer0 overload
ip nat inside source list 101 interface Dialer0 overload



Also can tidy up with

no interface dialer 1

and

interface Dot11Radio0
ip nat inside

if you want the wireless stuff to reach the internet.

Other points to consider

do you need dhcp for the lan devices, this can be added to the router.
do you want the wireless and wired devices on the same LAN, this is more common in the Cisco setup for this router but requires bridging and a BVI interface.

I can supply configs if needed.
0
kavinagpurAuthor Commented:
Thanks GJHopkins,

I had not noticed too much on it, You have a good knowledge,
Yes ur guess is correct, I want the wireless and wired devices on the same LAN, also want DHCP
can u suggest me how to configure bridging and a BVI interface.

Thanks

Vikrant
0
GJHopkinsCommented:
Ok this should get you going - some comments inline adjust as you need - this is set up for wireless WPA encryption


ip dhcp excluded-address 192.168.8.1 192.168.8.1
!
! extend range to cover any fixed ip ranges  you want to exclude
!
ip dhcp pool LAN-POOL
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 208.67.222.222 208.67.220.220
   lease 0 2                                                  

!
! these are OPEN DNS servers - can change to your ISP if requried
!
int VLAN 1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled    
!
!
! add vlan to bridge goup
!
! Wireless

dot11 ssid melbourne
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii your key goes here          



interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid melbourne
 !
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding          
!
interface BVI1
 ip address 192.168.8.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly  
!
!
bridge 1 route ip

no access-list 101 permit ip 192.168.9.0 0.0.0.255 any


Some handy commands

sh atm interface atm0

sh ip nat translations

sh ip dhcp bind

sh dot11 associations
0
kavinagpurAuthor Commented:
Hello GJHopkins,

Thanks for giving step by step guidence but ,Can you tell me there is missing something in my running configuration, because i am unable to access internet through router..

Just want to access Internet through router then i will configure DHCP & BVI interface.
cisco877#show run
Building configuration...

Current configuration : 2054 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname cisco877
!
boot-start-marker
boot-end-marker
!
enable password 7 XXXXXXXXXXXXXXXXXXXXX
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid melbourne
   authentication open
   guest-mode
!
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username admin password 7 XXXXXXXXXXXXXXXXXXXXX
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 ip address 192.168.9.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 !
 ssid melbourne
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

 station-role root
!
interface Vlan1
 ip address 192.168.8.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
!
interface Dialer0
 mtu 1454
 ip address negotiated
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp chap refuse
 ppp pap sent-username coinopsolutions@optusnet.com.au password 7 XXXXXXXXXXXXXXXXXXXXX

!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer0 overload
!
access-list 101 permit ip 192.168.8.0 0.0.0.255 any
access-list 101 permit ip 192.168.9.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
line con 0
 password 7 112A160A1B130C09247B72737A
 login local
 no modem enable
line aux 0
 password 7 112A160A1B130C09247B72737A
 login local
line vty 0 4
 password 7 112A160A1B130C09247B72737A
 login local
!
scheduler max-task-time 5000
end

Open in new window

0
GJHopkinsCommented:
Everything looks OK can you check the following

Has the ppp authentication worked and an ip address allocated to the router ?

Do a show ip int brief  and show ip route to check this.

Can you ping an internet address from the router ?

What ip settings are on a PC you are using to test with ? Do an ipconfig /all in windows ifconfig -a in OS X/linux

Is the NAT working

do a show ip nat trans

etc

0
kavinagpurAuthor Commented:
I am unable to ping VLAN
cisco877#ping ip 192.168.8.1 source 192.168.9.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.8.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.9.1
.....
Success rate is 0 percent (0/5)

atleast we should able to vlan1 from HyperTerminal
0
kavinagpurAuthor Commented:
Hello GJHopkins,

Only 1 issue is remaining i attached some output, please can u look & give me a guidence.

we are able to ping internet address from HyperTerminal but unable to access internet from System(we are able to ping router from system)
System IP is : 192.168.8.2
subnet         : 255.255.255.0
Gateway     : 192.168.8.1
Dns              : 192.168.8.1
preffered     : is blank


Thanks



Output.txt
0
kavinagpurAuthor Commented:
i went to configure BVI interface & DHCP
Everythig we to fine but when I ran below line i got error
cisco877(config)#interface bvI 1
Integrated Routing and Bridging is not configured!
                               ^
% Invalid input detected at '^' marker.

please suggest

Thanks
0
GJHopkinsCommented:
Ok i think the system issue is a DNS issue the PC has the router as the DNS, you need an internal or external DNS server try your ISP one or use 208.67.222.222 see www.opendns.com


can you ping the internet from the PC - say  ping 8.8.8.8 ( a good one to remember for tests google-public-dns-a.google.com.)

BVI interface issue

yes sorry I forgot the command

bridge irb

this is needed to activate integrated routing and bridging.


I'm not 100% sure the wireless will work without irb so traffic from .8 to .9 isn't a good test
0
kavinagpurAuthor Commented:
had a bit of luck this time, if I enter the DNS of ISP manually then it works but won't work on 192.168.8.1
but will work on ISP DNS, when previously it wasn't
My ISP DNS 198.142.0.51 203.2.75.132 , Please suggest

Thanks
0
GJHopkinsCommented:
the DHCP server needs to give the PC the DNS server addressing.

so configure the DHCP scope  the router with

ip dhcp pool LAN-POOL
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 198.142.0.51 203.2.75.132
         

otherwise you will have to configure each PC manually.
0
kavinagpurAuthor Commented:
If anyone I configure 192.168.8.1 in preffered DNS it shoud work (Manually) because I configure Server & Backup Server Manually But i don't want put DNS IP of ISP, I want to put the router IP Address in Gateway, Preffered DNS
what should we do for that

Please suggest

Thanks
0
GJHopkinsCommented:
I'm not sure what you are asking - the  router is not a DNS server so adding 192.168.8.1 as the DNS server entry will not prevent you routing to the Internet but it will prevent the PC resolving names to IP addresses using DNS.

The default gateway needs to be the router 192.168.8.1, the DNS needs to be a DNS server, either an internal one, the ISP one or one of the Open Servers.

If you are saying that you want to configure DNS severs manually then you can set that on the PC, but they have to be DNS servers not the router.
0
kavinagpurAuthor Commented:
means I want to if someone  enter Manually IP in System,  So it should not need to put the ISP's DNS,
His work should be done by putting 192.168.8.1 in Preffered DNS

I have two site , Where the router Address  doing works as a DNS, means i put Router IP in Gateway also Preffered DNS,
if u need a configuration i will give u

Thanks
0
GJHopkinsCommented:
Not sure what you mean do you want the router to act as a DNS proxy server?

it can act as a proxy server - add in

ip dns server

 and the details of your actual dns

ip name-server 198.142.0.51
ip name-server 203.2.75.132

you may also want to add the domain name

ip domain name mycompany.com

you would then use the router address as the dns server address either manually or in dhcp
0
kavinagpurAuthor Commented:
My Running IP of LAN
System IP      : 192.168.8.2
Subnet Mask : 255.255.255.0
Gateway      : 192.168.8.1
Preff. DNS    : 198.142.0.51

If I keep Setting As per Above in System of LAN, that time we are able to Access Internet
But when I changed as per below
System IP      : 192.168.8.2
Subnet Mask : 255.255.255.0
Gateway      : 192.168.8.1
Preff. DNS    : 192.168.8.1
that time we are unable to access Internet but want this for Manual Configuration also DHCP

I hope u understand my question
Thanks
0
GJHopkinsCommented:
For the PC to have

System IP      : 192.168.8.2
Subnet Mask : 255.255.255.0
Gateway      : 192.168.8.1
Preff. DNS    : 192.168.8.1

the router needs to have the following added

ip dns server
ip name-server 198.142.0.51
ip name-server 203.2.75.132

the dhcp scope needs to change to

ip dhcp pool LAN-POOL
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 192.168.8.1


0
kavinagpurAuthor Commented:
If I use as per below
ip dns server
ip name-server 198.142.0.51
ip name-server 203.2.75.132

the dhcp scope needs to change to

ip dhcp pool LAN-POOL
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 192.168.8.1

we are unable to access Internet
0
GJHopkinsCommented:
when this happens what are the settings on the PC - can you do a ipconfig /all from a cmd window

0
GJHopkinsCommented:
also have you added a domain name to the router

ip domain name "name"
0
kavinagpurAuthor Commented:
If I use as per below
ip dns server
ip name-server 198.142.0.51
ip name-server 203.2.75.132

the dhcp scope needs to change to

ip dhcp pool LAN-POOL
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 192.168.8.1

we are unable to access Internet
&  the settings on the PC I attachet alonf with this
Connection-specific DNS Suffix: 
Description: Broadcom NetXtreme Gigabit Ethernet
Physical Address: ¿00-17-A4-E0-ED-A3
DHCP Enabled: Yes
IPv4 Address: 192.168.8.11
IPv4 Subnet Mask: 255.255.255.0
Lease Obtained: Monday, April 05, 2010 11:13:30 AM
Lease Expires: Tuesday, April 06, 2010 11:13:30 AM
IPv4 Default Gateway: 192.168.8.1
IPv4 DHCP Server: 192.168.8.1
IPv4 DNS Server: 192.168.8.1
IPv4 WINS Server: 
NetBIOS over Tcpip Enabled: Yes
Link-local IPv6 Address: fe80::5991:db05:4db5:17f5%11
IPv6 Default Gateway: 
IPv6 DNS Server:

Open in new window

0
GJHopkinsCommented:
Ok that looks fine. I have tested this and it does work so there must be something in your config.

can you check that DNS is working from the router itself - ping www.cisco.com will do

post the key parts of the router config - NAT access lists, interface configs, name-server configs etc

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kavinagpurAuthor Commented:
Thanks GJHopkins
Our issue Has been solve There was only Acl issue
If you Have VOIP Experience pls help me on below issue

http://www.experts-xchange.com/Networking/Telecommunications/IP_Telephony/VoIP/Q_25418294.html
0
kavinagpurAuthor Commented:
yes
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.