Visio Viewer Does Not Work

After installing Visio Viewer 2007 (or 2003 for that matter), cannot open Visio files. IE 7 launches but I get a "little red x" in the upper corner of the screen. Can't seem to find any solution for this. This happens on more than one computer.
nwadmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

steveoskhCommented:
Probably a security setting in your browser.  I believe Vision uses some ActiveX controls to display it in the browser.  If security is locked down they will not show.   Assuming you can change the security settings, lower them and see if the viewer works.  
0
nwadmanAuthor Commented:
Sorry steveoskh, that didn't do anything. Any other ideas?
0
steveoskhCommented:
There is a known issue if Visio 2002 was installed on the computer.  Unlikely to be your issue if it is multiple machines.  
A search on IE 7 Visio Viewer will bring up quite a few posts of problems with ie7 and the viewer.    Most solutions involve allowing active content or changing the security zone for files.  Interesting is that one person had this problem opening from a local drive or network but could view it fine if opened from a USB stick.

I am fairly sure that when I had this issue it was a browser setting for allow active content.  I no longer have a machine with IE7 to test it, and I downloaded the beta for Visio2010 so I can not test the viewer.

http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/9211e9b9-c39c-41c4-ba68-e1a184a69f5f
http://support.microsoft.com/kb/926948
http://support.microsoft.com/kb/934366
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
Can you try on a system with IE8? It's much better about this sort of thing.

Scott
0
nwadmanAuthor Commented:
It was indeed an active content security setting in IE. Even though previously I had lowered the security level in IE (Tools > Internet Options > Security), I was still getting the same thing - a blank page with a rex x in the upper left corner of the screen. Following steveoskh's instructions, I enabled the  "allow active content to run in files on My Computer" (Tools > Internet Options > Advanced > Security) and now Visio files open properly. Thanks for the help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.