Unable to change password in Exchange 2010 OWA

for some reason, we are unable to change passwords using Exchange 2010 OWA.

users get the error "password does not meet the complexity requirements"
yet we are clearly entering a password that does.

I've tried disabling pwd complexity still same error.

any suggestions?

thanks!

S.
siber1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ggefterCommented:
can you change the password in AD? or on a local machine?
0
siber1Author Commented:
yes, that works fine. its just in OWA that we are seeing this behavior.
0
ggefterCommented:
ok, then this should do it:
http://support.microsoft.com/kb/297121
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

AkhaterCommented:
this doesn't look like on OWA problem to me

how many Domain controllers do you have ? when did you change the policy ?
0
siber1Author Commented:
Hi Akhater, I changed the policy over 2 hours ago.
here is the exact error we see when trying to change any of the passwords via OWA:

The password you entered doesn't meet the minimum security requirements.

any ideas why this is happening?
this is exchange 2010.  thx
0
AkhaterCommented:
how many Domain Controllers you have ? can it be a replication issue ?


on the exchange server if you run gpedit.msc and check the local password policy what is it set to ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
siber1Author Commented:
thx. seemed to clear after about 90min. but i had to remove complexity requirement. i think there is still an issue with EX2010 / OWA when complexity is set.
0
tiinettechCommented:
I'm having the same problem and I don't have the complexity enabled. any ideas?
Thanks:
0
sulebustCommented:
Experienced a similar problem, and the solution was to change the "Minimum Password Age" from 1 to 0 in the security policy. Dont disable the policy, just set it to 0.
0
SandyCommented:
sulebust : Boss you are champ.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.