Meta HTTP Redirect happening before download of activeX . happening too quickly in IE7 Not waiting for yellow bar prompt

The following code works in IE 6 and older. The code is supposed to prompt to download/run the object if it is not already installed on the machine. If it is installed it simply refreshes and loads index.html.

If the machine does not have the object installed already it should prompt /yellow bar/ to run the object. In IE7 & IE8 this donesn't happen. I can hear the prompt /yellow bar/ but it refreashes to the index.html before you can click the yellow bar to ask to download the object.
<head>
<OBJECT WIDTH=0 HEIGHT=0
    CLASSID="CLSID:7DD62E58-5FA8-11D2-AFB7-00104B64F126"
    ID=myobj
    CODEBASE="http://www.swiftview.com/product/current/svinstall_a_stat.cab#Version=5,3,0,4"
   >
   <PARAM NAME="SRC" VALUE="http://www.swiftview.com/tech/svrel.zhp">
   <PARAM NAME="SCROLLBARS" VALUE="vertical">
   <PARAM NAME="COMMANDS" VALUE="gui controls display rightbuttons|dpage last">
   </OBJECT>
<meta HTTP-EQUIV="Refresh" Content="0;URL=index.html">
</head>

Open in new window

jennifer_merrittAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Michel PlungjanConnect With a Mentor IT ExpertCommented:
so change to


<meta HTTP-EQUIV="Refresh" Content="5;URL=index.html">

or use javascript

window.onload=function() {
  if (document.getElementById('myobj')) location.replace('index.html')
}
0
All Courses

From novice to tech pro — start learning today.