• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1376
  • Last Modified:

Solaris 10 lp problems

I am installing a new Solaris 10 X86 server and attempting to get network printers working with no luck.  The commands I used for Solaris 9 and back do not appear to work.  These are simple jetdirect devices with an IP.

Here is what I have done, which worked on Solaris 9 but not with Solaris 10:
1. The printer is hpnet defined in /etc/hosts
2. Added the printer: lpadmin -p 0001p -o protocol=bsd,dest=hpnet -T PS -I postscript -v /dev/null -i /usr/lib/lp/model/netstandard
3. Enabled the printer: enable 0001p; accept 0001p
4. Created the filters for text:
lpfilter -f catv -F /etc/lp/fd/catv.fd
lpfilter -f download -F /etc/lp/fd/download.fd
lpfilter -f dpost -F /etc/lp/fd/dpost.fd
lpfilter -f postdaisy -F /etc/lp/fd/postdaisy.fd
lpfilter -f postdmd -F /etc/lp/fd/postdmd.fd
lpfilter -f postio -F /etc/lp/fd/postio.fd
lpfilter -f postior -F /etc/lp/fd/postior.fd
lpfilter -f postmd -F /etc/lp/fd/postmd.fd
lpfilter -f postpages -F /etc/lp/fd/postpages.fd
lpfilter -f postplot -F /etc/lp/fd/postplot.fd
lpfilter -f postprint -F /etc/lp/fd/postprint.fd
lpfilter -f postreverse -F /etc/lp/fd/postreverse.fd
lpfilter -f posttek -F /etc/lp/fd/posttek.fd
lpfilter -f pr -F /etc/lp/fd/pr.fd

When I print a text file, only the banner prints - no text.  So, I then modify /etc/lp/interfaces/0001p to set nobanner=no to nobanner=yes.

Now, nothing prints - no postscript, no text, no banner - nothing.  No errors in any logs.  An lpstat will show it printing, then nothing.

lpstat -p -l is:
printer 0001p idle. enabled since Fri Apr 02 11:05:00 2010. available.
        Form mounted:
        Content types: application/postscript
        Description:
        Printer types: PS
        Connection: direct
        Interface: /usr/lib/lp/model/netstandard
        On fault: write root
        After fault: continue
        Users allowed:
                (all)
        Forms allowed:
                (none)
        Media supported:
                (none)
        Banner required
        Character sets:
                (none)
        Default pitch:
        Default page size:
        Default port setting:
        Options: protocol=bsd, dest=hpnet
0
djpriceAtl
Asked:
djpriceAtl
  • 4
  • 2
1 Solution
 
yuzhCommented:
Please have a look at the answer in http:Q_23204262.html
0
 
djpriceAtlAuthor Commented:
I saw that one and followed those same steps but it did not resolve my probem.  My problem is a little different though, nothing prints for me - for that question they were getting something, it was just not filtered properly.  Those are the exact same steps I have used for all Solaris versions prior to 10, they do not appear to work for Solaris 10.  Nothing prints with the 'lp' command for me.  However, lpr works, also printing from a browser works - lp does not work.  I cannot print text or postscript, before disabling the banner only a banner would print.

This is a new Solaris 10 X86 install with the recommended patch cluster installed.
0
 
djpriceAtlAuthor Commented:
Ok, progress made (?) but it's still not right:

'lp file_name' does not print.

'lp -c file_name' prints.

Why/what would cause Solaris 10 to require/need the -c (copy) flag?  How do I set lp to print not requiring the -c flag?  Maybe this is a bug that has a patch not inlcuded in the latest patch cluster - I will look there.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
yuzhCommented:
It could be the lp bug for Solaris 10 x86, try to install the lp patch for Solaris 10x86 to see if it can fix it.
PS: I only have Solaris 10 (Sparc) boxes, could not test it for you.
Did you set any default print?  use "lpstat -t "  command to find out.
0
 
djpriceAtlAuthor Commented:
I do have a default printer set.  I think I am current with patches, I have installed the latest recommended patch cluster but that might not include the lp patch you are referring to.  Do you have a Patch ID# (if you only have the Sparc patch ID, I can get the X86 patch ID)?  In checking some, I have installed 141445-09 and 140121-01 for X86 - I could not find any other lp patches but there are so many they are sometimes hard to find.

I was thinking from the way this is acting it may be a bug also, you would think someone has seen this before though - I installed Solaris 10 x86 10/09 but the patch cluster was dated March '10 - it's not like it's a new O.S.   I contacted Sun/Oracle but have not heard anything.
0
 
AmolCommented:
-c                     Copies file before printing.

                            Unless -c is specified, users  should
                            not  remove any file before the print
                            request   has   completely   printed.
                            Changes  made to file after the print
                            request is  made  but  before  it  is
                            printed  might  be  reflected  in the
                            printed output. file  is  linked  (as
                            opposed to copied).

can you disable the filters and try if its printing properly...
0
 
djpriceAtlAuthor Commented:
Giving me the patch ID would have been very helpful, I finally found patch 143358 on my own which corrected the problem.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now