Folder Redirection user files viewable to other users

I have folder redirection setup and working well. However, the users that I have setup folder redirection for can see each others files.

Folder redirection is set to a folder titled UserProfiles on the server. User Bob can browse to the UserProfiles folder on the server and view his, Jim's, Carl's, and all other users files.

Here is how I have it setup:
On the Target tab:
Settings: Basic - Redirect everyone's folder to the same location
Target Folder Location: Create a folder for each user under the root path
Root Path: \\WINSERVER2008\UserProfiles
On the Settings tab:
Grant the user exclusive rights to the Documents is checked
Move the contents of Documents to the new location is checked
Redirect the folder back to the local userprofile location when policy is removed is selected

As for sharing and folder permissions, I have the following for the folder UserProfiles:
Sharing:
Authenticated Users and Administrators have full control
Permissions:
System has full control of This folder, subfolders, and files
Creator Owner has full control of Subfolders and files
Administrator has full control of This folder, subfolders, and files
Domain Admins has full control of This folder, subfolders, and files
Staff (group of users) has full control of This folder, subfolders, and files
No permissions are inherited.

I have ran gpupdate/force

What do I need to do so that users cannot view other users files?
jerrywin5Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AnnOminousCommented:
You need to add each user individually to the permissions, and remove the Staff group. You may be able to do this is a generic way using Creator Owner rather than each individual user, but possibly not.

The first step would be to check the permissions on the Documents folder when not redirected, and then simply replicate those permissions to the redirected folder. That should yield the same behavior.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jerrywin5Author Commented:
Since on the Settings tab I have "Grant the user exclusive rights to the Documents" checked, I am denied access to user's documents. I have now unchecked this. However, when I try to change permissions on the Documents folders, I do not have permission. When I try to view the folders directly in Explorer, I get the error, "You currently don't have access to this folder. Click her to get access to this folder". After clicking on Continue I get the error, "You have been denied permission to access this folder. To gain access you will need to use the security tab". I don't have permission to change the settings on the security tab. How can fix this?
0
AnnOminousCommented:
Take Ownership of the direcories and files, then you willbe able to change/replace the security settings.

But I'd suggest that you first log in under one account in question (or create one for testing) in order to confirm what the security settings are for the actual user who will be accessing the directory.
0
jerrywin5Author Commented:
I used SubInACL to resolve the folder permissions issue.

See: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7
/Q_25011061.html

Thanks for your help, AnnOminous
0
jerrywin5Author Commented:
Found part of solution elsewhere.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.