ORA-01152: file 1 was not restored from a sufficiently old backup

I am getting the following error


RMAN> alter database open resetlogs;

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of alter db command at 04/02/2010 10:28:11
ORA-01152: file 1 was not restored from a sufficiently old backup
ORA-01110: data file 1: '/oracle/oradata/xxx/system01.dbf'
BABU123Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

turnbulldCommented:
It means the DB cannot make itself consistent because that file is too new relative to the others and the available logs.  The DB tried to roll itself forward and there is a gap between the last point in time the DB could be made consistent and the contents of this file.

You may need to recover more redo logs or you may need to recover an older copy of this file.  If you haven't recovered any files, this can be caused by the DB being aborted and the redo logs removed or made unavailable.  
0
BABU123Author Commented:
Here is what I am trying to do..

We are testing restore and recovery using RMAN

1.I FTPed all the backup files from production to development box.
2. Issue restore controlfile from this backup copy from production..WORED FINE
3. Issued RESTORE database= Worked fine
RMAN> recover database;

Starting recover at 02-APR-10
using channel ORA_DISK_1

starting media recovery

unable to find archive log
archive log thread=1 sequence=33391
Oracle Error:
ORA-01547: warning: RECOVER succeeded but OPEN RESETLOGS would get error below
ORA-01152: file 3 was not restored from a sufficiently old backup
ORA-01110: data file 3: '/oracle/oradata/XXC/cwmlite01.dbf'

If I am doing wrong...please provide the steps I should do


giving err
2
0
k_murli_krishnaCommented:
First and foremost, check this:
ORA-01152: file string was not restored from a sufficiently old backup
http://ora-01152.ora-code.com/

You have to restore complete last valid backup and open your database.

Refer from string 'what would you do that now you have lost controlfile ,you dont have copy either you dont have autobackup on for controlfile,you need to create the control file' in:
http://forums.oracle.com/forums/thread.jspa?threadID=595603

Also refer:
ORA-01152: file 1 was not restored from a sufficiently old backup
http://oraware.blogspot.com/2008/05/ora-01152-file-1-was-not-restored-from.html
Controlfile Recovery Requires RESETLOGS
http://www.ardentperf.com/2007/05/09/controlfile-recovery-requires-resetlogs/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
POracleCommented:
ORA-01152: file 3 was not restored from a sufficiently old backup

This means your controlfile and datafile are not synchronized. your controlfile is older and datafile 3 is newer.
Why you restore controlfile? if you have latest controlfile available  then restore it then restore backup and then try to recover database. Make sure that all archived log file are available to recover database.


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.