code builder will not work in forms on Access 2003

I have one Access 2003 program that works perfectly fine on Terminal Server 2008 but another one that does not.  Everything works fine except the forms.  I get the "object or class does not support the set of events" error.  I am unable to get the code builder on the form to work.  I have tried the following:
1.  Created a new database and pulled all of the objects from the old one.
2.  Taken the one that does work, deleted all objects, imported from the one that does not.
3.  Made sure that all macros are enabled.
4.  Set the directory as a trusted center.
5.  Verified that the references in both databases are exactly the same.
6.  Verified that Track Name AutoCorrect is off
7.  Compiled the database - no errors
8.  Compact and repair
9.  Decompiled and recompiled

Where do I go from here?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I checked the Public forums and found the most frequently cited causes of the error you are getting are problems with utilizing the correct versions of vb ibrary references when running multiple versions of Access on the same machine..  See this link:

Another frequently cited cause is a form control that uses outdated (for Access 2003) comdlg32.ocx instead of the more current mscomct2.ocx. It was resolved by obtaining a copy of mscomct2.ocx.from a machine that is working correctly and registering it in the windows registry  as follows.

Copy it to C:\Windows\System32
Register it: regsvr32 c:\windows\system32\MSCOMCT2.OCX

If neither of the above fixes your problem, let me know.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Does the trouble app run okay outside of a TS environment?

What references do you have in the the trouble app? Are you 100% certain that they are installed correctly?

Did this just occur, or is this a new app just installed?

Have you fully updated the Office/Windows installs on the TS box?

How does the user launch the application? Is there a shortcut?
rockydeeAuthor Commented:
to puppydogbuddy:
1. I am running Access 2003 only on the terminal server - I assume that is what you mean by multiple versions.
2. mscomct2.ocx is the file on the system

to lsmconsulting:
1. The app runs fine outside the TS environment
2. The references work fine in 2 other apps I have out there which says to me they are working fine and they are
    a. Visual Basic For Applications
    b. Microsoft Access 12.0 Object Library
    c. OLE Automation
    d. Microsoft DAO 3.6 Object Library
    e. Microsoft ActiveX Data Objects 2.1 Library (have tried higher versions as well with no difference)
3. It is not a new app just placed recently on the TS and it works fine elsewhere
4. Office/Windows is fully updated on the TS
5. The user launches a bat file that checks for a newer version which it copies down if there is.  The same type of bat file that is used for the other two apps that have no problems
Hope that answers your questions and many thanks for working with me on this.
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
If you are ONLY running Access 2003 on the TS box, then your references are wrong:

"Microsoft Access 12.0 Object Library" is the reference for Access 2007, not 2003. This typically comes about due to opening this file in 2007, then trying to open it in 2003. Opening an 03 file in 2007 will upgrade the ref, but then opening THAT file in 03 will NOT downgrade the ref.

The "fix" is to always do your dev work in 03 - or at the very least, make sure that you do your "final build" in 2003, and check the references while in that session of 2003.
rockydeeAuthor Commented:
Found the problem.  I was unaware that my IT person had loaded both Access 2003 and 2007.  The programs were trying to load under 2003.  When I had them load under 2007, everything worked fine.  Thank you, puppydogbuddy, for suggesting multiple versions could be the problem.  I am awarding the points to puppydogbuddy.  Thank you, lsmconsulting, for taking the time to respond to this question.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.