Have a workflow send an email to a queue.

I am going to edit the question in hopes someone can assist.  

I am trying to create a workflow that sends an email to a queue based on certain events.  To break it down I started off by trying to send an email to the queues email address.  What I noticed was that only emails sent from outside the domain come into the queue but if I open the Queues email box I see emails both sent internally and externally, just only the ones that were sent from outside the domain make it into the queue box.

So I figured it was an email router problem.  I tried over 50 different ways just playing with it an nothing is working.  I am getting really frustrated now but hopefully someone knows how to fix this.  
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmckaneAuthor Commented:
I also went into the Email Router on the server and published the Users and Queues, and tested access to the queue I created and it has access.  

I tried just sending an email to eservice@domain.com and see if it would show up in the queue but it does not.  If I open up the eservice@domain.com web access account I can see all of the test emails that were sent to it.  
jmckaneAuthor Commented:
Can anyone please assist with this?
jmckaneAuthor Commented:
Queue Settings
•      Email = eserviceupdate@domain.com
•      Convert to e-mail activities = All e-mail messages
•      Email Access Type Incoming = Forward Mailbox
•      Email Access type Outgoing = Email Router

Email Router Configuration
•      Incoming and Outgoing profiles are setup and working as tested
•      Under the Deployments Tab the company is working correctly and has been for the last 2 18 months
•      Under Users and Queues the EserviceUpdate queue shows up and doesn’t have an incoming profile because its set to use a Forward Mailbox
•      Under the forward mailbox I have it setup correctly and tested it.  

•      If I send an email message to EServiceUpdate@domain.com I quickly open the Forward Mailbox account and I can see it sitting in the inbox.  If I send an email to EserviceUpdate@domain.com from my gmail account I see it go into the Forward Mailbox inbox and then about 20 seconds later its deleted because I have it set to delete and it shows up under the Queue in CRM.  However, if I send from my company email account to eserviceupdate@domain.com I see it enter the forward inbox and 20 seconds later its automatically deleted but never ends up in the queue.  So  it’s getting sent to the forward mailbox correctly but the forward mailbox is not sending it to the queue.  
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

Feridun KadirPrincipal ConsultantCommented:
Although this won't help you, I can confirm that the way you have set things up is fine.

I have seen on other forums people mention that they have problems catching internal e-mails to a queue but haven't found a resolution.

jmckaneAuthor Commented:
I figured out the problem buried in a Microsoft KB Article.


I just had to add this registry key and volia!

you must add the DoNotIgnoreInternalEmailToQueues entry to following registry subkey on the CRM server:
Set this registry entry to the DWORD type, and then set the value as follows:
0 = False
False value will ignore internal e-mail messages to queues.
1= True
True value will not ignore internal e-mail messages to queues.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Feridun KadirPrincipal ConsultantCommented:
Clever you!  

I'll certainly make a note of that for the future.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Enterprise Software

From novice to tech pro — start learning today.