• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1387
  • Last Modified:

Exchange server

I have an Exchange server 2003 with SP2

Some mails servers can't send mail to my server and gets an error message:

Tue, 30 Mar 2010 20:38:48 -0700 (PDT)
Error reading SMTP packet; response to dot-stuffed message expected; likely problem with network or remote SMTP server

Other servers especially public ones such as hotmail or g-mail have no troble

mail server address is athena.hayesthelawyer.com and test mail can be sent to administrator@hayesthelawyer.com
0
rmurakami
Asked:
rmurakami
  • 5
  • 2
1 Solution
 
B HCommented:
you have some kind of performance issue with your smtp server.

telnet athena.hayesthelawyer.com 25
(waits 45 seconds)
finally get the 220 line like i should
i issue helo whatever.com
(waits forever)...literally...

cannot continue.

the root cause is, the performance on your smtp server is preventing the sending servers from saying 'enter dot enter' at the end, to close the message.

what did you change recently in relation to exchange/smtp?  any new smtp sink, spam filter, gateway, etc?

check out the exchange best practice analyzer, it might find your cause and issue a fix

http://www.microsoft.com/downloads/details.aspx?FamilyID=DBAB201F-4BEE-4943-AC22-E2DDBD258DF3&displaylang=en
0
 
Shreedhar EtteCommented:
0
 
rmurakamiAuthor Commented:
the server is located in seattle.

When I telnet to it from another system in Seattle, it's instantaneous.  Where are you?

As for shreedhar's sugestion, port 25 isn't being proxied just forwaded.
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
B HCommented:
i'm in cleveland :)  but distance is pretty irrelevant on the internet, more important is the firewalls between us (yours)

if you do it from within your own network, and it's instant, that explains the server as being fine... and points to a firewall problem

how's that exchange best-practice analyzer coming?
0
 
B HCommented:
hmm, now it's not slow.  maybe we had 500 experts hitting your mailserver at the same time before.

now, it's very quick and i see no errors:

220 athena.hayesthelawyer.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.1830 ready at  Fri, 2 Apr 2010 15:20:20 -0700
helo whatever.com
250 athena.hayesthelawyer.com Hello [my-ip-address]
mail from:<joe@whatever.com>
250 2.1.0 joe@whatever.com....Sender OK
rcpt to:<administrator@hayesthelawyer.com>
250 2.1.5 administrator@hayesthelawyer.com
data
354 Start mail input; end with <CRLF>.<CRLF>
subject: test from experts-exchange guy bryon44035v3
test
test
test
sgjfkjasgka
gdfsagksdajga
using telnet here
ending mail now...
.
250 2.6.0 <ATHENAdUFSF0FrTLi0N00000006@athena.hayesthelawyer.com> Queued mail for delivery
0
 
rmurakamiAuthor Commented:
I found the solution to my problem.

The Qwest Actiontec M1000 DSL modem was dropping packets larger than 1464.  Using ping IP_address -f -l 1472, the computer would return request timed out.  I adjusted the MTU setting for the network card of my Exhange server and the issue is resolved
0
 
B HCommented:
wow awesome find!

don't feel obligated to assign points if you found the answer yourself, just accept your own comment 29503473 as the answer
0
 
B HCommented:
now that it is resolved, i am requesting attention from a moderator to edit all these comments and remove your personal info - there's a LOT of bad things people can do with hosts/ip's
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now