Windows 7 Pro Displays "Preparing Desktop" Message (Intermittently) Upon Login

I'm running Windows 7 Pro on a Dell Latitude E5500.  The machine is approximately two months old.  During the past 2 weeks, I'm experiencing the following behavior.

Upon login, immediately after I enter my password, a "Preparing Desktop" message displays for approximately 10-15 seconds.  After the message displays, I am logged into the machine as a guest user.  If I restart the machine, I can login to the admin account as usual (without the "preparing desktop" message).  This problem is intermittent and is happening approximately once out of every four logins.

An error message in the system tray indicates that I should "see event log" for details.  I do not know how to access the event log, nor would I know what to look for if I found it.

Thanks in advance for your help.

cnealy
LVL 1
cnealyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan_StewartCommented:
Check out what event viewer says:

http://www.windows7update.com/Windows7-Event-Viewer.html

There might be an issue with your profile (basically this is the information such as whats on your desktop, whats in your "my documents" etc)
Its worth checking the event logs errors and posting on here to let us know what you see
Thanks!
0
acl-puzzCommented:
Hi

just disable this guest user you dont need it... here is command::-

net user guest active:no

Cheers
0
cnealyAuthor Commented:
Dan - I've attached a screen print of the Windows errors and warnings in the event log since the first login attempt today (when the "Preparing Desktop" message occurred).

acl-puzz - I need the guest user, so disabling is not an option for me.
4-12-Event-Log.jpg
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

acl-puzzCommented:
can you paste output of this command here?goto run type cmd and then issue following command

sc query
0
acl-puzzCommented:
and also tell me do u have any security software installed? for instance this company http://securityinnovation.com/about/pr_20040217.htm

it also looks to me  that any software on yours system need TPM service enabled its trusted platform module and its hardware based security also you need to have TPM chip on yours motherboard in built to use this feature
0
cnealyAuthor Commented:
I issued the sc query command and DOS window quickly scrolled by and closed.  Need to know how to get the output of the command.

I am a novice home user, so I do not have any special security software enabled (that I am aware of).  
0
acl-puzzCommented:
sc query | more now it will show you all ist page wise simply right click and click on mark now you can select its output and paste it here

also give an screenshot of Wlan-Autoconfig warning message in yours logs Even it 10002

do you have Wlan-Autoconfig service enabled?
0
cnealyAuthor Commented:
sc query | more did not give me any output

I don't know if I have Wlan-Autoconfig service enabled.  

XML for Event 10002:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-WLAN-AutoConfig" Guid="{9580D7DD-0379-4658-9870-D5BE7D52D6DE}" />
  <EventID>10002</EventID>
  <Version>0</Version>
  <Level>3</Level>
  <Task>0</Task>
  <Opcode>0</Opcode>
  <Keywords>0x4000000000000000</Keywords>
  <TimeCreated SystemTime="2010-04-03T01:51:37.623081000Z" />
  <EventRecordID>18135</EventRecordID>
  <Correlation />
  <Execution ProcessID="984" ThreadID="4512" />
  <Channel>System</Channel>
  <Computer>Cetchren-Laptop</Computer>
  <Security UserID="S-1-5-18" />
  </System>
- <EventData>
  <Data Name="ExtensibleModulePath">C:\Windows\System32\bcmihvsrv.dll</Data>
  </EventData>
  </Event>
0
acl-puzzCommented:
it does!! see pix attached

to check you have WLAN-autoconfig status goto run type services.msc and at down you see it check its current state


Untitled.jpg
0
cnealyAuthor Commented:
Current state of WLAN AutoConfig is "Started."

I still cannot capture the output of sc query. " sc query | more" does not give me the output.
0
_Commented:
>> I issued the sc query command and DOS window quickly scrolled by and closed.  Need to know how to get the output of the command.

You need to do the -- CMD > Enter -- first, to get a DOS box. Then do the -- sc query -- at that Prompt.
Then you can scroll up and down in the DOS box.
0
cnealyAuthor Commented:
coral47 - thanks.  That helped.  

Now, I just need to know what DOS command to issue to pipe the output to a text file, so that I can post it here.
0
acl-puzzCommented:
sc query  >  C:\sc-output.txt
0
cnealyAuthor Commented:
I got  "Access is denied." when I entered the following command at the DOS prompt:

sc query > c:\sc-output.txt

I am logged in as the administrator.
0
acl-puzzCommented:
its strange it give error here its working see attached pix...
sc-output.PNG
0
cnealyAuthor Commented:
This worked: sc query  >  c:\users\myusername\sc-output.

Output attached.
sc-output.txt
0
acl-puzzCommented:
when system says "preparing desktop" its setting whole environment for the user which includes default user profile etc. there is NO problems in it do u have any more weird thing happening at yours system let me know so that i can help in that also.

anyways ........may i know why you are using guest account on system?

and if have WLAN-autoconfig service enabled on yours computer its very risky to have guest account enabled

read the description of this service goto Run type services.msc and see this service there and its description at left



0
cnealyAuthor Commented:
System is running fine.  No other odd behaviors.  I use guest account for friends/family who need to use my machine (rather than giving them administrator access).  However, I have never used guest account on this machine.  It is a new laptop.

I read the description of the service and it sounds like something that I need.  I have WiFi in my home and others in the home connect to my machine through the wireless network.  If I disable WLAN-autoconfig, then that will no longer work.

I don't understand the connection between WLAN-autoconfig and guest account.  Please explain.  Thanks.



0
acl-puzzCommented:
"I don't understand the connection between WLAN-autoconfig and guest account.  Please explain.  Thanks."

i know you cant disable this as you need it for yours Dell Wireless WLAN adapter

" I use guest account for friends/family who need to use my machine (rather than giving them administrator access).  However, I have never used guest account "

if they can access an hacker also access using many tools like net stumbler and there many which back-track linux has wont go much deep into it as it can lead this question to  an endless discussion....

0
cnealyAuthor Commented:
OK, so you are recommending that I disable guest account, which will resolve my problem, correct?

I can try it for awhile and see if it helps.  I did not set-up a guest account, so whatever account that is enabled is a default.

Please provide instructions on how to remove the guest account.
0
acl-puzzCommented:
all iam saying is having guest account enabled on any system is an security loophole thats what i wanted to say in my last comment...

If you want to disable(not removal) guest account simply right click on my computer >manage see the pix
guest.jpg
0
cnealyAuthor Commented:
OK, just to clarify, this is not something that you are suggesting to resolve my original problem.  Is that correct?
0
acl-puzzCommented:
first stanza of comment id  29762811 is where i answered yours actual question answer may be you didnt read it ..

i saw yours output sc command output i saw WLAN-Autoconfig is disabled+ guest account is enabled so  to secure yours pc i suggested to disable this account

if any more queries please ask :)

0
cnealyAuthor Commented:
I did read it, and I still don't understand how it resolves my problem.  Here is what is says:

"when system says "preparing desktop" its setting whole environment for the user which includes default user profile etc. there is NO problems in it."

This tell me what it is doing, but it doesn't tell me how to stop it.  
0
acl-puzzCommented:
all you want to stop system saying "Preparing desktop" ?

we can not stop system to do this and why we need it? is there any harm in it? no

i again saying when we enter our password OS loads our user profile from C:\User dirctory which contain default user settings environment variables sometime it loads up fastly some time it doesnt due to speed of loading it which depend on data this user profile have there nothing specific on data type here.

that why sometime says it and sometime doesnt

i"ll suggest you to download ccleaner and delete all junk from system drive which is C:\


0
cnealyAuthor Commented:
Perhaps my description was not clear.  What is happening is that I am getting the "preparing desktop" message and then I am being logged in as a guest user automatically.  After this happens, an error message in the system tray indicates that I should "see event log" for details (so there is some type of system problem that is preventing it from logging in as the Admin).  I have to reboot the machine in order to login as the Admin at this point.
0
acl-puzzCommented:
"d then I am being logged in as a guest user automatically"

you mean you dont even click on guest user on logon screen and it takes you to desktop without clicking or using keyboard?

if this is correct simply disable this guest account as suggest above
0
cnealyAuthor Commented:
Yes, I don't click on anything, it is happening automatically without prompting from me.
0
acl-puzzCommented:
ok first disable it and then type this command

control userpasswords2

take a screenshoot now to show me its dialog box

and also click on advanced and there check the box where it shows "Require users to press CTRL+ALT+DEL"

click ok

reboot yours pc it shold fix it
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cnealyAuthor Commented:
I will do this tonight when I get home (I am on Pacific time in the U.S.).  Thanks.
0
acl-puzzCommented:
ok and also run an scan on C:\ drive with this

 http://download.cnet.com/Spybot-Search-amp-Destroy/3000-8022_4-10122137.html

to avoid any bad program running on yours system :)

0
cnealyAuthor Commented:
I followed the instructions and discovered that guest account was already disabled.  I have never accessed this menu before.  So, I was surprised when I found this.  I've attached a screenshot of user passwords2.  And, I selected the "require ctr-alt-del" on the advanced tab.

I will monitor and see if the error happens again after a few days.  
userpasswords2.jpg
0
acl-puzzCommented:
ok and make sure Guest  user is only member of "Guest" default group to check this follow the same pix  in comment id 29807941 just look for "member of" tab

and what were results of scanning?

anyways you dont have to wait for many days just give yours pc 3-4  reboot to  test if it works or not.



0
cnealyAuthor Commented:
I have not performed the scan yet.  But, I did validate that the guest account is only a member of the guest group.

I prefer to wait for a few days because this issue does not happen every time.  Sometimes it doesn't happen for several days and then it occurs again.  I want to rule out "time" as a root cause of this issue (rather than testing by rebooting several times in a row on the same day).

I will accept your solution if the problem does not happen for at least one week.  I assure you that I will not forget about you.  I used to answer questions on experts-exchange many years ago.  So, I understand how important it is to accept a solution when it is resolved.
0
acl-puzzCommented:
i said that because reboot is the process where you have to login after kernel passes the control to registry not when we use switch user where all registry settings are already loaded

i hope you get me right so waiting for days is pointless  as it will only increase the time to solve the problem suppose if after 4 reboot you get the same problem then we can think of alternatives isnt?







0
cnealyAuthor Commented:
I hear you but suppose that I accept the solution (and pay the 500 points) and then the problem occurs again tomorrow.  Then, I have paid the points for nothing.

I will wait.  I give you my word that you will get your points if the problem does not occur again within a week.
0
acl-puzzCommented:
"I hear you but suppose that I accept the solution (and pay the 500 points) and then the problem occurs again tomorrow.  Then, I have paid the points for nothing."

dear cnealy

i only stay at an question if there an opportunity to learn and dig deeper if i think an question is not worth for me and for the author to seek my answer i say sorry i wont be able to help anymore that is what iam following from last week of feb 2010 when i answered my first question

and there many times when  it happened when somebody needed help after accepted solution i did help them even they didnt gave me  point now what do you think about me iam looking for point s at EE? :)

tc
0
cnealyAuthor Commented:
Hello acl -

Just wanted to let you know that I have not encountered the problem again.  I will let it "soak" until Monday and then I will accept your solution.  In summary, what do you think resolved this issue?
0
acl-puzzCommented:
Hi Cnealy,

we tried alot of things as we all do to solve a problem but i think CTRL+ALT+DEL that we enabled did solve it

its an security option that stops any automated logon where user have to use CTRL+ALT+DEL before getting option for typing their username and password

thats my point :)
0
cnealyAuthor Commented:
There was a bit of a disconnect at the beginning regarding solution offered for the issue that I described.  However, I suspect that this was simply a language problem that was easily overcome.  

0
cnealyAuthor Commented:
Thank you very much for solving this for me.  
0
acl-puzzCommented:
you are welcome
0
cnealyAuthor Commented:
This issue is happening again.  I am going to open a new question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.