restirct mailbox from exchange server 2003

Hi Exprty,

i have exchange server 2003

our IT policy that its not allowed to any body to keep his mails on the serevr - becasue we dont have storage solution- and all must use pst as thier default

problem is:
some users open thier outlook and change the default from pst to mailbox
and result is all thier mailboxes are saved on the server

i sent an IT officer to change the setting to pst, and after he keave thier office they again change it to teh mailbox

if i were in thier place i will do the same, till IT found a system polciy that restrice the not allowed users

how i from exchange server 2003 allow and dis allow users t use mailboxes
LVL 5
thabashAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian PiercePhotographerCommented:
It does seem to rather defeat the object of having exchange in the first place it users are not allowed to keep their messages on the server. I would seriously reconsider this policy. Disk storage is cheap these days and the cost of providing additional storage to my mind is insignifficant compared with the  costs of on-going management, support and loss of many of the benefits of exchange which are associated with using local PST flies only - it seems a crazy policy to me.
0
Hilal1924Commented:
You Have Couple of Options:

1. Use group policy to limit their access to Account Settings. Follow this link to achive this:
http://www.howto-outlook.com/howto/policies.htm
2. Use Storage Limit Option on Your Exchange Server ..Say people can only have upto 10MB mailbox size. After they reach 10MB limit, they will not be able to send email. And when they reach 15 MB they will not able to recive mail either. That way They will be forced to use PST.

Cheers,
Hilal
Limits.png
0
thabashAuthor Commented:
is there a way to force exchange download their mailbox to pst file
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Hilal1924Commented:
From Exchange Server, No there is no such option. But like I pointed above you can use Group Policy and Storgae limits to achieve your objective.

Cheers,
Hilal
0
Hilal1924Commented:
Hi Sorry, Disregard the above Picture. This is the correct one.
Limits.jpg
0
rakoczyCommented:
To force the use of cached mode (PST file) you can use the descrition on this page:

http://articles.techrepublic.com.com/5100-10878_11-6093822.html?tag=content%3bleftCol

But be aware that this will block regular MAPI connections for these users. If one of the users changes the cached mode setting, they will not be able to contact the exchange server. But that is what you wanted, right?

Download ADModify.NET from here:
http://admodify.codeplex.com/releases/view/6065

***ALTERNATIVELY***
In my opinion it is better to handle this via GPO if possible. And it is. The following extract shows you how to do this in GPO. I take it for granted that you are familiar with GPO's, if not let me know. Be aware the following: The GPO settings you see when you open GPMC on a server or computer is based ON THE LOCAL ADM(ADMX files on that very computer. That is why you will see different GPO options when editing GPO's from a XP computer than from a Windows 2008 server, or Windows 7. The article explains how to import the ADM files for seeing Outlook options and setting them in your GPO. The article explains how to do this.

***START ARTICLE***
To lock down Cached Exchange Mode options in Group Policy

In Group Policy, load the Outlook 2003 template (Outlk11.adm).
To require Cached Exchange Mode for users, under User Configuration\Administrative Templates\Microsoft Office Outlook 2003\Tools | E-mail Accounts\Cached Exchange Mode, double-click Disable Cached Exchange Mode on new profiles.
Click Enabled to enable configuring the policy.
Clear the Check to disable Cached Exchange Mode on new profiles check box.
Click OK.
To specify that new user profiles will use Cached Exchange Mode and to select the download mode for new user profiles, double-click Cached Exchange Mode (File | Cached Exchange Mode).
Click Enabled to enable configuring download options for Cached Exchange Mode in new Outlook user profiles.
In the Select Cached Exchange Mode for new profiles drop-down list, select a download option. For example, select Download Full Items.
Click OK.
To disallow setting the option to Download Full Items for existing user profiles with Cached Exchange Mode configured, double-click Disallow Download Full Items (File | Cached Exchange Mode).
Or you can enforce other download settings by using one of the following policies instead:

Disallow Download Headers then Full Items (File | Cached Exchange Mode)

Disallow Download Headers (File | Cached Exchange Mode)

Click Enabled to enable configuring the policy.
Select the check box in the policy.
Click OK.
It's important to be aware that, despite its name, the Disable Cached Exchange Mode on new profiles policy setting just described applies to existing as well as new profiles. Also note that in the user dialog box where this setting is first displayed, the setting value shown is determined from the user profile, not from the policy setting.
*** END ARTICLE***
Extract from http://office.microsoft.com/en-gb/help/HA011402591033.aspx

Download ADM files from here or search through your office CD:
Office 2003: http://office.microsoft.com/en-us/ork2003/HA011513711033.aspx
Office 2007: http://www.microsoft.com/downloads/details.aspx?FamilyID=92d8519a-e143-4aee-8f7a-e4bbaeba13e7&displaylang=en

Good luck!
0
rakoczyCommented:
I dont understand why all these people bother to polute the question with all this BS.

@Hilal1924 If you don't know how to do it, it doesn't mean it can't be done.

@KCTS Wether or not you think the question is "the best way to do it" or not is totally irrelevant.

Sigh..
0
Hilal1924Commented:
@rakoczy:

First of All, Cached mode is a client side implemntation which needs to be modified from either GPO and Administrative Controls. I repeat myself that it can't be done via Exchange (I Insist On it) What you have suggested via ADMODIFY.Net is basically forcing people to use Cached Mode, which can be either in Offline mode or Online Mode. If Cached Mode is used in online mode , an OST will be created on the local system but data will still remain on the server which is what he does not want. It defeats the purpose of having small mailbox size and if it is in online mode the data will still be on the server. So they still need to make offline copies of the mailbox if they want to use Cached mode.


@thabash: Please use the GPO settings to achieve your target.

Cheers,
Hilal
0
Hilal1924Commented:
@rakoczy: From your comment " To force the use of cached mode (PST file) you can use the descrition on this page"

Cached Mode uses OST's Not PST's. Please ensure you understand the difference.

Cheers,
Hilal
0
rakoczyCommented:
Good call on the ADModify solution. I agree. Use my exquisite guide on the GPO settings instead.

Your argument about Exchange is just for the argument and really not interesting regarding the question. It can't be done via INI files either, who cares? You may feel free to insist on such details if it pleases you.
0
rakoczyCommented:
Yes I see the typo there, good call on that one too. I should have been more specific about offline cached mode and online cached mode. Hope it doesn't confuse anyone.
0
thabashAuthor Commented:
Hi Hilal1924;
We enable the limits on Exchange mailbox store and it works but we want to give limit per user,if we enable size limit on mailbox store it will be default for all.please let me know how i can do for per user size limitation.
0
Hilal1924Commented:
If you don't want to limit organization wide, you can Active Diretory Users and Computers to limit it. Go to the properties of the user and go to Exchange General Tab and from there you can set the limit.
0
Hilal1924Commented:
This ScreenShot can Help:

ADUC-Limit.png
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thabashAuthor Commented:
Hilal
i tried but it didnt work
user tariq al habash as an example
his mailbox size is 274,415 KB

i went to the user property->storage limit and i make issue warning at 5000 KB

and i didnt receive any warning can you please explain what is the mistake
pls see the photo
i need only to warn thi suser,

is this fail because i already exceed the limit??? but warning should come
pls advice
mailboxsize.JPG
ad-limit.JPG
0
Hilal1924Commented:
Warning will come next time he does a Send/Recieve
Do a Test:

Create a New Mailbox , Set the Limit to 5000KB like you did in the above example. Configure 5000 KB in  Issue warning at and Prohibit Send and Recieve at.  Fill up his mailbox by sendning a 5MB attachment or email and then see if he gets the warning. In my Opinion He definitely should get a warning. Regarding above User, He also should get a warning. Configure one more option for the user whose mailbox is 274,415 KB. Put his Send/Recieve limit at 280,000 KB. That would be a good Test. Let me know if it worked for you.

Cheers,
Hilal
0
thabashAuthor Commented:
hilal

i receievd the warning in my mailbox at 12:am, seems by default it mail you at midnight, maybe this is the reason why it didint come at after noon.
seems its solved. but is there a way to change the default check, as it only show form the mailstore setup, but from user side (AD) it dont show option, and it come at 12 am
warn-mail.JPG
0
Hilal1924Commented:
That is not the default behavior, Everytime you exceed the limit the mail is sent to you, irrespective of the time. It might have come at 12:00 AM as default behavior but that is just a coincidence when Mailbox Assistant runs. You can modify from the MailServer and changes will propagate to Active Directory as well.

One Friendly Advice: Whenever you post a Screenshot or an Image, make sure it does not contain any sensitive info. Just post whatever is releavant and omit the information that might identify you or your company. Like in the above email I can see the tasks that are assigned to you, In the image before This, I see the IP address, Name, Configuration of your server which should be private and not exposed.

Cheers,
Hilal
0
thabashAuthor Commented:
hilal

many thanks for your suuport i appreciate your advice as well
0
thabashAuthor Commented:
thanks for the support

all workng as per my expectation,
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.