Still problem synchronizing HTC Hero with MS Exchange server 2010

A couple of days ago I asked a question about what could be wrong with our sync between HTC Hero and MS Exchange Server 2010. I then thought I had resolved the problem and therefor closed the question. However...

My own phone, a HTC Hero now works flawlessly (this is why I closed the previous question). Mail, contacts and calendar all work well.
So, I moved forward to the next step in our organization, last wednesday I synced two other Hero-phones with the same server. Neither of them worked. Both work well with mail and contacts but as soon as I get to calendar I get the message "Synchronization is experiencing problems."
I tried to put my own account on one of the phones and that works just like on my own so the phones themselves shouldn't be a problem.
Since last time I've also tried to sync one of the problematic accounts with other phones, a SE Xperia X1 running WM 6.5 and a HTC Tytn II running WM 6.1. Both phones sync the calendar ok.
On the Android phones, everything created directly in outlook works fine to sync, even calendar, but as soon as I import the old calendars the syncronization stop working. I can however open the imported calendar items and make some small adjustment, save and then it's possible to sync them. The problem is that each phone have about 600-1800 calendar items and I don't really want to open each item, make a change and save. It's 9 different Hero phones...
After my last thread I also tried to import a pst file directly into the exchange server using the Import-Mailbox command. No luck though.

Any sugestions?? Would it be possible somehow to have either exchange or outlook make some small change in every calendar item and save that??? Since that work if I try it manually maybe that would be a work-around.
xtpxtpAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Please have a read of my blog article that might help you out with your other devices:
http://alanhardisty.wordpress.com/2010/03/05/activesync-not-working-on-exchange-2010-when-inherit-permissions-not-set/ 
0
Alan HardistyCo-OwnerCommented:
If the sync in inconsistent, then it may be the imported items.  Did you import via the server or via Outlook?
Importing viA Outlook can resolve issues like this.
0
xtpxtpAuthor Commented:
I checked the inherit-check box and it is checked. And this is a completly new server with a new forest so no migration of users.

The sync is quite consistent in that It never work on the android phone, and it always work on the Windows Mobile phones for the "other" users.
it always work on my hero phone, I haven't tried my account on a WM-mobile

I have tried both ways of import, both Import-Mailbox and through outlook. I also tried to move all the items to my hard drive so that each item becomes a file, erase them all in the exchange calendar and then move them back. This is when my own phone started work but no luck with these two.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Alan HardistyCo-OwnerCommented:
Okay - just to confirm - you have an account that syncs happily with an Xperia X1 and an HTC TYTN II but not tte HTC Hero - is that correct?
Is your SSL cert a 3rd party Trusted Root certificat?
0
xtpxtpAuthor Commented:
That is correct. calendar ok on those two phones

Yes, the certificate was issued by Digi Cert

I've also tried to configure the server to allow sync without ssl through port 80 but with the same result
0
xtpxtpAuthor Commented:
And as I wrote; my own Hero work so there shouldn't be a problem with the certificate.
Also, if I open a calendar item, modify it somehow and save, that item suddenly start working when I sync the phone. I've tried this several times with only a single calendar entry in the calendar
0
Alan HardistyCo-OwnerCommented:
Thanks - just checking.
So if you sync the Hero to a new account with nothing in it, and create new items in the calendar etc, does it sync properly?
0
xtpxtpAuthor Commented:
Yes
0
Alan HardistyCo-OwnerCommented:
Hmm - sounds like store corruption.  Can you move the problem user to another store please and then try synching again.
0
xtpxtpAuthor Commented:
If you by store mean Mailbox database, it didn't have any effect.
I tried to create a new mailbox database on the same server (only have one server) and did a local move to the new database. when it had completed I tried to re-sync but no luck
0
Alan HardistyCo-OwnerCommented:
Yes - that is what I meant.
Okay - can you please export all items via Outlook to a .PST file, delete all items and then import them back in again and then try syncing.
0
xtpxtpAuthor Commented:
ok; status on this:

Initial status: sync not ok
<exported calendar items to pst-file (currently 2 items in the calendar)>
<erased the entire calendar>
Status: sync ok
<imported the pst-file again>
Status: sync not ok

A couple of days ago when I started out I used Outlook 2007 and now I'm using Outlook 2010 beta
0
Alan HardistyCo-OwnerCommented:
So if you export the calendar, delete the calendar items and then add an item manually and sync, does the phone sync?
0
xtpxtpAuthor Commented:
If I do that, the new single item syncs ok
0
Alan HardistyCo-OwnerCommented:
Okay - so all is well if you don't import items.  Sounds like you have found a 'feature' of Exchange 2010 (read bug).
Are you on Exchange 2010 Rollup 2 yet?
http://www.microsoft.com/downloads/details.aspx?FamilyID=6d3ae3e0-3982-46d6-9e9c-7d7d63fae565&displaylang=en 
0
xtpxtpAuthor Commented:
I had the same problem a couple of days ago when I used 2007. This is the reason why I upgraded to 2010, to see if that solved the problem. I'm almost considering installing a outlook 2003 on a virtual pc just to see if the problem remains.

When I take a non-syncable item and put it in a folder, that item is 29k in size on disk. When I add a space extra in the subject in the calendar-item, save, open it again, remove the space, save and then put that one in a folder the item is suddenly 30k...
somehow to me it feels like there is something the android phone doesnt like in the imported items but that that "flag" or whatever it could be is being removed when I re-save.
0
Alan HardistyCo-OwnerCommented:
Are the Hero phones on the same ROM version / Updates etc?
http://www.htc.com/www/supportdownloadlist.aspx?p_id=283&act=sd&cat=all
There is a ROM and Sync update available - can you make sure you are on the latest ROM and hae installed the Sync update please, then test again.
0
xtpxtpAuthor Commented:
Yes, they are on the latest ones both of them. The one I have here was updated three days ago to the same version as the one I am using on mine.
The sync update is not for exchange sync but for outlook sync/file sync using cable if you are using win7
0
Alan HardistyCo-OwnerCommented:
Have you added the bad account to your known working Hero and does that work properly?
0
xtpxtpAuthor Commented:
No, that didn't work.
0
Alan HardistyCo-OwnerCommented:
Well if that is the case, it seems to be a store problem.

Bearing in mind that moving the mailbox to another database does not solve the problem, I would recommend calling Microsoft as it seems to be a bug that only they will be able to solve.
0
Alan HardistyCo-OwnerCommented:
My only other thought is to import the mail into another .pst file, then import from the second .pst file and see if that works.  It could be your original .pst file that is corrupt slightly.
0
Alan HardistyCo-OwnerCommented:
The question was abandoned because you didn't respond to the last comments made.
0
xtpxtpAuthor Commented:
Didn't work
I ended up taking one month at a time for each user, when I found a month that didn't work I took one week at a time within that month, found which week, did the same for day in week and finally for individual meetings in that day. In each of the problematic calendars I found two or three meetings that was corrupt somehow, when these were removed I could sync with no problem. Recreated the meetings in the calendars and those recreated ones worked.
0
Alan HardistyCo-OwnerCommented:
I bet that was great fun ; )

A little surprised that moving the mailbox from one store to another did not iron out the problems by leaving the corrupted items behind.
0
xtpxtpAuthor Commented:
I don't think you and I have the same deffinition of fun... :)

Yes, so was I. Several of the above sugested solutions should had fixed the problem but no luck. I still have one Nokia E90 that can't sync the calendar but right now I hope he will realize he need something else (he is the only one with a nokia in the company)...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alan HardistyCo-OwnerCommented:
Ah well - you win some, you lose some.

Either way - I am glad you are sorted and sorry that you had to resort to the fix that worked for you.

I hope you had lots of caffeine to hand ; )
0
VincentDefourCommented:
Just modify all your calendar items, for example by adding an additonal category by change your view to "list" or "list all active" and selecting all your appointments. Add a category, remove the category and switch back your view. Now you can happy sync your calendar with E2k10:-)
0
xtpxtpAuthor Commented:
I will try this if I run into the same problem in the future. "Unfortunately" all phones work right now...
0
Alan HardistyCo-OwnerCommented:
You should accept your answer as the solution where you went through a month at a time rather than delete the question.  There is value in the question and comments.
0
xtpxtpAuthor Commented:
I agree, there is a lot of interesting information for future reference...
0
Alan HardistyCo-OwnerCommented:
Thanks.
Alan
0
Alan HardistyCo-OwnerCommented:
xtpxtp - You have chosen the wrong comment - please accept comment ID 32925185 as the solution.
Alan
 
http:#a32925185
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.