[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3694
  • Last Modified:

macbook pro snow leopard 10.6.3 slow shutdown

I just couldn't figure out why my macbook is taking such a long time to shutdown. It used to take only 5 seconds to shutdown since I press the shutdown button.

As the log shows, I pressed the shutdown key around 15:55:15, and it did not shutdown until 15:55:36, which is around 20 seconds. I want it to be within 10 seconds. Does anybody have any suggestion?

system log:

Apr  3 15:54:53 laptop SyncServer[3355]: [110f00] |SyncManager|Warning| removing client com.appigo.Appigo_Sync from plan because I couldn't send it a sync alert
Apr  3 15:55:15 laptop com.apple.launchd.peruser.501[2099] ([0x0-0x1e01e].com.apple.systemevents[2578]): Exited: Killed
Apr  3 15:55:15 laptop com.apple.launchd.peruser.501[2099] (com.apple.AirPortBaseStationAgent[2526]): Exited: Killed
Apr  3 15:55:15 laptop com.waltop.waltoptablet[2528]: Unexpectedly back from CFRunLoopRun()!
Apr  3 15:55:15 laptop loginwindow[37]: DEAD_PROCESS: 37 console
Apr  3 15:55:15 laptop /Library/StartupItems/HyperPenTabletDriverStarter/Executables/HyperPenTabletDriver.app/Contents/MacOS/HyperPenTabletDriver[699]: Logout Occurred
Apr  3 15:55:15 laptop auditd[3457]: Auditing enabled
Apr  3 15:55:15 laptop auditd[3457]: Got low space trigger
Apr  3 15:55:15 laptop auditd[3457]: auditd_read_dirs(): all audit log directories over soft limit
Apr  3 15:55:15 laptop auditd[3457]: renamed /var/audit/20100403225032.not_terminated to /var/audit/20100403225032.20100403225515
Apr  3 15:55:15 laptop auditd[3457]: New audit file is /var/audit/20100403225515.not_terminated
Apr  3 15:55:15 laptop user[3462]: audit warning: allsoft
Apr  3 15:55:15 laptop user[3463]: audit warning: soft /var/audit
Apr  3 15:55:15 laptop user[3464]: audit warning: closefile /var/audit/20100403225032.20100403225515
Apr  3 15:55:15 laptop ntfs-3g[2509]: Unmounting /dev/rdisk1s1 (OneTouch)
Apr  3 15:55:15 laptop KernelEventAgent[38]: tid 00000000 received event(s) VQ_DEAD (32)
Apr  3 15:55:15 laptop com.apple.kextd[15]: Error reconsidering volume /Volumes/BOOTCAMP.
Apr  3 15:55:15 laptop shutdown[3467]: reboot by user:
Apr  3 15:55:15 laptop shutdown[3467]: SHUTDOWN_TIME: 1270335315 917035
Apr  3 15:55:35 laptop mDNSResponder[36]: mDNSResponder mDNSResponder-214.3 (Feb 11 2010 04:49:16) stopping
Apr  3 15:55:35 laptop mDNSResponder[36]: mDNS_Register_internal: Shutting down, can't register   20 laptop._device-info._tcp.local. TXT model=MacBookPro5,5
Apr  3 15:55:35 laptop DirectoryService[20]: BUG in libdispatch: 10D573 - 1960 - 0x10004004
Apr  3 15:55:35 laptop ARDAgent[2521]: CGSShutdownServerConnections: Detaching application from window server
Apr  3 15:55:35 laptop ARDAgent[2521]: CGSDisplayServerShutdown: Detaching display subsystem from window server
Apr  3 15:55:35 laptop AppleVNCServer[2575]: CGSShutdownServerConnections: Detaching application from window server
Apr  3 15:55:35 laptop AppleVNCServer[2575]: CGSDisplayServerShutdown: Detaching display subsystem from window server
Apr  3 15:55:36 laptop WindowServer[673]: hidd died. Reestablishing connection.
Apr  3 15:55:36 laptop WindowServer[673]: Unable to create event queue via hidd: (0x10000003)
Apr  3 15:56:15 localhost com.apple.launchd[1]: *** launchd[1] has started up. ***
Apr  3 15:56:27 localhost bootlog[50]: BOOT_TIME: 1270335375 0
0
vip2000
Asked:
vip2000
  • 7
  • 5
  • 2
2 Solutions
 
strungCommented:
You should NOT shut down by pressing the shutdown button. The only safe way to shut down a Mac is to pull the Apple Menu down to Shut Down. If you use the power button, you are in effect crashing the computer deliberately and this will corrupt your disk drive and files.

I suggest you do a safe boot by booting while holding down the shift key to force a disk directory repair.

Then open Disk Utilty (found in the /Applications/Utilities folder) and run Verify Disk to make sure any disk errors have in fact been corrected. Then run Repair Permissions.

Once that is done, try shutting down properly by pulling down the Apple Menu to Shut Down and see if there is any improvement.
0
 
joseph_gormanCommented:
Do you press the power button to activate a shutdown or press and hold that sucker until the computer breathes no more.Based on your log, I'd guess the former.

It looks like mDNS Responder (Bonjour) could be causing the problem, so if you are connected via Bonjour to anything through Bonjour, try disconnecting before shutdown.
0
 
vip2000Author Commented:
Well let me correct myself here. The button I meant was the confirmation button after I selected the shutdown option under Appleb menu. I'm not that savaged yet to hold the hard power button to shut it down.

@strung: this is the result after repair disk and repair disk permissions. I think it used to take around 30-40 seconds.
@Joseph: that's something interesting to take a look at. I don't know exactly which app is using Bonjour. A few on top of my head is Dropbox, Dyndns dashboard plugin, etc.

So I guess the question is now: how do I know which app is using Bonjour service?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
joseph_gormanCommented:
Bonjour is only used on your local network (see LINK )

The only other thing that sticks out at me is where your log says
"Apr  3 15:55:15 laptop shutdown[3467]: reboot by user:
Apr  3 15:55:15 laptop shutdown[3467]: SHUTDOWN_TIME: 1270335315 917035"

did you trigger the "reboot by user:" message? Try a shutdown where you don't touch anything at all and post the logs and I can look at the differences.
0
 
joseph_gormanCommented:
ahaha i guess I should paste that link in!

http://en.wikipedia.org/wiki/Bonjour_(software)
0
 
vip2000Author Commented:
Oh ya, I chose restart instead of shutdown, they should do the exact same procedure as shutdown. In another word, there should not be a big performance difference between these 2 instructions.  
0
 
joseph_gormanCommented:
yeah, i was wondering why that was in the middle of the log
0
 
vip2000Author Commented:
Oh this just occurred to me. My harddisk is running out of space. Since Mac OS X writes To disk at the shutdown, this might cause an issue of allocating space or disk writes. I'm gonna clean my harddrive and try later.
0
 
joseph_gormanCommented:
good luck!
0
 
vip2000Author Commented:
updates:
I started up from the Install Disk and ran repair disk AND repair disk permission. That achieved faster startup time (the time period after I login til the time that all plugins are loaded).

I did some more research and it appears to having something to do with NTFS disk being mounted. However, *UNLIKE* other users have experienced, unmounting the bootcamp disk prior to shutdown did not optimize the shutdown speed. I also have done defragmentation on the disk and that did not improve anything.

I'm gonna run OnyX next and will post back if there is any finding...
0
 
vip2000Author Commented:
new update:
So I got really frustrated and decided to remove my boot camp partition. -- the shut down still takes around 40-60 seconds.

and then I removed the VPN client I have installed a long time ago, and no significant improvement either.

I think next I'll be removing the Parallels Desktop, and see if that helps.....

system log:
Apr  7 18:23:21 BGMac SecurityAgent[2710]: NSDocumentController's invocation of -[NSFileManager URLForDirectory:inDomain:appropriateForURL:create:error:] returned nil for NSAutosavedInformationDirectory. Here's the error:\nError Domain=NSCocoaErrorDomain Code=513 UserInfo=0x102422af0 "You don’t have permission to save the file “Library” in the folder “empty”." Underlying Error=(Error Domain=NSPOSIXErrorDomain Code=13 "The operation couldn’t be completed. Permission denied")
Apr  7 18:23:21 BGMac com.apple.launchd.peruser.501[245] (com.apple.AirPortBaseStationAgent[297]): Exited: Killed
Apr  7 18:23:21 BGMac com.waltop.waltoptablet[299]: Unexpectedly back from CFRunLoopRun()!
Apr  7 18:23:21 BGMac loginwindow[36]: DEAD_PROCESS: 36 console
Apr  7 18:23:21 BGMac /Library/StartupItems/HyperPenTabletDriverStarter/Executables/HyperPenTabletDriver.app/Contents/MacOS/HyperPenTabletDriver[172]: Logout Occurred
Apr  7 18:23:21 BGMac eapolclient[325]: en1 STOP
Apr  7 18:23:21 BGMac shutdown[3488]: halt by bruce:
Apr  7 18:23:21 BGMac shutdown[3488]: SHUTDOWN_TIME: 1270689801 689790
Apr  7 18:23:21 BGMac Parallels[3491]: Stopping Parallels Dispatcher Service
Apr  7 18:23:22 BGMac Parallels[3501]: Stopping Parallels networking
Apr  7 18:23:22 BGMac prl_naptd[142]: Exiting Parallels Network Daemon
Apr  7 18:23:24 BGMac Parallels[3526]: Unloading kernel extension  prl_netbridge.kext
Apr  7 18:23:26 BGMac Parallels[3551]: Failed to unload kernel extension  prl_netbridge.kext
Apr  7 18:23:26 BGMac Parallels[3556]: Unloading kernel extension  prl_vnic.kext
Apr  7 18:23:29 BGMac Parallels[3614]: Failed to unload kernel extension  prl_vnic.kext
Apr  7 18:23:31 BGMac hdiejectd[2600]: quitCheck: calling exit(0)
Apr  7 18:23:41 BGMac mDNSResponder[35]: mDNSResponder mDNSResponder-214.3 (Feb 11 2010 04:49:16) stopping
Apr  7 18:23:41 BGMac DirectoryService[20]: BUG in libdispatch: 10D573 - 1960 - 0x10004004
Apr  7 18:23:42 BGMac WindowServer[87]: hidd died. Reestablishing connection.
Apr  7 18:23:42 BGMac WindowServer[87]: bootstrap_look_ip failed: Unknown service name

0
 
strungCommented:
What's HyperPenTable? From the log it looks like there might be some sort of problem with the driver.

If you have a tablet attached, try disconnecting it.
0
 
vip2000Author Commented:
The thing is I don't have it attached. It's a pen device that I don't use very often.
0
 
vip2000Author Commented:
ok, I finally found the solution to this problem after struggling it for couple of days..

I think the root problem lies within Parallels Desktop. It creates a VPN for the Virtual Machine to share the network with the localhost, so every time during shutdown it will try to disconnect it which takes a long time. But I cannot confirm it 100% because of the reason which will be explained in the later part of this post.

Here is a list of things I did. I am not 100% sure which exact step fixed it.

      •      Removed boot camp partition (no change in shutdown time)
      •      Repair disk permission and repair disk using Disk Utilities (no change in shutdown time)
      •      Repair disk permission and repair disk using Disk Utilities by launching it from the Install DVD (no change in shutdown time)
      •      Defragmented partition using DiskToolsPro (no change in shutdown time)
      •      Deleted all items under System Preferences > Accounts > Login items (no change in shutdown time)
      •      Went in /Library/StartupItems/ and deleted HyperPenTable folder (no change in shutdown time)
      •      Uninstalled the penpower pointing device driver, restart (no change in shutdown time)
      •      Uninstalled Parallels Desktop 5.0 INCLUDING THE "Application Settings", restart. ***RESULT: 3 SECONDS SHUTDOWN!!!!***

But I still need parallels desktop.... after doing some more research, some people suggested disconnect the network device in the PD's settings will increase the shutdown time, which I tried and it worked. So I downloaded the latest version of PD 5 and installed, tried a restart and the shutdown time is around 10 seconds, not bad.

But I do not want to disconnect it manually every time, so I tried to set it to Bridge to Airport for the network settings, and that keeps the shutdown around 10 seconds. I then reinstalled the latest version of my penpower pointing device's driver, and the shutdown stays around 10 seconds. I also tried opening Windows XP in PD and watch a movie on it, then shutdown the VM, and quit the PD application, then shutdown, 10 seconds...

The moral of the story: remove parallels desktop completely including the "Application settings", do a clean install from the latest version, set the network connection of your VM to "Bridge to Airport" (or other device other than sharing)

Okay, problem solved, but will it come back if I start adding things back?
      •      Installed NTFS-3G plugin, OK
      •      Created a partition using Boot Camp (without installing windows on it), OK
      •      Penpower driver installed, OK

So I guess it's been fixed. But I don't know if it will come back if I install Windows 7 Ultimate on the new partition. Let me keep my finger crossed…
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 7
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now