Ethernet Switch problems

I have three devices in my home entertainment center that need Internet connections: a Dishnetwork satellite receiver, a Sony BDP-37X bluray player, and an Xbox 360.  I have only one wired Internet port there, so I bought a Linksys 5-port 10/100 Workgroup Switch.

Only one of the three devices get on the Internet through the switch: the satellite receiver.  The other two simply won't link up.  The three lights (Link/Act, 100, and Full/Col) all go on when I plug in, but the device always reports there is no connection to the internet.  I tried manually assigning an IP address, etc. but nothing works.  I recycled the router and the switch, the equipment, but still no joy.

The uplink to the switch is to port 1 on the back of my Linksys Wireless Router.

I am wondering if there are some devices that are simply made not to accept a switch.

Please tell me if I'm wasting my time fiddling with this, or if no, suggest a way to get this rig to work!

Many thanks to all!

CWW+++
Charlie WestonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
The first question is do each of them work properly when connected to the router by themselves without the switch?
0
Charlie WestonAuthor Commented:
No.  Even connected all by themselves, they won't tolerate the switch.
0
joseph_gormanCommented:
chaz, Dave means when you plug the satellite receiver, Blu-ray player, and Xbox into the router on their own, without using the switch at all, do they work?
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

Charlie WestonAuthor Commented:
The Xbox and the Blu-ray player both work perfectly if they are connected directly to the router, but neither will work if they are connected via the switch.  

The satellite receiver is fine either with or without the switch.
0
Dave BaldwinFixer of ProblemsCommented:
A switch is 'supposed' to be transparent.  Which Linksys model is the switch and the router?
0
Charlie WestonAuthor Commented:
The router is WRT54GS.  The opaque switch is EZXS55W.

CW+++
0
lanboyoCommented:
First tray switching the patch cables between the devices, you CAN have a patch that looks good on the switch but can't carry data. Also switch the ports on the linksys, you might have bad ports.

So..

1) if you have not power cycled the xbox and the blue-ray, do so, and see if that fixes anything. Also, power cycle the linksys router ( and switch ) .

2.) Connect the patch and port connected to the satelite reciever to the xbox then to the blue-ray, one at a time and see if they work on the known good port and cable.

If only the satelite reciever works, check lights on the other two devices... Do they have the same ethernet port lights on the switch patch port as they do connected to the router?

3.) How is the linksys configured? Is is a router or a wireles bridge. I have had problems with multiple devices connected to the remote end of a wireless bridge.

4) is the linksys configured as a router or a bridge? Many internet connections do a MAC limitation that prevent multiple devices connecting .

5) IS the full light blinking or solid green?

6) if you plug a pc into the switch does IT get an IP address?
0
Charlie WestonAuthor Commented:
The patches check out OK.

I tried power cycling everything, and no improvement.

I'll try the other things tomorrow, but how can I tell if the router is configured as a router or as a bridge?  I went into the setup screen and couldn't find any setting that mentioned "bridge".

CW+++



0
rogerorenCommented:
The Linksys router has to have DHCP on for the three devices to operate independently. If the switch works as it should, it passes the request from the X-Box to the router, which should assign a IP address to it. Check the router 'home page' to see if it shows attached devices, and what IP address it has assigned. If it doesn't assign any addresses, you may need to reconfigure the router.
0
Charlie WestonAuthor Commented:
It definitely does assign IP addresses so it's not a bridge.

BTW, is there any special order in which I should power recycle the various elements (router, switch, device)?

C
0
Dave BaldwinFixer of ProblemsCommented:
I did see one post on the internet where someone got their EZXS55W by powering their equipment up in a particular order but that's not 'normal'.  In my research, I found as many people saying their EZXS55W worked as failed.  A number of the failures were people who tried to use their EZXS55W in place of a router, sometimes on the advice of store personnel.

Who is your ISP? It is normal for most ISPs to 'automatically' assign 1 IP address but unusual for them to provide more than one.  That's what the router is for.  If your router is in 'bridge mode', you can still get one IP address.  Is your computer on when you're testing the other devices?  What IP addresses have you seen assigned so far?  When you connect devices without the switch, does each on get the same IP address?
0
Charlie WestonAuthor Commented:
OK, guys, I found the problem.  I finally opened up the user manual that came with the switch, and lo and behold, on the first page:

NOTE TO USERS OF THE 10/100 5- OR 8-PORT
SWITCH: If you connect a router or additional
switch to the Uplink port, then you cannot use
the numbered port next to the Uplink port
(port 5 on the 5-Port Switch or port 8 on the
8-Port Switch will be inactive). The two ports
are wired together, so they cannot be used
simultaneously.

I was stupidly hooking up to port 5 with the Blu-ray player, thinking that because it was next to the uplink port, it was port 1.  I repositioned the patch away from 5 to 1, shut everything off, rebooted, and it worked fine.

Thank you all for your helpful suggestions, but I guess the most important advice wasn't there: RTFM.  Read The Freakin' Manual!

CW+++
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.