Sonicwall VPN no DHCP

we have a sonicwall pro 240 still running strong. i would like to setup VPN access for remote users. I configured VPN access but cant not get a DHCP IP address. anyone have any ideas why? i am able to connect to the WAN sonicwall, but not DHCP IP address.
cadnycAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

digitapCommented:
Are you relaying DHCP requests to the Sonicwall or to an internal DHCP server?  Do you have the Sonicwall handing out DHCP to clients connecting to the WLAN zone via SonicPoints?  I would recommend configuring the Sonicwall to hand out DHCP requests.
0
digitapCommented:
Here is how I've configured it for a client running SonicPoints on the WLAN zone.  Setup a DHCP server on the SonicWALL and assign it to the X2 interface which is the interface assigned the WLAN zone.  Also, make sure to check the box, "Enable Conflict Detection".

Go to VPN > DHCP over VPN and click the drop down and select Central Gateway.  Click Configure.  Click the checkbox "Use Internal DHCP Server" and "For Global VPN Client".  Below, in the Relay IP Address box, type in the IP address of the X2 Interface.
0
cadnycAuthor Commented:
currently i am only using LAN (x0) and WAN (x1) ports on the sonicwall pro 240. DHCP server is enabled on the firewall. DHCP over VPN > Central Gateway > DHCP Relay > enabled Use Internal DHCP server and For Global VPN Client. On the VPN Client I am able to connect, but it doesnt know tell me the DHCP IP address. On the sonicwall i can see its 192.168.3.6, but the VPN client user cant not ping or access the inhouse servers.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

cadnycAuthor Commented:
is it normal that you can not edit the groupvpn? when i click on edit, i get a blank page. groupvpn has not gateway or destinations.
Clipboard01.jpg
0
cadnycAuthor Commented:
global vpn client tells me i'm connected by the status tab for virtual ip configuration: ip address: n/w and subnet mask n/a. general tab: other traffic allowed: enabled, default traffic tunnel to peer: disabled, use virtual IP address: disabled.

0
digitapCommented:
So, you are utilizing an internal Windows DHCP server?  If so, I believe you'll want to configure your clients like the screen shot I've attached.  The IP address in the screen shot will represent the Windows Server that is providing DHCP on your internal network.

Also, confirm the following:

Confirm in configuration settings at VPN > WAN GroupVPN > Client tab are set as you see in the screen shot.
Check out the firewall rules between your VPN zone and your LAN zone making sure the proper traffic is being allowed.  These rules should be configure automatically when you enable the WAN GroupVPN settings.  You might try to disable the WAN GroupVPN and reenable it if the rules don't appear correctly.
greenshot-2010-04-05-15-29-17.jpg
greenshot-2010-04-05-15-37-55.jpg
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cadnycAuthor Commented:
thank you digitap. those screenshots were very helpful. my IE8 is pretty screwed up. i was not able to edit the GroupVPN. Everytime clicked on the edit config, i would get a new window but a blank page. I logged into my firewall with firefox browser and I was able to see config for GroupVPN and enabled DHCP Lease for Virtual Adapter settings. VPN from home and was able to get a DHCP and access the servers. Thanks again.
0
digitapCommented:
Yeah...IE8 no likey Sonicwall interface.  I forgot about that.  I use Firefox exclusively, but had run into that before.  Look into IE8 Compatibility mode which might clear that up.  Glad I could help and thanks for the points!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.