When transferring Japanese file, its filenames and folders become unreadable

I'm helping one of my Japanese users to transfer his files over to his new(local) computer. As he has been working in Japan, I do not know what model he was using previously, I supposed it might be a Japanese notebook. He brought his backup files over here, and when the transferring commenced I noticed that most of the filenames are unreadable. It displays text like "Æ_æ¦âtâ@âCâïü@ü@üiÉlÄûè+îWüj", "Æ_æ¦ê°îpÅæ"; be it folders or files (mainly excel and word). The new computer is on Windows XP SP3 with all the latest patches.
I've applied Japanese under Languages and Advanced tab in Regional settings, but it doesn't resolve anything. Is there any solution to this?
misteelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sustekiCommented:
I'm assumming you have:

Win XP SP3
Control Panel -> Regional and Language Options->
Language Tab -> check the Install files for East Asian Languages, you will need i386 directory for this installation.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
misteelAuthor Commented:
Yup, already checked and installed.
0
sustekiCommented:
Try changing the language for non-Unicode programs to Japanese also.

Also check C:\WINDOWS\Fonts to see if the MS Mincho & MS PMincho exsist.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

samsymonCommented:
Just ask him which fond is using and check whether it is Unicode supported.
0
misteelAuthor Commented:
Hi all, thanks for the suggestions. I managed to find out where the problem lies. My user is using lzh file,  when I unzip using winrar it shows all the unreadable files and folders. Only when I change the regional settings to Japanese first then I could unzip (using winzip) them perfectly with the correct name.

0
misteelAuthor Commented:
d
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.