[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Losing Network Connection during Sleep

Posted on 2010-04-05
14
Medium Priority
?
605 Views
Last Modified: 2013-11-09
We only have one user using Vista in our company and he seems to be having this odd problem. He loses his network connection whenever his computer goes to sleep, or when the screen saver comes on. I have done a bit of research on the matter and have disabled the device's ability to 'turn off to save power'. I have also uninstalled and reinstalled all network drivers for the PC. Neither of these solutions seemed to work. Normally, I would be content to just disable Sleep mode on the PC, but whenever the group policy screen saver kicks in, it seems to lose the network connection as well. When he comes out of Sleep, there is no network connectivity for at least a few minutes. He has to close and reopen Outlook in order to check his messages
0
Comment
Question by:agruber85
  • 5
  • 3
  • 3
  • +1
14 Comments
 
LVL 9

Expert Comment

by:Michael Knight
ID: 29795547
If you've verified that the NIC isn't powering down with other components during sleep here:
control panel>>device manager / network adapters>>right click on connection>>Properties>>Power Management remove the check for the box
"allow this computer to turn off devices to save power"
If that's OK you might try disabling ipV6 I've seen it matter on some Vista/7 Boxes:
http://www.mydigitallife.info/2007/09/09/disable-and-turn-off-ipv6-support-in-vista/ 
0
 
LVL 4

Expert Comment

by:AnnOminous
ID: 29795694
This seems clear to be an issue with the NIC at least ignoring the 'Do not turn off device to save power' switch, or another switch acting in the same way.

There may be a device driver level option that does the same thing. Check there first. If you have another system with the identical hardware, look for variation in the device driver options, and then in the OS level options.
0
 
LVL 9

Expert Comment

by:Michael Knight
ID: 29796910
What Mfr. of card/hipset is this? Have you tried tweaking the NIC speed?
Right click on the Connection>>Configuration>>Advanced>>Speed and Duplex. Change from auto to 100 MB Half or 10 MB Half. If it works, bump it up to 100 MB Full or 1000 MB Full.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 

Author Comment

by:agruber85
ID: 29798074
Ok, I just wanted to double check that I had indeed disabled the "allow computer to turn off this device to save power" option and it somehow reenabled itself. Is there some sort of setting that I am missing? I know for a fact that I disabled the setting before, but now it seems to be enabled again. Any thoughts?
0
 
LVL 4

Expert Comment

by:AnnOminous
ID: 29798909
The switch in the UI is probably reflecting a setting in the registry or the drive. If something else resets it (or it does not change) then then next time you reboot and check it will be the old value.

First turn off the setting. reboot, confirm it is still off and verify that the problem does not recur.

If it does not recur, then you only need to resolve why the switch is turning on.
If it recurs anyway when the switch is off, spend your time looking elsewhere.
0
 
LVL 9

Expert Comment

by:Michael Knight
ID: 29799346
Could be that BIOS is overriding as well...as in you tell Windows to turn that off, but on reboot BIOS tell windows to turn it on?
Is the power off option set for everyone in the GPO? You stated that the GPO screensaver causes this as well, check that group policy.
0
 

Author Comment

by:agruber85
ID: 29799741
Ok, yeah after reboot it seemed to have taken the change, but I still lose the network connection

To answer your question, the Mfr of my Network Adapter is Intel.

Also, the only option that we have set for the Group Policy is the screensaver, all the other ones are not used. Any other ideas?
0
 
LVL 72

Expert Comment

by:Qlemo
ID: 29799756
Two things are causing that at my Vista box:
  1. The WLAN NIC driver is crashing when waked up, and restarting after one minute (recovery option in the service I use for that NIC)
  2. DNS Cache service not working after network changes. This is an issue which leads to unresolvable DNS - nslookup works, but nothing else using a DNS address. Workaround is to restart that service.
My WLAN NIC is powered off on sleep, not caring about the same option as you have already looked for. You are not alone ;-).
0
 

Author Comment

by:agruber85
ID: 29801222
michaelaknight: I just tried tweaking the NIC speed to no avail. It did not seem to help. Is there some sort of registry setting that can be altered to force it to not turn off the device to save power?

AnnOminous: How can I try to set the device driver level options that you referred to before?

Qlemo: So you have not been able to find a solution to this problem? Is it just another Vista bug that doesnt have an answer?
0
 
LVL 72

Expert Comment

by:Qlemo
ID: 29805162
I can't tell if is Vista or the NIC manufactor's fault, but no, I have no solution, searching for one year now.
0
 

Author Comment

by:agruber85
ID: 29805626
Do you have an Intel NIC? because that is what this user has and no matter how many times I have reinstalled the driver or searched for a new one, it does not seem to help...
0
 
LVL 72

Expert Comment

by:Qlemo
ID: 29805825
No. Something you won't know ;-). Since it is WLAN via USB Stick, using own software for connecting, it is, ehm, different. But it is a very common config here in Germany.
0
 

Author Comment

by:agruber85
ID: 29824776
Aha, gotcha.
Anyone else have any other suggestions on how to fix this issue? Or is it something that does not seem to be addressed and I will just have to deal with it being annoying?
0
 
LVL 4

Accepted Solution

by:
AnnOminous earned 2000 total points
ID: 29915783
Device driver level settings are exposed in the driver details panel in device manager. Not every driver offers configurable options, but this is where you could set them.

Have you tried checking with the NIC manufacturer web site to see if you have the latest driver. Windows Update often does not expose the latest versions, and OEMs seldom do. You need to check the manufacturer site (e.g. Realtek) to confirm the latest version.
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Make the most of your online learning experience.
Unable to change the program that handles the scan event from a network attached Canon/Brother printer/scanner. This means you'll always have to choose which program handles this action, e.g. ControlCenter4 (in the case of a Brother).
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

613 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question