SQL Express has stopped working after promoting the server to a DC

Experts!

We have a server running Server 2008 Standard,  It is running an instance of SQL Express, which has a small 500MB database for a CRM application.  We promoted the server to a DC temporarily to get a full time replacement in place during a migration.  Now we are having trouble accessing the CRM (non-critical), and its spitting an error no matter what we try:

an error occurred in method UseLogin. PopulateDatabaseList: A network related or instance specific error occurred while establishing a connection to SQL server. The server was not found or accessible. Verify that instance name is correct and that SQL server is configured to allow remote connections

We have tried running the app from 3 different machines, and on the server itself, and still the same error.  What do we do?

Thanks!
paylessofficeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Go into the service applet and reapply the service credentials. Then restart the MSSQL services. If you do not have a SPN issue,  this helps.
If you have a SPN issue, you need to issue an setspn. SPN is Server Principal Name, a registration of the MSSQL service in AD.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
paylessofficeAuthor Commented:
How do I reapply the service credentials?
0
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
Go into the Services applet, open the individual service properties (at least for the MSSQL Server instance), and change the login info forth and back.
0
paylessofficeAuthor Commented:
Thanks!  We got it, it was the service account credentials.  After I reset them, it worked...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.