Server 2008 R2 - The master browser has received a server announcement

recently setup a fresh new Server 2008 R2 domain controller.  This is the only DC and only server on the network.  I have 11 XP Pro clients joined to this domain.  Two of the clients continue to bother me with the following event:

Log: System
Type: Error
Event: 8003
Time: 12:34:23 pm 4-Apr-10 UTC
Source: bowser
Category: None
Username: N/A
Computer: DERMSERVER.derm.local
Description: The master browser has received a server announcement from the computer DERMMOHS2 that believes that it is the master browser for the domain on transport NetBT_Tcpip_{9F8B8496-2426-4AC2-B2BA-4AA21602EAB6}. The master browser is stopping or an election is being forced.

Help - It's becoming very annoying.  Everything is working as expected, just constantly getting these errors.  Thanks.
sknoll84Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott AndersonPrincipal Support EngineerCommented:
This should be a quick and easy...
Just go to the two systems that are causing the errors and disable "Computer Browser" service.  If they still fling errors, just follow step #6 here:
http://www.hightechdad.com/2007/05/09/how-to-fix-master-browser-mrxsmb-event-id-8003-errors/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Scott AndersonPrincipal Support EngineerCommented:
Here's the background on the Computer Browser Service..
http://support.microsoft.com/kb/188001
0
Darius GhassemCommented:
Don't stop the computer browser service you need to disable this setting the registry.

Disable Master Browser in XP, 9X, W2k:
Change master browser in w2k or XP:
Go to Program files, Admin tools, services then in the right panel right click on computer browser and right click go to properties then from the startup list select Disabled. Or type regedt32, and scroll to this key change value to False
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters IsDomainMaster=FALSE

Change master browser in 9X:
From network neighborhood properties select File & print sharing, select and click properties then select "Master Browser" from the right list and choose disabled from the left list.

http://www.chicagotech.net/browser.htm#Disable%20Master%20Browser%20in%20XP,%209X,%20W2k:
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.