Deleted SMTP connector but still routed through it?

We had some issues with spam, so created a smtp connector with IP [99.99.99.99] to clean up the queue.

Problem is, after i deleted the smtp connector and restated the smtp virtual server, all outgoing queues have "the remote server did not respond to a connection attempt" error.
I can telnet to each of the domains and send successfully, so no ports are blocked

I noticed in our firewall that the exchange server is still trying to connect to the IP I set for the smtp connector, even though it is already deleted.

I search the registry but there is no key for smtp connectors.

Created new connector to use DNS to route but still shows up on firewall as exchange trying to connect to [99.99.99.99] when processing queue.
I can do nslookup and ping each domain so it is doing DNS resolution set up correctly.
I ran SMTPdiag and it shows no issues, connects to each MX successfully.

Any idea what I should do?

Thanks.



Unsual event:

Event Type:      Information
Event Source:      MSExchangeTransport
Event Category:      Routing Engine/Service
Event ID:      984
Date:            4/5/2010
Time:            12:43:10 PM
User:            N/A
Computer:      EXCH
Description:
SMTP GetNextHop returned hr=0x0 in 0ms.
 DestAddr=<domain.com>, Type=<SMTP>
 MsgType=0x4, NextHopType=OTHER_ROUTING_GROUP
 Type=<SMTP>, Class=<domain.com>, SchedId=0xffffffff
 RouteAddr=<domain.com>
 Connector=<DNS>
sunhakAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SteveIT ManagerCommented:
I'd delete all SMTP connectors and firewall rules, reboot the exchange server and re-instate the connectors.

0
sunhakAuthor Commented:
I already deleted all SMTP connectors. We were not using any in the first place. Rebooted exchange server several times already. It is still being routed to the IP address that was set in the SMTP connector created for spam clean up even though that connector no longer exists.
0
Alan HardistyCo-OwnerCommented:
Download the IIS 6 Resource Kit and run Metabase Explorer.  There is probably still an entry under SMTp for 99.99.99.99 which you can manually delete, then setup another connector and send you mail properly:
http://support.microsoft.com/kb/840671
Use Metabase Explorer VERY CARFULLY - it is directly editing your server settings.
Run IISRESET after making any changes to make the changes take effect.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sunhakAuthor Commented:
That did it. Thank you so much! I was pull my hair all day.
There was an entry for [99.99.99.99] under SmtpSvc -domain - * RouteAction.
0
Alan HardistyCo-OwnerCommented:
It's always nice when it is well and truly buried.
Glad it resolved your issue - thanks for the points.
Alan
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.