Vista sp2 fails with error code 80004004

Sp2 install fails and crashes the machine. The only way we have been able to bring it back is to replace the acronis backup image to the drive.

All other updates are installed. machine has been scanned for viruses.

machine is an hp pavilion a1720n with vista home premium 32bit.

Any help would be appreciated.
Who is Participating?
Jamesey1Connect With a Mentor Author Commented:
Cool but the problem still remains that I can't log into the OS. It simply boot loops with the vista repairing screen. No gui, no windows login. no safe mode.

At any rate I ended up formatting the machine.

Thanks for trying though. Vista isn't my favorite :)
Please go into the event log and try to get the exact error that comes up after you attempt again.
If you cant boot into windows try safe mode.
Jamesey1Author Commented:
I won't be able to get an error code that way. I can't boot after the installation attempt. it will try to do the automatic vista repair option on the sp2 installation restart, find no errors and just start boot looping. Safe mode doesn't help past that point either
Jamesey1Author Commented:
Pulled the following from problems reports and solutions. Does this shed any light?

Host Process for Windows Services

Windows Update installation problem

4/2/2010 3:47 AM

Report Sent

A Windows update did not install properly. Sending the following information to Microsoft can help improve the software.

Problem signature
Problem Event Name:      WindowsUpdateFailure
ClientVersion:      7.4.7600.226
Win32HResult:      80004004
UpdateId:      0BC0E502-52B6-492E-8856-14B84973C615
Scenario:      Download
SourceId:      107
Environment:      Unmanaged
OS Version:      6.0.6001.
Locale ID:      1033

Extra information about the problem
Bucket ID:      722476848
Try to do the following before installing the update, they dont provide any output:
msiexec /unregister
msiexec /regserver
This will correct any possible issues with the windows isntaller.
Also make sure to turn off any antivirus apps, and open msconfig and disable any non ms services and programs.
Make sure to right click on the sp file and hit run as administrator when installing as well.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.