[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Exchange 2007 Crash

Posted on 2010-04-05
25
Medium Priority
?
365 Views
Last Modified: 2012-05-09
The exchange store has crashed and will not mount any longer. I have tried to build a recovery storage group, but it can't move the mailboxes into it since the main store is offline. I have NTbackups from the original store. How can I get this exchange server back online?

Thanks!
0
Comment
Question by:rbmacct
  • 14
  • 9
  • 2
25 Comments
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29822824
Can you see if its in dirty shutdown?  

eseutil /mh  databasefile

if it is in dirty shutdown then run eseutil /p databasefile to fix
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29823378
Do I do this in the cmd or the cmdlt?

Also, is the snytax 'eseutil /mh  'Mailbox Database'



0
 
LVL 1

Author Comment

by:rbmacct
ID: 29823571
See attached.

err1.JPG
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 29824065
Please restore the backup in the original production store.
And run Hard recovery on the restored database backup files.

Restore the backup to "C:\temp folder" you will get a folder call First Storage Group

run the following command: eseutil /cc "c:\temp\First Storage Group" and try mount the store.
Please check this and revert back with the if the issue re-occurs.
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29824804
How do I point ESM to use the new database in C:\Temp folder\First Storage Group?

0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29824830
for eseutil you need the full path for the mailbox database,.   Your problem is you don't have the correct path.

example:

eseutil /mh "C:/Programs/Microsoft/Exchange Server/Mailbox/First Storage Group/Mailbox/edb"

Look in exchange for the correct path.
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29824894
I don't recommend restoring the db yet.   I would work with eseutil first.
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29825831
Right now, the database recovery troubleshooter is running through the ESM. that's done now...

What do I do next?


error2.JPG
0
 
LVL 9

Assisted Solution

by:v_9mhdrf
v_9mhdrf earned 400 total points
ID: 29826310
you have to type the followinng command to check the status of the database files.

eseutil /mh "location of the database files"

e.g.:- eseutil /mh "C:\program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\mailbox database.edb"

Please run the command appropriately,.
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29826718
After running:

eseutil /mh "C:\program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\mailbox database.edb"
error3.JPG
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29827339
So I was able to mount the restored database. What is the next step now?

See attached..


mount-database.JPG
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29828794
I ran it again, and it says the it's locked and/or in use


locked-file.JPG
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29829685
If you have the database mounted you have to dismount to run eseutil against it.  
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29829890
I'm not trying to run esetuil against the mounted (restored) database. I'm trying to run it again the production (crashed/dismounted) database. and I get the errors above. Sorry for the confusion.
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29830391
here's what I've done.

The dismounted database (Production) location: C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group.  It's the crashed database. I ran the ESM repair tool and still nothing.

The mounted database (From backup) location: D:\ExchangeRecovery\Data\. It's mounted in a RSG. And when I try to merge/copy it complains that the database is offline. I'm assuming it's refering to the production database to be able to pull the data from.

I'm completely lost in the steps needed to get the mailboxes back online.

0
 
LVL 1

Author Comment

by:rbmacct
ID: 29830686
I just ran:

eseutil /mh "C:\program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\mailbox database.edb"

And it was a dirty shutdown.


        File Type: Database
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,12
 Engine ulVersion: 0x620,12
Created ulVersion: 0x620,12
     DB Signature: Create time:04/05/2010 14:37:17 Rand:16434679 Computer:
         cbDbPage: 8192
           dbtime: 209460447 (0xc7c1cdf)
            State: Dirty Shutdown
     Log Required: 0-0 (0x0-0x0)
    Log Committed: 0-0 (0x0-0x0)
   Streaming File: No
         Shadowed: Yes
       Last Objid: 75397
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 2
      Repair Date: 04/05/2010 14:37:17
 Old Repair Count: 0
  Last Consistent: (0x0,0,0)  00/00/1900 00:00:00
      Last Attach: (0x0,0,0)  04/05/2010 14:37:17
      Last Detach: (0x0,0,0)  00/00/1900 00:00:00
             Dbid: 1
    Log Signature: Create time:00/00/1900 00:00:00 Rand:0 Computer:
       OS Version: (5.2.3790 SP 2 NLS 1.1)

Previous Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Copy Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Differential Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

       ECC Fix Success Count: none
   Old ECC Fix Success Count: none
         ECC Fix Error Count: none
     Old ECC Fix Error Count: none
    Bad Checksum Error Count: found (1)
Last Bad Checksum Error Date: 04/05/2010 14:37:17
Old bad Checksum Error Count: found (1)

Operation completed successfully in 0.63 seconds.
0
 
LVL 20

Accepted Solution

by:
Rick Fee earned 1600 total points
ID: 29830892
Cool well now change the switch to /p and then you can attempt to mount or run /mh again to make sure its in clean shut down.
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29831468
It's scanning the database now with the /p switch.


sacn.JPG
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29831577
Cool cool well once this is complete you should be good to mount the db...if it does not work then run /mh again...but my guess is /p is going to fix it for you.
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29839457
Initiating FILE DUMP mode...
         Database: C:\program Files\Microsoft\Exchange Server\Mailbox\First Stor
age Group\mailbox database.edb

        File Type: Database
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,12
 Engine ulVersion: 0x620,12
Created ulVersion: 0x620,12
     DB Signature: Create time:04/05/2010 16:11:03 Rand:2567147 Computer:
         cbDbPage: 8192
           dbtime: 212028284 (0xca34b7c)
            State: Clean Shutdown
     Log Required: 0-0 (0x0-0x0)
    Log Committed: 0-0 (0x0-0x0)
   Streaming File: No
         Shadowed: Yes
       Last Objid: 75397
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 4
      Repair Date: 04/05/2010 16:11:03
 Old Repair Count: 0
  Last Consistent: (0x0,0,0)  04/05/2010 16:50:21
      Last Attach: (0x0,0,0)  04/05/2010 16:11:03
      Last Detach: (0x0,0,0)  04/05/2010 16:50:21
             Dbid: 1
    Log Signature: Create time:00/00/1900 00:00:00 Rand:0 Computer:
       OS Version: (5.2.3790 SP 2 NLS 1.1)

Previous Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Copy Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Differential Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

       ECC Fix Success Count: none
   Old ECC Fix Success Count: none
         ECC Fix Error Count: none
     Old ECC Fix Error Count: none
    Bad Checksum Error Count: found (1)
Last Bad Checksum Error Date: 04/05/2010 14:37:17
Old bad Checksum Error Count: found (1)

Operation completed successfully in 0.47 seconds.


C:\Program Files\Microsoft\Exchange Server\Bin>eseutil /mh "C:\program Files\Mic
rosoft\Exchange Server\Mailbox\First Storage Group\mailbox database.edb"



*******

The database still will not mount. Any suggestions?
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29839643
remove the log files and attempt to mount
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29839732
The .logs

What about the .jrs, .chk files?/
0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29840498
yes what I would do is create a subfolder call templog and move everything in there then attempt to moint
0
 
LVL 1

Author Comment

by:rbmacct
ID: 29840623
It mounted and mail is coming in now. This is awesome! However I got this error message in my application eventvwr.

Failed to create a new named property for database "First Storage Group\Mailbox Database" because the number of named properties reached the quota limit (8192).
 User attempting to create the named property: "NETWORK SERVICE"
 Named property GUID: 00020329-0000-0000-c000-000000000046
 Named property name/id: "PCRUID"

Is this a deal breaker?

0
 
LVL 20

Expert Comment

by:Rick Fee
ID: 29841527
Shouldnt be...check out this article:  http://support.microsoft.com/default.aspx?kbid=820379

0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will demonstrate that how to do a PST migration from Exchange Server to Office 365. This method allows importing one single PST, or multiple PST's at once.
Microsoft Jet database engine errors can crop up out of nowhere to disrupt the working of the Exchange server. Decoding why a particular error occurs goes a long way in determining the right solution for it.
how to add IIS SMTP to handle application/Scanner relays into office 365.
In this video I will demonstrate how to set up Nine, which I now consider the best alternative email app to Touchdown.
Suggested Courses
Course of the Month9 days, 19 hours left to enroll

591 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question