We have Lost our Running Configuration after Restart Router

Hello Expert,

I Have Big Issue, I have cisco 877 Router, When I restart Router, I have lost my Running Configuration, It's Happend again & again,  Router has been turn in Normal mode like new router or configure less router

I am Not sure why? pls any onesuggest me what should i do for that
Thanks
kavinagpurAsked:
Who is Participating?
 
Istvan KalmarConnect With a Mentor Head of IT Security Division Commented:
if you have rommon mode you need this:

rommon 1 > confreg 0x2102

You must reset or power cycle for new config to take effect

rommon 2 > reset
0
 
illfusion82Commented:
You need to save the running-config to the start-up config before restarting the router. To do that you can use "copy running-config startup-config" without the quotes. The running config only gets stored into RAM and gets wiped when the router is restarted. When you run the preceding command it saves the running-config into nvram.

Let me know if that helps.
0
 
kavinagpurAuthor Commented:
I used "copy running-config startup-config" This command but still have a Same Issue

Thanks
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Istvan KalmarHead of IT Security Division Commented:
Please provide us:

sh ver
sh run
sh start
0
 
kavinagpurAuthor Commented:
Please help me ,
Why it's Happend again & again

Thanks
sh-run.txt
sh-start.txt
ShVer.txt
0
 
Istvan KalmarHead of IT Security Division Commented:
HI,

The problem Configuration register is 0x2142, so you need to change it...

conf t
 config-register 0x2042


write

Best regards,
Istvan

0
 
kavinagpurAuthor Commented:
Same issue,
I did it
conf t
 config-register 0x2042
write


Pls help me
0
 
kavinagpurAuthor Commented:
Now i am going to change from Rommon Mode
0
 
Istvan KalmarHead of IT Security Division Commented:
sorry 2102 the right conf reg

conf t
 config-register 0x2102
write

and it will be working...:)
0
 
kavinagpurAuthor Commented:
Thanks ikalmar
Issue Has been solve, It will be a great if u give me a suggestion on below
http://www.experts-exchange.com/Networking/Telecommunications/IP_Telephony/VoIP/Q_25549202.html
0
 
kavinagpurAuthor Commented:
Good Knowledge
0
All Courses

From novice to tech pro — start learning today.