Linksys WRT120N wireless only 1 PC connects

Just bought the WRT120N
1 Laptop Vista Home Premium
1 Laptop Windows XP Pro

With Wizard Setup run with enclosed CD, setup went flawlessly.  PPPoE connection with Username and Password required by ISP - no problem.  Security is disabled since I'm in a rural area with no users within a mile.

Basic Wireless Setting:
                                 Default                       1st Change
Network Mode:         Mixed                          Mixed
Network Name:         xxxxxxxxxxx             xxxxxxxxxx
Channel Width:         Auto                            20mhz
Wide Channel:          Auto                            Auto
Standard Channel:   Auto                            1-2.41Ghz
SSID Broadcast:       Enabled                       Enabled



Two "wired" computers came right up.

The "wireless" Vista Laptop came right up with the Default settings  The "wireless" Windows XP Pro Laptop shows "Limited or No Connectivity" with the Default settings.

Per a phone call with Linksys techs (which took an hour and produced poor results) I made the changes listed under "1st Change".  This resulted in a reversal of the "wireless" PC's connections.  The Vista PC no longer connects - the Windows XP Pro PC now connects.  

XP Pro computer has an Atheros AR5005g network card.
Vista computer has Intel(R) Wireless WiFi Link 4965AGN network card.

Am assuming there's a happy medium to be reached between 11 different Standard channel settings and experimenting with Channel Width for each Standard channel setting.

Am hoping someone can help cut through the experimentation.

Thanks.







baleman2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnny_the_knifeCommented:
You need to select a channel where there is minimal interference from other devices, such as cordless telephones, other wireless networks etc.  The channel selection can also have an impact on dead spots in your network due to radio waves defracting around the place in differant ways depending on their frequency.

Can the wireless machines connect one at a time, or does the problem exist regardless if one or both are connected?
0
sukamtoCommented:
try use :
network mode => G
standard channel => 11
channel width => auto

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
engeltjeCommented:
There is nothing wrong with coosing whatever channel you want, except:

Older cards cannot connect to hogh channels.
Since you are in a rural environment, there can be no disturbance on the wifi channel.
Leave all Wifi settings default.

Now: one PC connects, the other does not.
Check if the énd PC indeeds doesn't connect.
It can happen it IS connected, but gets no IP parameters.

So: the WRT is a router, not an access point. It should have DHCP server ebabled.
There are 2 wired computers coming up, and one Wireless.
The DHCP server in the router isn't configured to give just 3 IP numbers?

Allround, I get best results with channel 6, but, this can be only an impression.

Further: dut the network mode to Wireless G instead of N, as suggested above.

Any results?
0
baleman2Author Commented:
To all: thanks!
Johnny's points awarded for general (not specific) instructions.
Sukamto & Engeltje got points because I believe their suggestion of switching mode to ONLY "G" actually allowed both wireless PC's to connect as they should
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.