ado select returns only 255

I have a problem with ado in delphi, select statements only returns 255 byte, characters of data, but there is clearly more data stored into the field.

what could be the problem?
LVL 3
KarlisBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Geert GOracle dbaCommented:
what is the field type in the dataset on the db
and in your table/query definition ?
0
KarlisBAuthor Commented:

field type is bytea
0
Geert GOracle dbaCommented:
problem solved ?
and how ?

not very nice to have someone look at questions and then just delete them with "problem solved"
waste of time for people looking at those questions

this is a site with references to solutions
how did you solve it ?
post your solution and then accept your own solution.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

KarlisBAuthor Commented:

well, you where the only one to 'respond' in some way to my question.
since I found solution for a different thread of mine, this problem drops off.
Clearly, thats a good reason do delete question, where answer isnt needed any-more and no solution found.

Solution which cause to drop this one:
http://www.experts-exchange.com/Database/PostgreSQL/Q_25724406.html

Sorry Geert, I kinda have a bad habit:
waste couple days to trying to solve some problems,
 then when I have the courage to ask help from experts,
 am finding solution on my own  to my problems a couple hours later after asking the question.
Well, since you waisted your time...
Cheers!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Geert GOracle dbaCommented:
lol, i get that too
just keep hitting that keyboard without a result
i now what frustration is too :)

i now see those 2 questions were related
1 solved the other? I hand't made the link myself yet
thanx for noting that

i'm gonna work in postgre too in the near future, and i like too see some problems i'm going to run in to
i sometimes monitor a question and i tend to post the "accept your own solution" advice when i'm also interested

:)


0
8080_DiverCommented:
KarlisB,
>>well, you where the only one to 'respond' in some way to my question.
Your question was posted at 02:50 my local time . . . I'm not up at that hour.  I just got into my email and and, to be honest, while I admire your finding your own solution, complaining that Geert was the only one to respond does seem just a bit impatient. ;-)
0
Geert GOracle dbaCommented:
lol,
8080_Diver are you one of those people who is not an "early bird" ?

btw, you will miss a lot of questions while you sleep, you can't answer them all ... :)
sleep is just one of those nasty habits that humans have to deal with
and it's the most time consuming

next to that: the time zone is a setting in your profile on EE
you can set it to anything you want ...
0
8080_DiverCommented:
Geert,
If I set the timezone on my profile to that of Europe, does that mean I won't receive the messages until the corresponding time of day locally? ;-)
As for not being an early bird, yes, I confess.  Also, I have about 900 emails that I have to go through for work before I can get to the fun ones. ;-)  While most of them are of the "Okay, that worked." type, it still takes a bit of time.  
Still, I sometimes wonder when someone expects an immediate response without considering the facts of life represented by different time zones.  Since I am currently at GMT -5:00, I do what I can. ;-)
0
KarlisBAuthor Commented:
8080_Diver,
you know, there are times when you are biting of your fingernails and irritation is so great that you could accidentally hit colleague just because one question "how are you? are you ok?".
you have spent 2 days without sleep, even more to find a simple solution, but you cant find it.
Mother 'google' and uncle 'bing' are giving hundreds of articles to read, but you realize it's just not it.
then as a last resort you are trying to ask cousin 'expert' for some clues.
cousin, like always is sleeping or out of range, and does not respond right away.
Every minute feels like agony, every hour - like an eternity.  
While cousin is still sleeping, you still try to find answer, opening 10 fire-fox browsers with 20 more panels in each. Typing countless variations of words to feed google... .
And then when sanity is no more with you, you are starting to hallucinate, asking mother for answers with some bizarre keywords, sometimes totally unrelated keywords to your problem.
And then, surprise surprise, there it is THE ANSWER you have searched for so long, comes right in to your hand :). That even cousin didn't manage to yawn ....
Well, this explains why i am impatient most times :)
0
Geert GOracle dbaCommented:
900 mails ?
is that all ?
lol, i have set up our oracle monitor to look at some 120+ databases. (I created 3 more today)
I only need 10 mails per database to beat that ... hehehe ... easy !
The good thing is that i only need need to look at the latest per category:
status, backup status, standby status, drc status, deadlocks, tablespace status, growth, etc, etc

The problem is that i still get ordinary mails
but i set those to auto -delete [ nasty grin ]

fixing the problem mails is off course a daily routine
0
Geert GOracle dbaCommented:
the setting of the local time zone, is only a indication of what time zone you are in in the world
nothing to do with mails or delays

i was at GMT-7 2 weeks ago, good weather in Dallas
i hate this Europe weather at GMT+1 atm, but since i live there, i'll have to go along with it
0
senadCommented:
Q 29914240 - This is the best comment I have seen in all the years I have been on E-E.
:KarlisB - Thank you !
:)
0
RDWilson2Commented:
@KarlisB,

The least you could do is to post the answer you found/figured out.  IMHO, just posting, in effect, "Problem solved." with nothing else comes off as rude and, on top of that, doesn't help anyone else who may be struggling with the same loss of sleep, etc., trying to solve the same problem.

@Geert,
You should have popped down to San Antonio . . . our weather is often even better than Dallas'. ;-)

As for the emails, that 900 is only what happened between about 06:00 and 08:00 . . . there's still a pile more that come in between 0800 and 17:00.  However, I, too, have figured out how to set rules and filters and even how to suppress the Read and Delivery notifications. ;-)
0
KarlisBAuthor Commented:
@RDWilson2:

just for you :)

read:
 ID: 29899196
and most importantly
 ID: 29914240

I already apologized, a solution for another question of mine, dropped the reason to get answer for this one.
I can say, that the problem lies in ADO and how ado interprets BYTEA field type.

Adding "ByteaAsLongVarBinary=1" to connection string should solve this issue as well.

Satisfied?
cheers.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.