can't update RedHat

I have several RHEL5 they are all regiterd with rhn, I could update before but for about a month, i can no longer update them, I get the error shown below. any idea why i can't update using "yum updater" or even install a software example snmp.


my repository if is:
/etc/yum.repos.d
rhel-debuginfo.repo

content is:
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release





Install      2 Package(s)         
Update      36 Package(s)         
Remove       2 Package(s)         

Total download size: 88 M
Is this ok [y/N]: y
Downloading Packages:

Error Downloading Packages:
  firefox-3.0.19-1.el5_5.i386: failed to retrieve getPackage/firefox-3.0.19-1.el5_5.i386.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  pango-1.14.9-8.el5.x86_64: failed to retrieve getPackage/pango-1.14.9-8.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
.
.
.
.
etc...

Open in new window

rawandnetAsked:
Who is Participating?
 
deepak_iqConnect With a Mentor Commented:
Hi,
Comment enabled in repo file.
Do yum list
Send me the output. Also,then try to install/upgrade any package.
If still getting error,send me the error output.
0
 
rawandnetAuthor Commented:
it is a very big list i will send you some of it.
it don't install any packages, and the error output for one package is:

pango-1.14.9-8.el5.x86_64: failed to retrieve getPackage/pango-1.14.9-8.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden

Loaded plugins: rhnplugin, security
Installed Packages
Deployment_Guide-en-US.noarch  5.2-11             installed                     
GConf2.i386                    2.14.0-9.el5       installed                     
GConf2.x86_64                  2.14.0-9.el5       installed                     
ImageMagick.i386               6.2.8.0-4.el5_1.1  installed                     
ImageMagick.x86_64             6.2.8.0-4.el5_1.1  installed                     
MAKEDEV.x86_64                 3.23-1.2           installed                     
MySQL-python.x86_64            1.2.1-1            installed                     
NetworkManager.i386            1:0.7.0-9.el5_4    installed                     
NetworkManager.x86_64          1:0.7.0-9.el5_4    installed                     
NetworkManager-glib.i386       1:0.7.0-9.el5_4    installed                     
NetworkManager-glib.x86_64     1:0.7.0-9.el5_4    installed                     
NetworkManager-gnome.x86_64    1:0.7.0-9.el5_4    installed                     
ORBit2.i386                    2.14.3-5.el5       installed                     
ORBit2.x86_64                  2.14.3-5.el5       installed                     
OpenIPMI.x86_64                2.0.16-5.el5_4.1   installed                     
OpenIPMI-libs.i386             2.0.16-5.el5_4.1   installed                     
OpenIPMI-libs.x86_64           2.0.16-5.el5_4.1   installed                     
OpenIPMI-tools.x86_64          2.0.16-5.el5_4.1   installed                     
PyQt.x86_64                    3.16-4             installed                     
PyXML.x86_64                   0.8.4-4.el5_4.2    installed                     
SDL.x86_64                     1.2.10-8.el5       installed                     
SysVinit.x86_64                2.86-15.el5        installed                     
Virtualization-en-US.noarch    5.2-11             installed                     
Xaw3d.x86_64                   1.5E-10.1          installed                     
a2ps.x86_64                    4.13b-57.2.el5     installed                     
acl.x86_64                     2.2.39-3.el5       installed                     
acpid.x86_64                   1.0.4-9.el5_4.2    installed                     
alacarte.noarch                0.10.0-1.fc6       installed                     
alchemist.x86_64               1.0.36-2.el5       installed                     
alsa-lib.i386                  1.0.17-1.el5       installed                     
alsa-lib.x86_64                1.0.17-1.el5       installed                     
alsa-utils.x86_64              1.0.17-1.el5       installed                     
amtu.x86_64                    1.0.6-1.el5        installed                     
anacron.x86_64                 2.3-45.el5         installed                     
antiword.i386                  0.37-3.el5.rf      installed                     
antlr.x86_64                   2.7.6-4jpp.2       installed                     
apr.i386                       1.2.7-11.el5_3.1   installed                     
apr.x86_64                     1.2.7-11.el5_3.1   installed                     
apr-util.i386                  1.2.7-7.el5_3.2    installed                     
apr-util.x86_64                1.2.7-7.el5_3.2    installed                     
aspell.i386                    12:0.60.3-7.1      installed                     
aspell.x86_64                  12:0.60.3-7.1      installed                     
aspell-en.x86_64               50:6.0-2.1         installed                     
at.x86_64                      3.1.8-82.fc6       installed                     
at-spi.i386                    1.7.11-3.el5       installed                     
at-spi.x86_64                  1.7.11-3.el5       installed                     
atk.i386                       1.12.2-1.fc6       installed                     
atk.x86_64                     1.12.2-1.fc6       installed                     
attr.x86_64                    2.4.32-1.1         installed                     
audiofile.i386                 1:0.2.6-5          installed                     
audiofile.x86_64               1:0.2.6-5          installed                     
--More--

.
.
.
.
zlib-devel.i386                1.2.3-3            installed                     
zlib-devel.x86_64              1.2.3-3            installed                     
zsh.x86_64                     4.2.6-3.el5        installed                     
Available Packages
Deployment_Guide-as-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-bn-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-de-DE.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-es-ES.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-fr-FR.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-gu-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-hi-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-it-IT.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-ja-JP.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-kn-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-ko-KR.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-ml-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-mr-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-or-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-pa-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-pt-BR.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-ru-RU.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-si-LK.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-ta-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-te-IN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-zh-CN.noarch  5.2-11             rhel-x86_64-server-5          
Deployment_Guide-zh-TW.noarch  5.2-11             rhel-x86_64-server-5          
ElectricFence.x86_64           2.2.2-20.2.2       rhel-x86_64-server-5          
GConf2-devel.i386              2.14.0-9.el5       rhel-x86_64-server-5          
GConf2-devel.x86_64            2.14.0-9.el5       rhel-x86_64-server-5          
ImageMagick-c++.i386           6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
ImageMagick-c++.x86_64         6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
ImageMagick-c++-devel.i386     6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
ImageMagick-c++-devel.x86_64   6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
ImageMagick-devel.i386         6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
ImageMagick-devel.x86_64       6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
ImageMagick-perl.x86_64        6.2.8.0-4.el5_1.1  rhel-x86_64-server-5          
NetworkManager.i386            1:0.7.0-10.el5     rhel-x86_64-server-5          
NetworkManager.x86_64          1:0.7.0-10.el5     rhel-x86_64-server-5          
NetworkManager-devel.i386      1:0.7.0-10.el5     rhel-x86_64-server-5          
NetworkManager-devel.x86_64    1:0.7.0-10.el5     rhel-x86_64-server-5          
NetworkManager-glib.i386       1:0.7.0-10.el5     rhel-x86_64-server-5          
NetworkManager-glib.x86_64     1:0.7.0-10.el5     rhel-x86_64-server-5          
.
.
.
.etc

xulrunner-devel.i386           1.9.0.19-1.el5_5   rhel-x86_64-server-5          
xulrunner-devel.x86_64         1.9.0.19-1.el5_5   rhel-x86_64-server-5          
xulrunner-devel-unstable.x86_64
                               1.9.0.19-1.el5_5   rhel-x86_64-server-5          
xz.x86_64                      4.999.9-0.3.beta.20091007git.el5
                                                  rhel-x86_64-server-5          
xz-devel.i386                  4.999.9-0.3.beta.20091007git.el5
                                                  rhel-x86_64-server-5          
xz-devel.x86_64                4.999.9-0.3.beta.20091007git.el5
                                                  rhel-x86_64-server-5          
xz-libs.i386                   4.999.9-0.3.beta.20091007git.el5
                                                  rhel-x86_64-server-5          
xz-libs.x86_64                 4.999.9-0.3.beta.20091007git.el5
                                                  rhel-x86_64-server-5          
xz-lzma-compat.x86_64          4.999.9-0.3.beta.20091007git.el5
                                                  rhel-x86_64-server-5          
yp-tools.x86_64                2.9-1.el5          rhel-x86_64-server-5          
ypserv.x86_64                  2.19-5.el5         rhel-x86_64-server-5          
yum.noarch                     3.2.22-26.el5      rhel-x86_64-server-5          
yum-NetworkManager-dispatcher.noarch
                               1.1.16-13.el5      rhel-x86_64-server-5          
yum-aliases.noarch             1.1.16-13.el5      rhel-x86_64-server-5          
yum-basearchonly.noarch        1.1.10-9.el5       rhel-x86_64-server-5          
yum-changelog.noarch           1.1.16-13.el5      rhel-x86_64-server-5          
yum-downloadonly.noarch        1.1.16-13.el5      rhel-x86_64-server-5          
yum-fastestmirror.noarch       1.1.16-13.el5      rhel-x86_64-server-5          
yum-filter-data.noarch         1.1.16-13.el5      rhel-x86_64-server-5          
yum-keys.noarch                1.1.16-13.el5      rhel-x86_64-server-5          
yum-kmod.noarch                1.1.16-13.el5      rhel-x86_64-server-5          
yum-list-data.noarch           1.1.16-13.el5      rhel-x86_64-server-5          
yum-protect-packages.noarch    1.1.16-13.el5      rhel-x86_64-server-5          
yum-protectbase.noarch         1.1.16-13.el5      rhel-x86_64-server-5          
yum-rhn-plugin.noarch          0.5.4-15.el5       rhel-x86_64-server-5          
yum-skip-broken.noarch         1.1.10-9.el5       rhel-x86_64-server-5          
yum-tmprepo.noarch             1.1.16-13.el5      rhel-x86_64-server-5          
yum-updateonboot.noarch        1.1.16-13.el5      rhel-x86_64-server-5          
yum-utils.noarch               1.1.16-13.el5      rhel-x86_64-server-5          
yum-verify.noarch              1.1.16-13.el5      rhel-x86_64-server-5          
yum-versionlock.noarch         1.1.16-13.el5      rhel-x86_64-server-5          
zsh-html.x86_64                4.2.6-3.el5        rhel-x86_64-server-5  

Open in new window

0
 
deepak_iqCommented:
can you share the ip details so that i can login ?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
deepak_iqCommented:
Also,what's the firewall status?
If enable,disable it and check.
0
 
rawandnetAuthor Commented:
it isn't publick IP address, it is private, and unfortunatly i don't have control on the external firewall system.
0
 
deepak_iqCommented:
What's the output of :
#getenforce
#uptime
#uname -a
0
 
deepak_iqCommented:
Try :
#setenforce 0
and then try to update any package.
0
 
rawandnetAuthor Commented:
[root@test3 yum.repos.d]# getenforce
Enforcing
[root@tserver yum.repos.d]# uptime
 14:53:39 up  4:17,  1 user,  load average: 0.00, 0.00, 0.00
[root@tserver yum.repos.d]# uname -a
Linux tserver 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@test3 yum.repos.d]#
0
 
rawandnetAuthor Commented:
I have another server:

[root@exch02 ~]# getenforce
Disabled
[root@exch02 ~]# uptime
 13:49:18 up 33 days, 20:18,  2 users,  load average: 0.00, 0.00, 0.00
[root@exch02 ~]# uname -a
Linux exch02 2.6.18-164.9.1.el5xen #1 SMP Wed Dec 9 03:35:42 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

0
 
rawandnetAuthor Commented:
error message from exch02 is:
.
.
.
  xorg-x11-server-Xorg-1.1.1-48.76.el5.x86_64: failed to retrieve getPackage/xorg-x11-server-Xorg-1.1.1-48.76.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  openssh-askpass-4.3p2-41.el5.x86_64: failed to retrieve getPackage/openssh-askpass-4.3p2-41.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  rhn-client-tools-0.4.20-33.el5_5.1.noarch: failed to retrieve getPackage/rhn-client-tools-0.4.20-33.el5_5.1.noarch.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  openldap-servers-2.3.43-12.el5.x86_64: failed to retrieve getPackage/openldap-servers-2.3.43-12.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  numactl-0.9.8-11.el5.x86_64: failed to retrieve getPackage/numactl-0.9.8-11.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  1:NetworkManager-0.7.0-10.el5.i386: failed to retrieve getPackage/NetworkManager-0.7.0-10.el5.i386.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  pciutils-devel-2.2.3-8.el5.x86_64: failed to retrieve getPackage/pciutils-devel-2.2.3-8.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  checkpolicy-1.33.1-6.el5.x86_64: failed to retrieve getPackage/checkpolicy-1.33.1-6.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  iproute-2.6.18-11.el5.x86_64: failed to retrieve getPackage/iproute-2.6.18-11.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  libvirt-0.6.3-33.el5.x86_64: failed to retrieve getPackage/libvirt-0.6.3-33.el5.x86_64.rpm from rhel-x86_64-server-vt-5
error was [Errno 14] HTTP Error 403: Forbidden
  openssh-clients-4.3p2-41.el5.x86_64: failed to retrieve getPackage/openssh-clients-4.3p2-41.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  14:libpcap-0.9.4-15.el5.x86_64: failed to retrieve getPackage/libpcap-0.9.4-15.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  filesystem-2.4.0-3.el5.x86_64: failed to retrieve getPackage/filesystem-2.4.0-3.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  1:readahead-1.3-8.el5.x86_64: failed to retrieve getPackage/readahead-1.3-8.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  libaio-0.3.106-5.x86_64: failed to retrieve getPackage/libaio-0.3.106-5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  glibc-2.5-49.x86_64: failed to retrieve getPackage/glibc-2.5-49.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  OpenIPMI-2.0.16-7.el5.x86_64: failed to retrieve getPackage/OpenIPMI-2.0.16-7.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  cyrus-sasl-devel-2.1.22-5.el5_4.3.i386: failed to retrieve getPackage/cyrus-sasl-devel-2.1.22-5.el5_4.3.i386.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden
  libXt-1.0.2-3.2.el5.x86_64: failed to retrieve getPackage/libXt-1.0.2-3.2.el5.x86_64.rpm from rhel-x86_64-server-5
error was [Errno 14] HTTP Error 403: Forbidden

Open in new window

0
 
deepak_iqCommented:
Is this after you made firewall disabled? (#setenforce 0)
0
 
deepak_iqCommented:
Hi,

That's what I am saying,make #setenforce 0, and then try,most probably it should work.

Deepak
0
 
rawandnetAuthor Commented:
yes, before forewall was enabled and setenforce was enabled too, i didn't have problem.  do you think that might be some thing to do with proxy server or from redhat them selves?

even if i disable firewall still i have same error.
0
 
deepak_iqCommented:
Is issue coming in exch02 also or it is working fine there? If issue is not coming there,then is the repo file in both servers same?Also,what other things are different in these two servers other than kernel.What's the OS (cat /etc/redhat-release),/etc/init.d/httpd status,ifconfig).

Also,do:
#ftp ftp.redhat.com
username:
password:
bye

If you are able to do this,then proxy is not a problem.
0
 
deepak_iqCommented:
After doing ftp to ftp.redhat.com,logout and then try upgrading any pkg.
0
 
rawandnetAuthor Commented:
I do have 4 servers they all stoped updating,
is it secure if i enter my rhn username and password under ftp? by the way my server isn't xwindows, it is command base.
after issueing ftp ftp.redhat.com I get the following:

331 This FTP server is anonymous only.

shall i enter username and password, is it secure?
0
 
deepak_iqCommented:
you don't enter your rhn u/n and p/w but your official userid (which is configured for ur project ) and ur password(which you enter for login) and immediatly after login you do bye(i.e.logout).
This is completely secure.
0
 
rawandnetAuthor Commented:
I have fedora and centos, i use it for practice, they do receive update?
0
 
rawandnetAuthor Commented:
by the way i managed to log in using anonymous  user with no password

Name (ftp.redhat.com:root): anonymous
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
227 Entering Passive Mode (209,132,183,61,254,203)
150 Here comes the directory listing.
lrwxrwxrwx    1 ftp      ftp             1 Dec 19 14:36 pub -> .
drwxr-xr-x   16 ftp      ftp          4096 Mar 19  2009 redhat
226 Directory send OK.
0
 
deepak_iqCommented:
Do you have team viewer installed in your system?
0
 
deepak_iqCommented:
Can you download team viewer 5, and run it in your desktop (from where you are accessing the remote servers).
0
 
deepak_iqCommented:
What happens if you do this?
#cd /etc/yum.repos.d
#yum clean all
#mv rhel-debuginfo.repo /tmp/rhel-debuginfo.repo
#vi my.repo
[rhel]
name=rhel
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/
gpgcheck=0
#yum list

Now upgrade any package.
0
 
rawandnetAuthor Commented:
what is team viewer 5?
0
 
deepak_iqCommented:
It is latest version of team viewer for desktop sharing.

You can download it from below link:
http://www.teamviewer.com/download/index.aspx

Also,did you tried  steps mentioned in my last post?
0
 
rawandnetAuthor Commented:
I tried didn't work.

if you have RHEL5, could you tell me how many repository files you have under /etc/yum.repos.d/. and tell me the content of the files?
0
 
deepak_iqConnect With a Mentor Commented:
In my server:

Red Hat Enterprise Linux Server release 5 (Tikanga)

ll /etc/yum.repos.d/rhel-debuginfo.repo

-rw-r--r--   1 root root   254 Feb  8  2007 rhel-debuginfo.repo

$ cat rhel-debuginfo.repo
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

This is one server, but where I am doing testing I am not having access to that one today but will have it by tomorrow 09:00 EST.

But why yum is not working in your system, that has made me thinking.

Usually it should not be creating this much problem. That's why I wanted to have a look at the server and  see to myself what other possibilites could be.
0
 
rawandnetAuthor Commented:
I don't think /etc/yum.repos.d/rhel-debuginfo.repo file is responsbile for update or package installation, that is what confusing me, under other destribution like fedora or Centos, all repository files are located under /etc/yum.repos.d/, with the mirror links to package server.
if you issue  (yum repolist all) you get some result showing that the rhel-debuginfo.repo is disabled by default (enabled=0), that is mean update has to be recieved from  (rhel-x86_64-server-5, rhel-x86_64-server-vt-5 and rhn-tools-rhel-x86_64-server-5), where are the repos file that tell to get update from rhel-x86....etc? see below


[root@intranet~]# yum repolist all
Loaded plugins: rhnplugin, security
repo id                        repo name                          status
rhel-debuginfo                 Red Hat Enterprise Linux 5Server - disabled
rhel-x86_64-server-5           Red Hat Enterprise Linux (v. 5 for enabled: 9,349
rhel-x86_64-server-vt-5        RHEL Virtualization (v. 5 for 64-b enabled:   301
rhn-tools-rhel-x86_64-server-5 Red Hat Network Tools for RHEL Ser enabled:   430
repolist: 10,080

Open in new window

0
 
rawandnetAuthor Commented:
thanks, the internet connection was the problem
0
 
deepak_iqCommented:
Hi,
Good that your problem is resolved but I din't understood this that how were you able to login to ftp.redhat.com .
I din't slept peacefully for two nights because of this and if your problem is really resolved then it's fine.
If you are getting any issues then do let me know.
Deepak
0
All Courses

From novice to tech pro — start learning today.