• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 905
  • Last Modified:

Network problem between Windows 2008 R2 and XP Pro

I have 6 computers
two running windows7 Pro
three running Windows XP Pro
one running Windows 2008 R2

All computers are on same subnet (172.24.10.x) and share one Gigabit Switch

Copying between Windows7 and Windows 2008 R2 is no problem (speed > 100 mb.)
Copying beetween Windows7 and Windows Xp is no problem (speed > 100 mb.)
Copying between Windows 2008 R2 and Windows XP is problem (speed < 1 mb.)
Most of the time I get The specfied network name are no longer aviable.
Pinging between all computers are Ok and without drop. (less than 1 ms all the time)

0
soffcec
Asked:
soffcec
  • 4
  • 4
  • 2
  • +1
7 Solutions
 
gurutcCommented:
Hi,

Is the 2008 computer configured as a Domain Controller?  I'm thinking it could be an issue with DNS.

Good Luck,
- gurutc
0
 
soffcecManagerAuthor Commented:
When copying I use IP adresses and not DNS names, and Yes then Server is Domain Controller.
I am trying to copy with Drag and drop,xcopy.exe,copy and robocopy.exe
0
 
gurutcCommented:
Hi,

Is the copy from the server to workstations initiated from the server or from the workstation client sessions?

Are the workstations members of the Domain?

Do any errors show in the System, DNS, or Application logs of the server or workstation?  

Is DNS Server service running on the server?

Are the workstations configured to use the server as their primary DNS server?  

Good Luck,
- gurutc
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
soffcecManagerAuthor Commented:
I am trying to pull content from the server I am not having problem pushing content from the server to the XP boxes. One XP is member of the domain and both Win7 boxes.

I found this error
The Terminal Server security layer detected an error in the protocol stream and has disconnected the client.
and no others.

I cannot see how this can be DNS problem. I have no problem adding and removing  the XP boxes to and from the domain.
0
 
gurutcCommented:
Hi,

Concerning the Terminal Server Error, the workstations aren't doing the copy from a TS Session are they?

Also, is that error on the server log or on a workstation log?

Good Luck,

- gurutc
0
 
Iain MacMillanIT ManagerCommented:
why use IP addresses, if these are domain systems, why not just use drive shares/mappings to copy files to and from the server??  Are you running DNS/DHCP on your server??  if so these systems should have it listed on the IPConfig settings (so they can see each other).

do your systems have Gigabit Ethernet NICs??  Again would allow you to transfer data more quickly if you used the full potential of the switch.  Something that might also help is to disable TCP Connection Offload protocol for IPv4 and IPv6 on the 2008 R2 server and perhaps Win 7 systems.  You will have to check the NIC advanced config to make these changes.  The issue you are having is known but solutions are thin on the ground, but I believe its related to SMB2 (part of R2), as older OS's such as XP, 2000 and 2003 only use SMB1 and are not SMB2 'aware'.

Robocopy will negate the overhead of using the Explorer UI, and give more accurate readings.  Fixing the ports on the switch for the server to 1000/Full will improve things, if you set the NIC to be 1000/Full too.
0
 
soffcecManagerAuthor Commented:
The error is on the server. I am not copying trough TS session.
0
 
gurutcCommented:
Hi,

You may be running into the connection limit of XP.  But if you add the workstations to the domain, and use unc/shares to support the connections it may negate this issue.

Just an idea.

- gurutc
0
 
soffcecManagerAuthor Commented:
No changes after I add the XP computers to the Domain
0
 
shaynegCommented:
Try to disable the SMB2 on the R2 server and monitor the speed.

To disable SMB2 :

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled

Check if there is any improvement.
0
 
shaynegCommented:
I've also had this resolved by going into the network adapter driver properties and DISABLE "TCP Connection Offload (IPv4)".  This is generally listed on the advanced tab of the network adapter.
This problem had me stumped for weeks but with the 2 methods I have posted I think you'll find either one will resolve your issue.
Shayne
0
 
Iain MacMillanIT ManagerCommented:
i think you will find that some info was already posted about disabling the TCP Connection Offload and SM2.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now